<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge"><script type="text/javascript">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</script>
<meta name="viewport" content="width=device-width, initial-scale=1">
<script>
        !function(n,e,o,r,i){if(!e){e=e||{},window.permutive=e,e.q=[],e.config=i||{},e.config.projectId=o,e.config.apiKey=r,e.config.environment=e.config.environment||"production";for(var t=["addon","identify","track","trigger","query","segment","segments","ready","on","once","user","consent"],c=0;c<t.length;c++){var f=t[c];e[f]=function(n){return function(){var o=Array.prototype.slice.call(arguments,0);e.q.push({functionName:n,arguments:o})}}(f)}}}(document,window.permutive,"f389d50a-32e0-478b-9d4b-2d4592528bea", "9502d019-da52-4a3c-be4a-f811a812c7af",{});
        permutive.addon("web", { page: {"user":{"latitude":null,"longitude":null,"city":null,"region":null,"state":null,"countryName":null,"zipcode":null,"postalCode":null,"stateCode":null,"countryCode":null,"userAgent":"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/15.0 Safari/605.1.15"},"title":"Kia Sportage PHEV pricing, Dodge Hornet PHEV revealed, inside the Mercedes EQE SUV: Today\u2019s Car News","description":"The Kia Sportage Plug-In Hybrid slots in at a lower price than the RAV4 Prime. We take a look inside the Mercedes-Benz EQE SUV. And the Dodge Hornet R/T attempts to give a sportier edge to plug-in hybrids. This and more, here at Green Car Reports. With a 30-mile electric range, all-wheel drive, and a performance-car flavor with plenty of muscle-car cues...","vehicle":{"tags":["news","today-in-car-news"]}} });
    </script>
<script async src="https://cdn.permutive.com/f389d50a-32e0-478b-9d4b-2d4592528bea-web.js"></script>
<script>
        dataLayer =  [{"tags":["news","today-in-car-news"]}] ;
                (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
        new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
        j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
        'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
        })(window, document, 'script', 'dataLayer', 'GTM-M73XHX4');
    </script>
<title>Kia Sportage PHEV pricing, Dodge Hornet PHEV revealed, inside the Mercedes EQE SUV: Today’s Car News</title>
<meta name="description" content="The Kia Sportage Plug-In Hybrid slots in at a lower price than the RAV4 Prime. We take a look inside the Mercedes-Benz EQE SUV. And the Dodge Hornet R/T attempts to give a sportier edge to plug-in hybrids. This and more, here at Green Car Reports. With a 30-mile electric range, all-wheel drive, and a performance-car flavor with plenty of muscle-car cues..."> <link rel="canonical" href="https://www.greencarreports.com/news/1136856_kia-sportage-phev-pricing-dodge-hornet-phev-revealed-inside-the-mercedes-eqe-suv-today-s-car-news">
<script type="application/ld+json">

{"@context":"https://schema.org","@type":"WebPage","@id":"https://www.greencarreports.com/news/1136856_kia-sportage-phev-pricing-dodge-hornet-phev-revealed-inside-the-mercedes-eqe-suv-today-s-car-news","url":"https://www.greencarreports.com/news/1136856_kia-sportage-phev-pricing-dodge-hornet-phev-revealed-inside-the-mercedes-eqe-suv-today-s-car-news","isPartOf":{"@type":"WebSite","@id":"https://www.greencarreports.com/#site"},"breadcrumb":{"@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://www.greencarreports.com/news","name":"News"}},{"@type":"ListItem","position":2,"item":{"@id":"https://www.greencarreports.com/news/today-in-car-news","name":"Today in Car News"}}]},"mainEntity":{"@type":"NewsArticle","@id":"https://www.greencarreports.com/news/1136856_kia-sportage-phev-pricing-dodge-hornet-phev-revealed-inside-the-mercedes-eqe-suv-today-s-car-news#this","url":"https://www.greencarreports.com/news/1136856_kia-sportage-phev-pricing-dodge-hornet-phev-revealed-inside-the-mercedes-eqe-suv-today-s-car-news","headline":"Kia Sportage PHEV pricing, Dodge Hornet PHEV revealed, inside the Mercedes EQE SUV: Today\u2019s Car News","datePublished":"2022-08-17T15:55:00+0000","dateModified":"2022-08-17T16:13:50+0000","description":"The Kia Sportage Plug-In Hybrid slots in at a lower price than the RAV4 Prime. We take a look inside the Mercedes-Benz EQE SUV. And the Dodge Hornet R/T attempts to give a sportier edge to plug-in hybrids. This and more, here at Green Car Reports. With a 30-mile electric range, all-wheel drive, and a performance-car flavor with plenty of muscle-car cues...","author":{"@type":"Person","name":"Bengt Halvorson","jobTitle":"Senior Editor","image":"https://images.hgmsites.net/tny/avatar-image-for-bengt_100544847_0.jpg","url":"https://www.greencarreports.com/writer/10001004_bengt-halvorson"},"publisher":{"@type":"Organization","@id":"https://www.greencarreports.com/#organization"},"articleSection":"Today in Car News","keywords":"Today in Car News","image":{"@type":"ImageObject","@id":"https://images.hgmsites.net/lrg/2023-dodge-hornet_100851621_l.jpg#this","url":"https://images.hgmsites.net/lrg/2023-dodge-hornet_100851621_l.jpg","caption":"2023 Dodge Hornet","description":"","width":1024,"height":573,"uploadDate":"2022-08-16T23:05:56+0000"}}}
</script>
<meta property="fb:pages" content="143669659002741">
<meta property="fb:app_id" content="80517230974">
<meta property="og:site_name" content="Green Car Reports">
<meta property="og:type" content="article">
<meta property="og:url" content="https://www.greencarreports.com/news/1136856_kia-sportage-phev-pricing-dodge-hornet-phev-revealed-inside-the-mercedes-eqe-suv-today-s-car-news">
<meta property="og:title" content="Kia Sportage PHEV pricing, Dodge Hornet PHEV revealed, inside the Mercedes EQE SUV: Today&rsquo;s Car News">
<meta property="og:description" content="The Kia Sportage Plug-In Hybrid slots in at a lower price than the RAV4 Prime. We take a look inside the Mercedes-Benz EQE SUV. And the Dodge Hornet R/T attempts to give a sportier edge to plug-in hybrids. This and more, here at Green Car Reports. With a 30-mile electric range, all-wheel drive, and a performance-car flavor with plenty of muscle-car cues...">
<meta property="og:image" content="https://images.hgmsites.net/hug/2023-dodge-hornet_100851621_h.jpg">
<meta property="twitter:card" content="summary_large_image">
<meta property="twitter:site" content="@GreenCarReports">
<meta property="twitter:creator" content="@ben_gt">
<meta property="twitter:title" content="Kia Sportage PHEV pricing, Dodge Hornet PHEV revealed, inside the Mercedes EQE SUV: Today&rsquo;s Car News">
<meta property="twitter:description" content="The Kia Sportage Plug-In Hybrid slots in at a lower price than the RAV4 Prime. We take a look inside the Mercedes-Benz EQE SUV. And the Dodge Hornet R/T attempts to give a sportier edge to plug-in hybrids. This and more, here at Green Car Reports. With a 30-mile electric range, all-wheel drive, and a performance-car flavor with plenty of muscle-car cues...">
<meta property="twitter:image" content="https://images.hgmsites.net/hug/2023-dodge-hornet_100851621_h.jpg">
<link href="https://feeds.highgearmedia.com/?sites=GreenCarReports" rel="alternate" type="application/rss+xml" title="Green Car Reports News">
<link href="/favicon.ico" rel="shortcut icon" type="image/x-icon">
<link href="/css/app.css?id=14dbff1cbbf0fecf5913" rel="stylesheet">
<style>
.rail-box.most-popular{padding:0;background:transparent}.rail-box.most-popular:after{content:"";display:table;clear:both}.rail-box.most-popular .item{height:204px;color:#fff;padding:4em 2em;box-sizing:border-box;position:relative;background-size:cover}@media (max-width:1023px){.rail-box.most-popular .item{width:33%;float:left}}@media (max-width:768px){.rail-box.most-popular .item{width:50%;float:left}}@media (max-width:414px){.rail-box.most-popular .item{width:100%}}.rail-box.most-popular .item .overlay{background-color:#000;opacity:.5}.rail-box.most-popular .item .info{display:flex;flex-direction:column;justify-content:space-between;box-sizing:border-box;position:absolute;width:86%;height:63%}@media (max-width:768px){.rail-box.most-popular .item .info{width:89%}}.rail-box.most-popular .item .info .comment,.rail-box.most-popular .item .info .date{text-transform:uppercase;font-size:12px;font-weight:400;line-height:1}.rail-box.most-popular .item .info .comment a,.rail-box.most-popular .item .info .title a{color:#fff}.rail-box.most-popular .item .info .title{font-size:18px;font-weight:600;line-height:1.25}@media (max-width:768px){.rail-box.most-popular .item .info .title{font-size:16.8px;font-weight:600;line-height:1.2}}

</style>
<script src="/js/head.js?id=ab654b229848d266608c"></script>
<script async src="https://confiant-integrations.global.ssl.fastly.net/cVCBi6sio0Kr78j5IZSJs1SQ8No/gpt_and_prebid/config.js"></script>
<script async src="https://js-sec.indexww.com/ht/p/184397-164216896053308.js"></script> <script async src="https://cdn.districtm.ca/merge/merge.116298.js"></script> <script async src="https://internetbrands-d.openx.net/w/1.0/jstag?nc=2922-GreenCarReports"></script> <script class="kxct" data-id="sh2lfhber" data-timing="async" data-version="3.0">
                    window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);
                    (function(){
                        function retrieve(n){
                            var k='kx'+'internetbrands_'+n, ls=(function(){
                                try {
                                    return window.localStorage;
                                } catch(e) {
                                    return null;
                                }
                            })();
                            if (ls) {
                                return ls[k] || '';
                            } else if (navigator.cookieEnabled) {
                                var m = document.cookie.match(k+'=([^;]*)');
                                return (m && unescape(m[1])) || '';
                            } else {
                                return '';
                            }
                        }
                        Krux.user = retrieve('user');
                        Krux.segments = retrieve('segs').split(',');
                    })();
                </script>
<script async src="https://cdn.krxd.net/controltag/sh2lfhber.js"></script>
<script>
    var gptadslots = [],
        googletag = googletag || {};
    googletag.cmd = googletag.cmd || [];
    (function(){
        var gads = document.createElement('script');
        var useSSL = 'https:' === document.location.protocol;
        gads.async = true;
        gads.type = 'text/javascript';
        gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
        var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(gads, node);
    })();
</script>
<script>
        hgmads.setAdUnitBasePath('/2922/greencarreports.tmus');
</script>
<script>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</script>
<script>
    !function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function()
        {q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];
        g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

    // initialize apstag and have apstag set bids on the googletag slots when they are returned to the page
    apstag.init({
        pubID:'3188',
        adServer:'googletag',
        bidTimeout:2e3
    });


</script>
<script>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</script>
<script type="text/javascript" src="https://gdpr.internetbrands.com/v2/ibccm.min.js"></script>
</head>
<body>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M73XHX4"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<header>
<div class="nav-container">
<nav>
<div class="mobile-menu"><a class="toggle-device-nav" href="#"></a></div>
<div class="logo"><a href="/" title="Green Car Reports"></a></div>
<div class="nav-items">
<ul>
<li><a class="nav-link" data-menu="news" href="/news">News</a></li>
<li><a class="nav-link" href="/news/first-drives">First Drives</a></li>
<li><a class="nav-link" href="/news/electric-cars">Electric Cars</a></li>
<li><a class="nav-link" href="/news/hybrid-cars">Hybrids</a></li>
<li><a class="nav-link" href="/news/buying-guides">Guides</a></li>
<li><a class="nav-link" href="/news/green-life">Green Life</a></li>
<li class="desktop-newsletter"><a class="nav-link-btn" data-menu="newsletter" href="javascript:void(0)" title="Newsletter Signup"><img src="/images/envelope.svg" />newsletter</a></li>
</ul>
</div>
<div class="search">
<a class="nav-link-search" data-menu="search" href="javascript:void(0)" title="Search"></a>
</div>
</nav>
</div>
<div class="adv-spacer-top-wraper">
<div class="adv-spacer top ">
<div id="ad-top"></div>
</div>
</div>
<div id="breadcrumbs">
<a href="/">Home</a>
<span> / </span>
 <a href="/news">News</a>
<span> / </span>
<a href="/news/today-in-car-news">Today in Car News</a>
</div>
</header>
<div id="main">
<div class="hidden-slot" id="ad-a-1"></div>
<script>
        window.disqus_domain = 'https://www.greencarreports.com';
        window.disqus_shortname = 'greencarreports';
        window.disqus_key = 'NCF9QGiigz0WoG2RAdgNHu0h4WSUWoLkzI4RZJ6UisUx951obo7XTL1BigknDT9P';
    </script>
<script>
            var xpath = 'insertAfter(p[3])',
                sizes = [[300, 250]],
                zone = 'newsarticle',
                pos = 'm-center',
                sizeW = '300',
                sizeH = '250',
                adClasses = 'adv-spacer',
                adSizeMap = [],
                label = '',
                throttleInterval = 2;

            var targets = [];
            targets.push( {'kw': ["m-center"] });
            targets.push( {'sz': ["300x250"] });
                                        targets.push( {'tags': ["news,today-in-car-news"]} );
                                                    targets.push( {'page': ["blog-post-article"]});
                targets.push( {'variation': window.hgm_variation || ''});

                                                adSizeMap.push({'viewport':  [0,0] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [1280,800] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [600,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [800,600] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [320,300] ,'map': [[300,250]]  }) ;
                            
            var callbackFunctions = false;
            
            var wayPointConfig = false;
                        hgmads.addDynamicSlot(xpath, sizes, targets, zone, pos, sizeW, sizeH, adClasses, adSizeMap, label, callbackFunctions, throttleInterval, wayPointConfig);
        </script>
<script>
            var xpath = 'appendTo(.adv-container .adv-spacer-top)',
                sizes = [[300, 250]],
                zone = 'newsarticle',
                pos = 'd-media-pop-up-top_m-media-pop-up-bottom',
                sizeW = '300',
                sizeH = '250',
                adClasses = '',
                adSizeMap = [],
                label = '',
                throttleInterval = 2;

            var targets = [];
            targets.push( {'kw': ["d-media-pop-up-top_m-media-pop-up-bottom"] });
            targets.push( {'sz': ["300x250"] });
                                        targets.push( {'tags': ["news,today-in-car-news"]} );
                                                    targets.push( {'page': ["blog-post-article"]});
                targets.push( {'variation': window.hgm_variation || ''});

                                                adSizeMap.push({'viewport':  [0,0] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [1280,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [1280, 600] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [600,800] ,'map': [[320,50]]  }) ;
                                    adSizeMap.push({'viewport':  [800,600] ,'map': [[728,90]]  }) ;
                                    adSizeMap.push({'viewport':  [320,300] ,'map': [[320,50]]  }) ;
                            
            var callbackFunctions = false;
            
            var wayPointConfig = false;
                        hgmads.addDynamicSlot(xpath, sizes, targets, zone, pos, sizeW, sizeH, adClasses, adSizeMap, label, callbackFunctions, throttleInterval, wayPointConfig);
        </script>
<script>
            var xpath = 'appendTo(.adv-container .adv-spacer-bottom)',
                sizes = [[300, 250]],
                zone = 'newsarticle',
                pos = 'd-media-pop-up-bottom_m-media-pop-up-bottom',
                sizeW = '300',
                sizeH = '250',
                adClasses = '',
                adSizeMap = [],
                label = '',
                throttleInterval = 2;

            var targets = [];
            targets.push( {'kw': ["d-media-pop-up-bottom_m-media-pop-up-bottom"] });
            targets.push( {'sz': ["300x250"] });
                                        targets.push( {'tags': ["news,today-in-car-news"]} );
                                                    targets.push( {'page': ["blog-post-article"]});
                targets.push( {'variation': window.hgm_variation || ''});

                                                adSizeMap.push({'viewport':  [0,0] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [1280,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [1280, 600] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [600,800] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [800,600] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [320,300] ,'map': []  }) ;
                            
            var callbackFunctions = false;
            
            var wayPointConfig = false;
                        hgmads.addDynamicSlot(xpath, sizes, targets, zone, pos, sizeW, sizeH, adClasses, adSizeMap, label, callbackFunctions, throttleInterval, wayPointConfig);
        </script>
<script>
            var xpath = 'appendTo(.video-popup-sidebar .adv-spacer-top)',
                sizes = [[300, 250]],
                zone = 'newsarticle',
                pos = 'd-media-pop-up-top_m-media-pop-up-bottom',
                sizeW = '300',
                sizeH = '250',
                adClasses = '',
                adSizeMap = [],
                label = '',
                throttleInterval = 2;

            var targets = [];
            targets.push( {'kw': ["d-media-pop-up-top_m-media-pop-up-bottom"] });
            targets.push( {'sz': ["300x250"] });
                                        targets.push( {'tags': ["news,today-in-car-news"]} );
                                                    targets.push( {'page': ["blog-post-article"]});
                targets.push( {'variation': window.hgm_variation || ''});

                                                adSizeMap.push({'viewport':  [0,0] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [1280,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [600,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [800,600] ,'map': [[320,50]]  }) ;
                                    adSizeMap.push({'viewport':  [320,300] ,'map': [[320,50]]  }) ;
                            
            var callbackFunctions = false;
            
            var wayPointConfig = false;
                        hgmads.addDynamicSlot(xpath, sizes, targets, zone, pos, sizeW, sizeH, adClasses, adSizeMap, label, callbackFunctions, throttleInterval, wayPointConfig);
        </script>
<script>
            var xpath = 'appendTo(.video-popup-sidebar .adv-spacer-bottom)',
                sizes = [[300, 250]],
                zone = 'newsarticle',
                pos = 'd-media-pop-up-bottom_m-media-pop-up-bottom',
                sizeW = '300',
                sizeH = '250',
                adClasses = '',
                adSizeMap = [],
                label = '',
                throttleInterval = 2;

            var targets = [];
            targets.push( {'kw': ["d-media-pop-up-bottom_m-media-pop-up-bottom"] });
            targets.push( {'sz': ["300x250"] });
                                        targets.push( {'tags': ["news,today-in-car-news"]} );
                                                    targets.push( {'page': ["blog-post-article"]});
                targets.push( {'variation': window.hgm_variation || ''});

                                                adSizeMap.push({'viewport':  [0,0] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [1280,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [600,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [800,600] ,'map': [[320,50]]  }) ;
                                    adSizeMap.push({'viewport':  [320,300] ,'map': [[320,50]]  }) ;
                            
            var callbackFunctions = false;
            
            var wayPointConfig = false;
                        hgmads.addDynamicSlot(xpath, sizes, targets, zone, pos, sizeW, sizeH, adClasses, adSizeMap, label, callbackFunctions, throttleInterval, wayPointConfig);
        </script>
<div class="article-block" data-id="1136856" data-url="/news/1136856_kia-sportage-phev-pricing-dodge-hornet-phev-revealed-inside-the-mercedes-eqe-suv-today-s-car-news" data-title="Kia Sportage PHEV pricing, Dodge Hornet PHEV revealed, inside the Mercedes EQE SUV: Today’s Car News" data-publishdate="August 17, 2022" data-next-id="1136840" data-infinite-scroll="false" data-min-comments="1">
<section class="hero-wrap-parallax parallax-window  " data-image-src-h="https://images.hgmsites.net/hug/2023-dodge-hornet_100851621_h.jpg" data-image-src-l="https://images.hgmsites.net/lrg/2023-dodge-hornet_100851621_l.jpg" data-image-src-m="https://images.hgmsites.net/med/2023-dodge-hornet_100851621_m.jpg" data-image-src-s="https://images.hgmsites.net/sml/2023-dodge-hornet_100851621_s.jpg">
<div class="overlay"></div>
<div class="hero-inner-wrap">
<div class="left-col">
<header class="title-wrap">
<h1 class="article-title"><span>Kia Sportage PHEV pricing, Dodge Hornet PHEV revealed, inside the Mercedes EQE SUV: Today’s Car News</span></h1>
<div class="portrait-wrapper">
<a href="/writer/10001004_bengt-halvorson" class="portrait">
<img src="https://images.hgmsites.net/sml/avatar-image-for-bengt_100544847_s.jpg" alt="Bengt Halvorson">
</a>
</div>
<a href="/writer/10001004_bengt-halvorson" rel="author" class="by-line">
Bengt Halvorson
</a>
<time datetime="2022-08-17T15:55:00+0000">
August 17, 2022
</time>
<a href="javascript:void(0)" class="comments-link">
<i class="icon fas fa-comments"></i><span>Comment Now!</span>
</a>
</header>
</div>
<div class="right-col"></div>
</div>
</section>
<div class="article-wrap">
<div class="left-col">
<header class="title-wrap">
<h1 class="article-title"><span>Kia Sportage PHEV pricing, Dodge Hornet PHEV revealed, inside the Mercedes EQE SUV: Today’s Car News</span></h1>
<div class="portrait-wrapper">
<a href="/writer/10001004_bengt-halvorson" class="portrait">
<img src="https://images.hgmsites.net/sml/avatar-image-for-bengt_100544847_s.jpg" alt="Bengt Halvorson">
</a>
</div>
<a href="/writer/10001004_bengt-halvorson" rel="author" class="by-line">
Bengt Halvorson
</a>
<time datetime="2022-08-17T15:55:00+0000">
August 17, 2022
</time>
<a href="javascript:void(0)" class="comments-link">
<i class="icon fas fa-comments"></i><span>Comment Now!</span>
</a>
</header>
<article class="content article-style  gcr-article ">
<section class="article-body">
 <p dir="ltr">The Kia Sportage Plug-In Hybrid slots in at a lower price than the RAV4 Prime. We take a look inside the Mercedes-Benz EQE SUV. And the Dodge Hornet R/T attempts to give a sportier edge to plug-in hybrids. This and more, here at <em>Green Car Reports.</em> </p>
<p dir="ltr"><strong><strong></strong></strong>With a 30-mile electric range, all-wheel drive, and a performance-car flavor with plenty of muscle-car cues from the larger Charger—and a crossover style that at some angles harks to hatchback compact cars—the <a href="https://www.greencarreports.com/news/1136846_preview-2023-dodge-hornet-plug-in-hybrid-30-miles-range-performance" target="_blank">2023 Dodge Hornet R/T plug-in hybrid</a> plays a lot of different angles all at once. </p><div class="nativo-article-slot"></div>
<p dir="ltr"><strong><strong></strong></strong>Mercedes-Benz has provided <a href="https://www.greencarreports.com/news/1136845_us-built-mercedes-eqe-suv-teased-with-interior-photos-due-for-october-debut" target="_blank">a look inside its upcoming EQE SUV</a>, before an October reveal for the exterior and the full vehicle. The five-seat SUV will be built in the U.S., and it’s both a counterpart to the Model S–sized EQE sedan and a smaller sibling to the seven-seat EQS SUV set to arrive later this year.</p>
<p dir="ltr"><strong><strong></strong></strong>And pricing is out for the <a href="https://www.greencarreports.com/news/1136855_2023-kia-sportage-plug-in-hybrid-price-range" target="_blank">2023 Kia Sportage Plug-In Hybrid</a>—just in time, it seems, for the model to fall off the list of qualifying vehicles for the EV tax credit. That said, the Sportage PHEV costs a little less than the RAV4 Prime but a little more than the Ford Escape and Hyundai Tucson PHEVs.</p><div class="ac-floating-trigger"></div>
<p>_______________________________________</p>
<p><em>Follow Green Car Reports on </em><a href="https://www.facebook.com/GreenCarReports" target="_blank"><em>Facebook</em></a><em> and </em><a href="https://twitter.com/greencarreports" target="_blank"><em>Twitter</em></a></p>
</section>
<section class="footer">
</section>
<div class="video-player-ac hidden-player" data-player-id="001w000001RrzqE_1691">
<div class="player-wrapper">
<script src="https://player.anyclip.com/anyclip-widget/lre-widget/prod/v1/src/lre.js" data-ar="16:9" pubname="internetbrandscom" widgetname="001w000001RrzqE_1691">
            </script>
<script>
   window.addEventListener('message',  event => {
        if (event.data) {
            if (typeof event.data === 'string') {
                if (event.data.indexOf('lre:playerReady://') === 0) {
                    var target = document.querySelector('.video-player-ac'),
                        customEvent = new CustomEvent('tcc:acPlayerReady'),
 playerId = '001w000001RrzqE_1691',
 widget = window.anyclip.getWidget(playerId);
 target.setAttribute('data-loaded-player-id', playerId); 
                    widget.floatingModeToggle(false);
                    window.dispatchEvent(customEvent);                }
            }
        }
    });
</script>
</div>
</div>
<div class="article-tags">
<h3>Tags:</h3>
<a href="/news/news">News</a>
<a href="/news/today-in-car-news">Today in Car News</a>
</div>
<div class="article-contribute">
<h3>Contribute:</h3>
<ul>
<li><a href="/aboutus#contact-us">
<i class="icon fas fa-lightbulb"></i> Send us a tip
</a>
<li><a href="javascript:void(0)" class="comments-link">
<i class="icon fas fa-comments"></i><span>Comment</span>
</a>
<li><a href="/aboutus#contact-us">
<i class="icon fas fa-pencil-alt"></i> Contact the editor
</a>
</ul>
</div>
<div class="adv-spacer">
<div id="ad-a-2"></div>
</div>
<div style="margin-top: 2em" class="footer-block">
<div class="share-this">
<h3>Share This Article:</h3>
<a class="social-btn fab fa-facebook-f facebook" href="javascript:void(0)" title="Share this article on Facebook" onclick="window.open('https://www.facebook.com/sharer.php?t=Kia%20Sportage%20PHEV%20pricing%2C%20Dodge%20Hornet%20PHEV%20revealed%2C%20inside%20the%20Mercedes%20EQE%20SUV%3A%20Today%E2%80%99s%20Car%20News&u=https%3A%2F%2Fwww.greencarreports.com%2Fnews%2F1136856_kia-sportage-phev-pricing-dodge-hornet-phev-revealed-inside-the-mercedes-eqe-suv-today-s-car-news', 'social', 'toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=700, height=300'); hgm.socialShare('Facebook', 'https://www.greencarreports.com/news/1136856_kia-sportage-phev-pricing-dodge-hornet-phev-revealed-inside-the-mercedes-eqe-suv-today-s-car-news');">
</a>
<a class="social-btn fab fa-twitter twitter" href="javascript:void(0)" title="Tweet this article" onclick="window.open('https://twitter.com/intent/tweet?text=Kia%20Sportage%20PHEV%20pricing%2C%20Dodge%20Hornet%20PHEV%20revealed%2C%20inside%20the%20Mercedes%20EQE%20SUV%3A%20Today%E2%80%99s%20Car%20News&url=https%3A%2F%2Fwww.greencarreports.com%2Fnews%2F1136856_kia-sportage-phev-pricing-dodge-hornet-phev-revealed-inside-the-mercedes-eqe-suv-today-s-car-news', 'social', 'toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=700, height=300'); hgm.socialShare('Twitter', 'https://www.greencarreports.com/news/1136856_kia-sportage-phev-pricing-dodge-hornet-phev-revealed-inside-the-mercedes-eqe-suv-today-s-car-news');">
</a>
<a class="social-btn fab fa-linkedin-in linkedin" href="javascript:void(0)" title="Share this article on LinkedIn" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true?title=Kia%20Sportage%20PHEV%20pricing%2C%20Dodge%20Hornet%20PHEV%20revealed%2C%20inside%20the%20Mercedes%20EQE%20SUV%3A%20Today%E2%80%99s%20Car%20News&url=https%3A%2F%2Fwww.greencarreports.com%2Fnews%2F1136856_kia-sportage-phev-pricing-dodge-hornet-phev-revealed-inside-the-mercedes-eqe-suv-today-s-car-news&source=GreenCarReports.com', 'social', 'toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=700, height=300'); hgm.socialShare('LinkedIn', 'https://www.greencarreports.com/news/1136856_kia-sportage-phev-pricing-dodge-hornet-phev-revealed-inside-the-mercedes-eqe-suv-today-s-car-news');">
</a>
<a class="social-btn fab fa-flipboard flipboard" href="javascript:void(0)" title="Flip this article" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?text=Kia%20Sportage%20PHEV%20pricing%2C%20Dodge%20Hornet%20PHEV%20revealed%2C%20inside%20the%20Mercedes%20EQE%20SUV%3A%20Today%E2%80%99s%20Car%20News&url=https%3A%2F%2Fwww.greencarreports.com%2Fnews%2F1136856_kia-sportage-phev-pricing-dodge-hornet-phev-revealed-inside-the-mercedes-eqe-suv-today-s-car-news', 'social', 'toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=700, height=300'); hgm.socialShare('Flipboard', 'https://www.greencarreports.com/news/1136856_kia-sportage-phev-pricing-dodge-hornet-phev-revealed-inside-the-mercedes-eqe-suv-today-s-car-news');">
</a>
<a class="social-btn far fa-envelope email" href="javascript:void(0)" title="Email this article" onclick="window.open('mailto:?subject=Kia%20Sportage%20PHEV%20pricing%2C%20Dodge%20Hornet%20PHEV%20revealed%2C%20inside%20the%20Mercedes%20EQE%20SUV%3A%20Today%E2%80%99s%20Car%20News&body=Hi%20There%2C%0A%0AI%20thought%20you%20might%20like%20this%20article%3A%0A%0A%20%20%20%20Kia%20Sportage%20PHEV%20pricing%2C%20Dodge%20Hornet%20PHEV%20revealed%2C%20inside%20the%20Mercedes%20EQE%20SUV%3A%20Today%E2%80%99s%20Car%20News%0A%20%20%20%20https%3A%2F%2Fwww.greencarreports.com%2Fnews%2F1136856_kia-sportage-phev-pricing-dodge-hornet-phev-revealed-inside-the-mercedes-eqe-suv-today-s-car-news%0A%0ACheers%21%0A', 'social', 'toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=700, height=300'); hgm.socialShare('Email', 'https://www.greencarreports.com/news/1136856_kia-sportage-phev-pricing-dodge-hornet-phev-revealed-inside-the-mercedes-eqe-suv-today-s-car-news');">
</a>
</div>
</div>
<div class="footer-block">
<div id="article-author">
<h3>connect with the editor:</h3>
<a href="/writer/10001004_bengt-halvorson">
<img src="https://images.hgmsites.net/sml/avatar-image-for-bengt_100544847_s.jpg" class="portrait" alt="Bengt Halvorson">
</a>
<a href="/writer/10001004_bengt-halvorson" rel="author" class="by-line">
Bengt Halvorson - Senior Editor
</a>
<a href="https://twitter.com/ben_gt" onclick="hgm.socialFollow('Twitter', 'ben_gt'); return true;" target="_blank" title="Bengt Halvorson’s Twitter profile">
<img class="social" src="/images/twitter.png" alt="Twitter">
</a>
</div>
<div class="follow-us">
<h3>Follow Us Today:</h3>
<a class="social-btn" title="Like us on Facebook" href="https://www.facebook.com/GreenCarReports" target="_blank" onclick="hgm.socialFollow('Facebook', 'GreenCarReports'); return true;">
<span class="fab fa-facebook-f"></span>
</a>
<a class="social-btn" title="Follow us on Twitter" href="https://www.twitter.com/GreenCarReports" target="_blank" onclick="hgm.socialFollow('Twitter', 'GreenCarReports'); return true;">
<span class="fab fa-twitter"></span>
</a>
<a class="social-btn" title="Follow us on Instagram" href="https://www.instagram.com/greencarreports/" target="_blank" onclick="hgm.socialFollow('Instagram', 'greencarreports'); return true;">
<span class="fab fa-instagram"></span>
</a>
<a class="social-btn" title="Subscribe to our YouTube channel" href="https://www.youtube.com/user/greencarreports" target="_blank" onclick="hgm.socialFollow('YouTube', 'greencarreports'); return true;">
<span class="fab fa-youtube"></span>
</a>
<a class="social-btn" title="Follow us on Filpboard" href="https://www.flipboard.com/@GreenCarReports" target="_blank" onclick="hgm.socialFollow('Flipboard', 'GreenCarReports'); return true;">
<span class="fab fa-flipboard"></span>
</a>
</div>
</div>
<div class="newsletter-signup  newsletter-signup-wide ">
<h3>Green Car Reports Newsletter</h3>
<p>
Sign up to get the latest green car and environmental news, delivered to your inbox daily!
</p>
<form data-pos="wide" class="newsletter-signup-form" action="/api/newsletter-subscribe" method="post">
<input class="newsletter-email" type="email" name="email" placeholder="Enter your email address…" required data-msg="Email is required">
<button class="red-button newsletter-signup-btn" type="submit">Sign Up Today!</button>
<div class="response_message"></div>
</form>
<p>
I agree to receive emails from Green Car Reports. I understand that I can unsubscribe at any time. <a href="https://www.internetbrands.com/privacy/privacy-main.html" target="_blank">Privacy Policy.</a>
</p>
</div>
<div id="disqus_thread"></div>
</article>
<div class="two-column">
<div class="content-wrap">
<script>
            var xpath = 'li[2]',
                sizes = [[300, 250]],
                zone = 'newsarticle',
                pos = 'm-center',
                sizeW = '300',
                sizeH = '250',
                adClasses = 'adv-spacer',
                adSizeMap = [],
                label = '',
                throttleInterval = 2;

            var targets = [];
            targets.push( {'kw': ["m-center"] });
            targets.push( {'sz': ["300x250"] });
                                        targets.push( {'tags': ["news,today-in-car-news"]} );
                                                    targets.push( {'page': ["blog-post-article"]});
                targets.push( {'variation': window.hgm_variation || ''});

                                                adSizeMap.push({'viewport':  [0,0] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [1280,800] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [600,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [800,600] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [320,300] ,'map': [[300,250]]  }) ;
                            
            var callbackFunctions = false;
            
            var wayPointConfig = false;
                            wayPointConfig = {fetchMarginPercent: '200%', renderMarginPercent: '150%'};
                        hgmads.addDynamicSlot(xpath, sizes, targets, zone, pos, sizeW, sizeH, adClasses, adSizeMap, label, callbackFunctions, throttleInterval, wayPointConfig);
        </script>
<script>
            var xpath = 'li[7]',
                sizes = [[300, 250]],
                zone = 'newsarticle',
                pos = 'm-center',
                sizeW = '300',
                sizeH = '250',
                adClasses = 'adv-spacer',
                adSizeMap = [],
                label = '',
                throttleInterval = 2;

            var targets = [];
            targets.push( {'kw': ["m-center"] });
            targets.push( {'sz': ["300x250"] });
                                        targets.push( {'tags': ["news,today-in-car-news"]} );
                                                    targets.push( {'page': ["blog-post-article"]});
                targets.push( {'variation': window.hgm_variation || ''});

                                                adSizeMap.push({'viewport':  [0,0] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [1280,800] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [600,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [800,600] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [320,300] ,'map': [[300,250]]  }) ;
                            
            var callbackFunctions = false;
            
            var wayPointConfig = false;
                            wayPointConfig = {fetchMarginPercent: '200%', renderMarginPercent: '150%'};
                        hgmads.addDynamicSlot(xpath, sizes, targets, zone, pos, sizeW, sizeH, adClasses, adSizeMap, label, callbackFunctions, throttleInterval, wayPointConfig);
        </script>
<script>
            var xpath = 'li[12]',
                sizes = [[300, 250]],
                zone = 'newsarticle',
                pos = 'm-center',
                sizeW = '300',
                sizeH = '250',
                adClasses = 'adv-spacer',
                adSizeMap = [],
                label = '',
                throttleInterval = 2;

            var targets = [];
            targets.push( {'kw': ["m-center"] });
            targets.push( {'sz': ["300x250"] });
                                        targets.push( {'tags': ["news,today-in-car-news"]} );
                                                    targets.push( {'page': ["blog-post-article"]});
                targets.push( {'variation': window.hgm_variation || ''});

                                                adSizeMap.push({'viewport':  [0,0] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [1280,800] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [600,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [800,600] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [320,300] ,'map': [[300,250]]  }) ;
                            
            var callbackFunctions = false;
            
            var wayPointConfig = false;
                            wayPointConfig = {fetchMarginPercent: '200%', renderMarginPercent: '150%'};
                        hgmads.addDynamicSlot(xpath, sizes, targets, zone, pos, sizeW, sizeH, adClasses, adSizeMap, label, callbackFunctions, throttleInterval, wayPointConfig);
        </script>
<script>
            var xpath = 'li[18]',
                sizes = [[300, 250]],
                zone = 'newsarticle',
                pos = 'm-center',
                sizeW = '300',
                sizeH = '250',
                adClasses = 'adv-spacer',
                adSizeMap = [],
                label = '',
                throttleInterval = 2;

            var targets = [];
            targets.push( {'kw': ["m-center"] });
            targets.push( {'sz': ["300x250"] });
                                        targets.push( {'tags': ["news,today-in-car-news"]} );
                                                    targets.push( {'page': ["blog-post-article"]});
                targets.push( {'variation': window.hgm_variation || ''});

                                                adSizeMap.push({'viewport':  [0,0] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [1280,800] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [600,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [800,600] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [320,300] ,'map': [[300,250]]  }) ;
                            
            var callbackFunctions = false;
            
            var wayPointConfig = false;
                            wayPointConfig = {fetchMarginPercent: '200%', renderMarginPercent: '150%'};
                        hgmads.addDynamicSlot(xpath, sizes, targets, zone, pos, sizeW, sizeH, adClasses, adSizeMap, label, callbackFunctions, throttleInterval, wayPointConfig);
        </script>
<div class="article-list">
<ul class="items-list">
<li class="large">
<a class="img-wrap" href="/news/1136855_2023-kia-sportage-plug-in-hybrid-price-range">
<img data-id="100828347" src="https://cimg3.ibsrv.net/ibimg/hgm/1350x759-1/100/828/2023-kia-sportage_100828347.jpg" alt="2023 Kia Sportage PHEV" srcset="https://cimg3.ibsrv.net/ibimg/hgm/1350x759-1/100/828/2023-kia-sportage_100828347.jpg 1350w, https://cimg3.ibsrv.net/ibimg/hgm/960x540-1/100/828/2023-kia-sportage_100828347.jpg 960w, https://cimg3.ibsrv.net/ibimg/hgm/880x495-1/100/828/2023-kia-sportage_100828347.jpg 880w, https://cimg3.ibsrv.net/ibimg/hgm/800x450-1/100/828/2023-kia-sportage_100828347.jpg 800w, https://cimg3.ibsrv.net/ibimg/hgm/440x248-1/100/828/2023-kia-sportage_100828347.jpg 440w" sizes="(min-width: 1024px) 960px, (max-width: 440px) 440px, calc(100vw - 2rem)">
<div class="overlay"></div>
</a>
<div class="item-text">
<div class="shift">
<div class="title-wrap"><a class="title" href="/news/1136855_2023-kia-sportage-plug-in-hybrid-price-range">2023 Kia Sportage Plug-In Hybrid priced just under $40,000, goes 34 electric miles</a></div>
<a href="/writer/10001004_bengt-halvorson" rel="author" class="by-line">Bengt Halvorson</a>
 <time datetime="2022-08-17T15:45:00+0000">August 17, 2022</time>
</div>
<p>The Sportage PHEV will be available in all 50 states but is unlikely to be eligible for the reconstituted EV tax credit.</p>
</div>
</li>
<li class="nativo-slot" id="nativo-1" data-slot-id="1"></li>
<li>
<a class="img-wrap" href="/news/1136845_us-built-mercedes-eqe-suv-teased-with-interior-photos-due-for-october-debut">
<img class="lazy" data-id="100851555" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg3.ibsrv.net/ibimg/hgm/1920x1080-1/100/851/2023-mercedes-benz-eqe-suv_100851555.jpg" alt="2023 Mercedes-Benz EQE SUV" data-srcset="https://cimg3.ibsrv.net/ibimg/hgm/1600x900-1/100/851/2023-mercedes-benz-eqe-suv_100851555.jpg 1600w, https://cimg3.ibsrv.net/ibimg/hgm/880x495-1/100/851/2023-mercedes-benz-eqe-suv_100851555.jpg 880w, https://cimg3.ibsrv.net/ibimg/hgm/800x450-1/100/851/2023-mercedes-benz-eqe-suv_100851555.jpg 800w, https://cimg3.ibsrv.net/ibimg/hgm/626x352-1/100/851/2023-mercedes-benz-eqe-suv_100851555.jpg 626w, https://cimg3.ibsrv.net/ibimg/hgm/440x248-1/100/851/2023-mercedes-benz-eqe-suv_100851555.jpg 440w, https://cimg3.ibsrv.net/ibimg/hgm/313x176-1/100/851/2023-mercedes-benz-eqe-suv_100851555.jpg 313w" sizes="(min-width: 1024px) 313px, (max-width: 440px) 440px, calc(100vw - 2rem)">
</a>
<div class="item-text">
<a class="title" href="/news/1136845_us-built-mercedes-eqe-suv-teased-with-interior-photos-due-for-october-debut">US-built Mercedes EQE SUV teased with interior photos, due for October debut</a>
<p>The EQE SUV will be a taller counterpart to the Tesla Model S–sized EQE sedan that's also supposed to arrive in the U.S. later this year.</p>
<a href="/writer/10044742_stephen-edelstein" rel="author" class="by-line">Stephen Edelstein</a>
<time datetime="2022-08-17T12:00:00+0000">August 17, 2022</time>
</div>
</li>
<li>
<a class="img-wrap" href="/news/1136846_preview-2023-dodge-hornet-plug-in-hybrid-30-miles-range-performance">
<img class="lazy" data-id="100851619" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg3.ibsrv.net/ibimg/hgm/1920x1080-1/100/851/2023-dodge-hornet_100851619.jpg" alt="2023 Dodge Hornet" data-srcset="https://cimg3.ibsrv.net/ibimg/hgm/1600x900-1/100/851/2023-dodge-hornet_100851619.jpg 1600w, https://cimg3.ibsrv.net/ibimg/hgm/880x495-1/100/851/2023-dodge-hornet_100851619.jpg 880w, https://cimg3.ibsrv.net/ibimg/hgm/800x450-1/100/851/2023-dodge-hornet_100851619.jpg 800w, https://cimg3.ibsrv.net/ibimg/hgm/626x352-1/100/851/2023-dodge-hornet_100851619.jpg 626w, https://cimg3.ibsrv.net/ibimg/hgm/440x248-1/100/851/2023-dodge-hornet_100851619.jpg 440w, https://cimg3.ibsrv.net/ibimg/hgm/313x176-1/100/851/2023-dodge-hornet_100851619.jpg 313w" sizes="(min-width: 1024px) 313px, (max-width: 440px) 440px, calc(100vw - 2rem)">
</a>
<div class="item-text">
<a class="title" href="/news/1136846_preview-2023-dodge-hornet-plug-in-hybrid-30-miles-range-performance">Preview: Dodge Hornet R/T plug-in hybrid stings with 30-mile electric range, muscle-car cues</a>
<p>The R/T's 15.5-kwh battery pack allows it to go more than 30 miles of EPA electric driving range, according to Dodge, with efficiency still an unknown.</p>
<a href="/writer/10001004_bengt-halvorson" rel="author" class="by-line">Bengt Halvorson</a>
<time datetime="2022-08-16T23:00:00+0000">August 16, 2022</time>
</div>
</li>
<div class="adv-spacer" id="ad-a-3"></div>
<li>
<a class="img-wrap" href="/news/1136840_ev-tax-credit-shortlist-polestar-6-roadster-iphone-maker-s-electric-tractors-today-s-car-news">
<img class="lazy" data-id="100836340" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg0.ibsrv.net/ibimg/hgm/1920x1080-1/100/836/2023-toyota-bz4x_100836340.jpg" alt="2023 Toyota bZ4X XLE FWD" data-srcset="https://cimg0.ibsrv.net/ibimg/hgm/1600x900-1/100/836/2023-toyota-bz4x_100836340.jpg 1600w, https://cimg0.ibsrv.net/ibimg/hgm/880x495-1/100/836/2023-toyota-bz4x_100836340.jpg 880w, https://cimg0.ibsrv.net/ibimg/hgm/800x450-1/100/836/2023-toyota-bz4x_100836340.jpg 800w, https://cimg0.ibsrv.net/ibimg/hgm/626x352-1/100/836/2023-toyota-bz4x_100836340.jpg 626w, https://cimg0.ibsrv.net/ibimg/hgm/440x248-1/100/836/2023-toyota-bz4x_100836340.jpg 440w, https://cimg0.ibsrv.net/ibimg/hgm/313x176-1/100/836/2023-toyota-bz4x_100836340.jpg 313w" sizes="(min-width: 1024px) 313px, (max-width: 440px) 440px, calc(100vw - 2rem)">
</a>
<div class="item-text">
<a class="title" href="/news/1136840_ev-tax-credit-shortlist-polestar-6-roadster-iphone-maker-s-electric-tractors-today-s-car-news">EV tax credit shortlist, Polestar 6 roadster, iPhone maker&#039;s electric tractors: Today’s Car News</a>
<p>Polestar confirms what looks a lot like a rival to the Tesla Roadster 2.0. Foxconn plans to build electric tractors alongside the Lordstown Endurance. And it&rsquo;s the end of the EV tax credit as we know it. This and more, here at Green Car Reports. With President Biden signing the Inflation...</p>
<a href="/writer/10001004_bengt-halvorson" rel="author" class="by-line">Bengt Halvorson</a>
<time datetime="2022-08-16T15:55:00+0000">August 16, 2022</time>
</div>
</li>
<li>
<a class="img-wrap" href="/news/1136839_tax-credit-unlikely-to-return-for-these-evs-and-plug-in-hybrids">
<img class="lazy" data-id="100827155" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg3.ibsrv.net/ibimg/hgm/1350x759-1/100/827/2022-kia-ev6_100827155.jpg" alt="2022 Kia EV6" data-srcset="https://cimg3.ibsrv.net/ibimg/hgm/1350x759-1/100/827/2022-kia-ev6_100827155.jpg 1350w, https://cimg3.ibsrv.net/ibimg/hgm/880x495-1/100/827/2022-kia-ev6_100827155.jpg 880w, https://cimg3.ibsrv.net/ibimg/hgm/800x450-1/100/827/2022-kia-ev6_100827155.jpg 800w, https://cimg3.ibsrv.net/ibimg/hgm/626x352-1/100/827/2022-kia-ev6_100827155.jpg 626w, https://cimg3.ibsrv.net/ibimg/hgm/440x248-1/100/827/2022-kia-ev6_100827155.jpg 440w, https://cimg3.ibsrv.net/ibimg/hgm/313x176-1/100/827/2022-kia-ev6_100827155.jpg 313w" sizes="(min-width: 1024px) 313px, (max-width: 440px) 440px, calc(100vw - 2rem)">
</a>
<div class="item-text">
<a class="title" href="/news/1136839_tax-credit-unlikely-to-return-for-these-evs-and-plug-in-hybrids">Inflation Reduction Act drastically cuts EV, plug-in hybrid models eligible for federal tax credit</a>
<p>The tax credit is almost certainly gone for the rest of 2022 and will be back at the beginning of 2023 for a smaller group of vehicles. Here's an idea of what that list will include.</p>
<a href="/writer/10001004_bengt-halvorson" rel="author" class="by-line">Bengt Halvorson</a>
<time datetime="2022-08-16T15:40:00+0000">August 16, 2022</time>
</div>
</li>
<li>
<a class="img-wrap" href="/news/1136831_foxconn-self-driving-electric-tractor-ohio-factory-lordstown-fisker">
<img class="lazy" data-id="100851527" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg3.ibsrv.net/ibimg/hgm/1920x1080-1/100/851/monarch-mk-v-electric-tractor_100851527.jpg" alt="Monarch Mk-V electric tractor" data-srcset="https://cimg3.ibsrv.net/ibimg/hgm/1600x900-1/100/851/monarch-mk-v-electric-tractor_100851527.jpg 1600w, https://cimg3.ibsrv.net/ibimg/hgm/880x495-1/100/851/monarch-mk-v-electric-tractor_100851527.jpg 880w, https://cimg3.ibsrv.net/ibimg/hgm/800x450-1/100/851/monarch-mk-v-electric-tractor_100851527.jpg 800w, https://cimg3.ibsrv.net/ibimg/hgm/626x352-1/100/851/monarch-mk-v-electric-tractor_100851527.jpg 626w, https://cimg3.ibsrv.net/ibimg/hgm/440x248-1/100/851/monarch-mk-v-electric-tractor_100851527.jpg 440w, https://cimg3.ibsrv.net/ibimg/hgm/313x176-1/100/851/monarch-mk-v-electric-tractor_100851527.jpg 313w" sizes="(min-width: 1024px) 313px, (max-width: 440px) 440px, calc(100vw - 2rem)">
</a>
<div class="item-text">
<a class="title" href="/news/1136831_foxconn-self-driving-electric-tractor-ohio-factory-lordstown-fisker">Foxconn to make self-driving electric tractor at same Ohio factory as EVs from Lordstown, Fisker</a>
<p>GM's former Ohio factory might soon be making an electric pickup, an urban EV, and self-driving tractors.</p>
<a href="/writer/10044742_stephen-edelstein" rel="author" class="by-line">Stephen Edelstein</a>
<time datetime="2022-08-16T13:00:00+0000">August 16, 2022</time>
</div>
</li>
<li class="large">
<a class="img-wrap" href="/news/1136834_polestar-6-electric-roadster-confirmed-for-production-in-2026-chasing-tesla-roadster-2-0">
<img class="lazy" data-id="100830975" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg3.ibsrv.net/ibimg/hgm/1920x1080-1/100/830/polestar-o2-concept_100830975.jpg" alt="Polestar O2 concept" data-srcset="https://cimg3.ibsrv.net/ibimg/hgm/1920x1080-1/100/830/polestar-o2-concept_100830975.jpg 1920w, https://cimg3.ibsrv.net/ibimg/hgm/1600x900-1/100/830/polestar-o2-concept_100830975.jpg 1600w, https://cimg3.ibsrv.net/ibimg/hgm/960x540-1/100/830/polestar-o2-concept_100830975.jpg 960w, https://cimg3.ibsrv.net/ibimg/hgm/880x495-1/100/830/polestar-o2-concept_100830975.jpg 880w, https://cimg3.ibsrv.net/ibimg/hgm/800x450-1/100/830/polestar-o2-concept_100830975.jpg 800w, https://cimg3.ibsrv.net/ibimg/hgm/440x248-1/100/830/polestar-o2-concept_100830975.jpg 440w" sizes="(min-width: 1024px) 960px, (max-width: 440px) 440px, calc(100vw - 2rem)">
<div class="overlay"></div>
</a>
<div class="item-text">
<div class="shift">
<div class="title-wrap"><a class="title" href="/news/1136834_polestar-6-electric-roadster-confirmed-for-production-in-2026-chasing-tesla-roadster-2-0">Polestar 6 electric roadster confirmed for production in 2026, chasing Tesla Roadster 2.0</a></div>
<a href="/writer/10001004_bengt-halvorson" rel="author" class="by-line">Bengt Halvorson</a>
<time datetime="2022-08-16T11:00:00+0000">August 16, 2022</time>
</div>
<p>The hardtop convertible will be built on Polestar’s own aluminum platform and “showcases the brand’s vision for future sports cars.”</p>
</div>
</li>
<li>
<a class="img-wrap" href="/news/1136828_cheapest-us-evs-fastest-charging-ev-gas-vs-electric-pickups-diesel-rule-suit-dropped-today-s-car-news">
<img class="lazy" data-id="100836121" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg1.ibsrv.net/ibimg/hgm/1920x1080-1/100/836/nissan-leaf_100836121.jpg" alt="2023 Nissan Leaf" data-srcset="https://cimg1.ibsrv.net/ibimg/hgm/1600x900-1/100/836/nissan-leaf_100836121.jpg 1600w, https://cimg1.ibsrv.net/ibimg/hgm/880x495-1/100/836/nissan-leaf_100836121.jpg 880w, https://cimg1.ibsrv.net/ibimg/hgm/800x450-1/100/836/nissan-leaf_100836121.jpg 800w, https://cimg1.ibsrv.net/ibimg/hgm/626x352-1/100/836/nissan-leaf_100836121.jpg 626w, https://cimg1.ibsrv.net/ibimg/hgm/440x248-1/100/836/nissan-leaf_100836121.jpg 440w, https://cimg1.ibsrv.net/ibimg/hgm/313x176-1/100/836/nissan-leaf_100836121.jpg 313w" sizes="(min-width: 1024px) 313px, (max-width: 440px) 440px, calc(100vw - 2rem)">
</a>
<div class="item-text">
<a class="title" href="/news/1136828_cheapest-us-evs-fastest-charging-ev-gas-vs-electric-pickups-diesel-rule-suit-dropped-today-s-car-news">Cheapest US EVs, fastest-charging EV, gas vs. electric pickups, diesel-rule suit dropped: Today’s Car News</a>
<p>We look at the lowest-priced U.S. EVs. An industry group drops its lawsuit over tighter diesel tailpipe rules. How much better for emissions are electric pickups? And a Chinese automaker claims to have the world&rsquo;s fastest-charging mass-production EV. This and more, here at Green Car Reports...</p>
<a href="/writer/10001004_bengt-halvorson" rel="author" class="by-line">Bengt Halvorson</a>
<time datetime="2022-08-15T15:55:00+0000">August 15, 2022</time>
</div>
</li>
<div class="adv-spacer" id="ad-a-4"></div>
<li>
<a class="img-wrap" href="/news/1136827_truckmakers-drop-lawsuit-challenging-tailpipe-emissions-standards">
<img class="lazy" data-id="100838458" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg2.ibsrv.net/ibimg/hgm/2000x1125-1/100/838/tesla-semi-courtesy-of-tesla-inc_100838458.jpg" alt="Tesla Semi  (Courtesy of Tesla, Inc.)" data-srcset="https://cimg2.ibsrv.net/ibimg/hgm/1600x900-1/100/838/tesla-semi-courtesy-of-tesla-inc_100838458.jpg 1600w, https://cimg2.ibsrv.net/ibimg/hgm/880x495-1/100/838/tesla-semi-courtesy-of-tesla-inc_100838458.jpg 880w, https://cimg2.ibsrv.net/ibimg/hgm/800x450-1/100/838/tesla-semi-courtesy-of-tesla-inc_100838458.jpg 800w, https://cimg2.ibsrv.net/ibimg/hgm/626x352-1/100/838/tesla-semi-courtesy-of-tesla-inc_100838458.jpg 626w, https://cimg2.ibsrv.net/ibimg/hgm/440x248-1/100/838/tesla-semi-courtesy-of-tesla-inc_100838458.jpg 440w, https://cimg2.ibsrv.net/ibimg/hgm/313x176-1/100/838/tesla-semi-courtesy-of-tesla-inc_100838458.jpg 313w" sizes="(min-width: 1024px) 313px, (max-width: 440px) 440px, calc(100vw - 2rem)">
</a>
<div class="item-text">
<a class="title" href="/news/1136827_truckmakers-drop-lawsuit-challenging-tailpipe-emissions-standards">Truckmakers drop lawsuit challenging tailpipe emissions standards</a>
<p>After resistance from a wide range of states and companies, an industry group has dropped its opposition to tighter diesel rules.</p>
<a href="/writer/10001004_bengt-halvorson" rel="author" class="by-line">Bengt Halvorson</a>
<time datetime="2022-08-15T15:44:00+0000">August 15, 2022</time>
</div>
</li>
<li>
<a class="img-wrap" href="/news/1136814_electric-pickups-less-co2-than-average-gasoline-truck">
<img class="lazy" data-id="100769511" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg3.ibsrv.net/ibimg/hgm/1920x1080-1/100/769/rivian-r1t_100769511.jpg" alt="Rivian R1T" data-srcset="https://cimg3.ibsrv.net/ibimg/hgm/1600x900-1/100/769/rivian-r1t_100769511.jpg 1600w, https://cimg3.ibsrv.net/ibimg/hgm/880x495-1/100/769/rivian-r1t_100769511.jpg 880w, https://cimg3.ibsrv.net/ibimg/hgm/800x450-1/100/769/rivian-r1t_100769511.jpg 800w, https://cimg3.ibsrv.net/ibimg/hgm/626x352-1/100/769/rivian-r1t_100769511.jpg 626w, https://cimg3.ibsrv.net/ibimg/hgm/440x248-1/100/769/rivian-r1t_100769511.jpg 440w, https://cimg3.ibsrv.net/ibimg/hgm/313x176-1/100/769/rivian-r1t_100769511.jpg 313w" sizes="(min-width: 1024px) 313px, (max-width: 440px) 440px, calc(100vw - 2rem)">
</a>
<div class="item-text">
<a class="title" href="/news/1136814_electric-pickups-less-co2-than-average-gasoline-truck">Analysis: Electric pickups emit less CO2 than the average gasoline truck anywhere in the US</a>
<p>Including manufacturing and other necessary pieces, an electric pickup reduces lifetime emissions 57% compared to the average gasoline truck, the analysis found.</p>
<a href="/writer/10044742_stephen-edelstein" rel="author" class="by-line">Stephen Edelstein</a>
<time datetime="2022-08-15T13:30:00+0000">August 15, 2022</time>
</div>
</li>
<li>
<a class="img-wrap" href="/news/1136813_xpeng-g9-suv-fastest-charging-mass-produced-ev">
<img class="lazy" data-id="100851475" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg3.ibsrv.net/ibimg/hgm/1266x712-1/100/851/xpeng-g9_100851475.jpg" alt="Xpeng G9" data-srcset="https://cimg3.ibsrv.net/ibimg/hgm/1266x712-1/100/851/xpeng-g9_100851475.jpg 1266w, https://cimg3.ibsrv.net/ibimg/hgm/880x495-1/100/851/xpeng-g9_100851475.jpg 880w, https://cimg3.ibsrv.net/ibimg/hgm/800x450-1/100/851/xpeng-g9_100851475.jpg 800w, https://cimg3.ibsrv.net/ibimg/hgm/626x352-1/100/851/xpeng-g9_100851475.jpg 626w, https://cimg3.ibsrv.net/ibimg/hgm/440x248-1/100/851/xpeng-g9_100851475.jpg 440w, https://cimg3.ibsrv.net/ibimg/hgm/313x176-1/100/851/xpeng-g9_100851475.jpg 313w" sizes="(min-width: 1024px) 313px, (max-width: 440px) 440px, calc(100vw - 2rem)">
</a>
<div class="item-text">
<a class="title" href="/news/1136813_xpeng-g9-suv-fastest-charging-mass-produced-ev">Top-tech Xpeng G9 SUV claimed to be world&#039;s fastest-charging mass-produced EV</a>
<p>The quickest charging rates will also require new 480-kw DC fast chargers Xpeng plans to roll out in sync with the G9's market launch.</p>
<a href="/writer/10044742_stephen-edelstein" rel="author" class="by-line">Stephen Edelstein</a>
<time datetime="2022-08-15T12:00:00+0000">August 15, 2022</time>
</div>
</li>
</ul>
</div>
<button type="button" class="red-button" id="load-more" data-page="1" data-itemsPerPage="12">Load More Articles</button>
<div class="red-spinner"><img src="/images/Spinner-1s-54px.svg"></div>
</div>
</div>
</div>
<div class="right-col gcr-rail ">
<aside>
<div class="adv-spacer" id="ad-a-5"></div>
<div class="related-articles">
<h2 class="title">Related Articles</h2>
<ul class="block-list rail-related-list">
<li>
<a class="block-image" href="/news/1136840_ev-tax-credit-shortlist-polestar-6-roadster-iphone-maker-s-electric-tractors-today-s-car-news">
<img class="lazy" data-id="100836340" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg0.ibsrv.net/ibimg/hgm/1920x1080-1/100/836/2023-toyota-bz4x_100836340.jpg" alt="2023 Toyota bZ4X XLE FWD" data-srcset="https://cimg0.ibsrv.net/ibimg/hgm/200x113-1/100/836/2023-toyota-bz4x_100836340.jpg 200w, https://cimg0.ibsrv.net/ibimg/hgm/100x56-1/100/836/2023-toyota-bz4x_100836340.jpg 100w" sizes="100px">
</a>
<a class="block-link" href="/news/1136840_ev-tax-credit-shortlist-polestar-6-roadster-iphone-maker-s-electric-tractors-today-s-car-news">
EV tax credit shortlist, Polestar 6 roadster, iPhone maker&#039;s electric...
</a>
</li>
<li>
<a class="block-image" href="/news/1136827_truckmakers-drop-lawsuit-challenging-tailpipe-emissions-standards">
<img class="lazy" data-id="100838458" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg2.ibsrv.net/ibimg/hgm/2000x1125-1/100/838/tesla-semi-courtesy-of-tesla-inc_100838458.jpg" alt="Tesla Semi  (Courtesy of Tesla, Inc.)" data-srcset="https://cimg2.ibsrv.net/ibimg/hgm/200x113-1/100/838/tesla-semi-courtesy-of-tesla-inc_100838458.jpg 200w, https://cimg2.ibsrv.net/ibimg/hgm/100x56-1/100/838/tesla-semi-courtesy-of-tesla-inc_100838458.jpg 100w" sizes="100px">
</a>
<a class="block-link" href="/news/1136827_truckmakers-drop-lawsuit-challenging-tailpipe-emissions-standards">
Truckmakers drop lawsuit challenging tailpipe emissions standards
</a>
</li>
<li>
<a class="block-image" href="/news/1136828_cheapest-us-evs-fastest-charging-ev-gas-vs-electric-pickups-diesel-rule-suit-dropped-today-s-car-news">
<img class="lazy" data-id="100836121" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg1.ibsrv.net/ibimg/hgm/1920x1080-1/100/836/nissan-leaf_100836121.jpg" alt="2023 Nissan Leaf" data-srcset="https://cimg1.ibsrv.net/ibimg/hgm/200x113-1/100/836/nissan-leaf_100836121.jpg 200w, https://cimg1.ibsrv.net/ibimg/hgm/100x56-1/100/836/nissan-leaf_100836121.jpg 100w" sizes="100px">
</a>
<a class="block-link" href="/news/1136828_cheapest-us-evs-fastest-charging-ev-gas-vs-electric-pickups-diesel-rule-suit-dropped-today-s-car-news">
Cheapest US EVs, fastest-charging EV, gas vs. electric pickups...
</a>
</li>
<li>
<a class="block-image" href="/news/1136815_ev-tax-credit-breakdown-f-150-lightning-price-hike-used-ev-prices-tesla-fsd-pushback-the-week-in-reverse">
<img class="lazy" data-id="100850941" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg1.ibsrv.net/ibimg/hgm/1920x1080-1/100/850/lucid-air-stealth-look_100850941.jpg" alt="Lucid Air Stealth Look" data-srcset="https://cimg1.ibsrv.net/ibimg/hgm/200x113-1/100/850/lucid-air-stealth-look_100850941.jpg 200w, https://cimg1.ibsrv.net/ibimg/hgm/100x56-1/100/850/lucid-air-stealth-look_100850941.jpg 100w" sizes="100px">
</a>
<a class="block-link" href="/news/1136815_ev-tax-credit-breakdown-f-150-lightning-price-hike-used-ev-prices-tesla-fsd-pushback-the-week-in-reverse">
EV tax credit breakdown, F-150 Lightning price hike, used EV prices, Tesla...
</a>
</li>
<li>
<a class="block-image" href="/news/1136811_ev-tax-credit-twisted-timeline-ikea-charging-nader-and-tesla-fsd-todays-car-news">
 <img class="lazy" data-id="100781583" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg3.ibsrv.net/ibimg/hgm/1920x1080-1/100/781/chevrolet-bolt_100781583.jpg" alt="2022 Chevrolet Bolt EV" data-srcset="https://cimg3.ibsrv.net/ibimg/hgm/200x113-1/100/781/chevrolet-bolt_100781583.jpg 200w, https://cimg3.ibsrv.net/ibimg/hgm/100x56-1/100/781/chevrolet-bolt_100781583.jpg 100w" sizes="100px">
</a>
<a class="block-link" href="/news/1136811_ev-tax-credit-twisted-timeline-ikea-charging-nader-and-tesla-fsd-todays-car-news">
EV tax credit’s twisted timeline, IKEA charging, Nader and Tesla FSD...
</a>
</li>
<li>
<a class="block-image" href="/news/1136783_f-150-lightning-price-hike-meyers-manx-ev-lucid-air-stealth-today-s-car-news">
<img class="lazy" data-id="100850999" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg3.ibsrv.net/ibimg/hgm/1703x958-1/100/850/meyers-manx-2-0-electric_100850999.jpg" alt="Meyers Manx 2.0 Electric" data-srcset="https://cimg3.ibsrv.net/ibimg/hgm/200x113-1/100/850/meyers-manx-2-0-electric_100850999.jpg 200w, https://cimg3.ibsrv.net/ibimg/hgm/100x56-1/100/850/meyers-manx-2-0-electric_100850999.jpg 100w" sizes="100px">
</a>
<a class="block-link" href="/news/1136783_f-150-lightning-price-hike-meyers-manx-ev-lucid-air-stealth-today-s-car-news">
F-150 Lightning price hike, Meyers Manx EV, Lucid Air Stealth: Today’s...
</a>
</li>
</ul>
</div>
<div class="adv-spacer" id="ad-a-6"></div>
<h3>Most Popular</h3>
<div class="rail-box most-popular">
<div class="item opacity-background  lazy-background " data-background="https://images.hgmsites.net/med/2021-ford-mustang-mach-e_100723926_m.jpg">
<div class="overlay"></div>
<div class="info">
<div class="date">
August 12, 2022
</div>
<div class="title">
<a href="/news/1136801_claim-the-7500-federal-ev-tax-credit-now-before-it-expires-for-2022">Buy now to claim the $7,500 federal EV tax credit before it expires for 2022</a>
</div>
<div class="comment">
<a href="/writer/10001004_bengt-halvorson" rel="author">
Bengt Halvorson - Senior Editor
</a>
</div>
</div>
</div>
<div class="item opacity-background  lazy-background " data-background="https://images.hgmsites.net/med/lucid-air-stealth-look_100850941_m.jpg">
<div class="overlay"></div>
<div class="info">
<div class="date">
August 13, 2022
</div>
<div class="title">
<a href="/news/1136815_ev-tax-credit-breakdown-f-150-lightning-price-hike-used-ev-prices-tesla-fsd-pushback-the-week-in-reverse">EV tax credit breakdown, F-150 Lightning price hike, used EV prices, Tesla FSD pushback: The Week in Reverse</a>
</div>
<div class="comment">
<a href="/writer/10001004_bengt-halvorson" rel="author">
Bengt Halvorson - Senior Editor
</a>
 </div>
</div>
</div>
<div class="item opacity-background  lazy-background " data-background="https://images.hgmsites.net/med/2022-kia-ev6_100827155_m.jpg">
<div class="overlay"></div>
<div class="info">
<div class="date">
August 16, 2022
</div>
<div class="title">
<a href="/news/1136839_tax-credit-unlikely-to-return-for-these-evs-and-plug-in-hybrids">Inflation Reduction Act drastically cuts EV, plug-in hybrid models eligible for federal tax credit</a>
</div>
<div class="comment">
<a href="/writer/10001004_bengt-halvorson" rel="author">
Bengt Halvorson - Senior Editor
</a>
</div>
</div>
</div>
<div class="item opacity-background  lazy-background " data-background="https://images.hgmsites.net/med/chevrolet-bolt_100781597_m.jpg">
<div class="overlay"></div>
<div class="info">
<div class="date">
August 14, 2022
</div>
<div class="title">
<a href="/news/1133548_affordable-all-electric-the-5-lowest-priced-new-evs-in-the-us">Affordable, all-electric: The 5 lowest-priced new EVs in the US</a>
</div>
<div class="comment">
<a href="/writer/10001004_bengt-halvorson" rel="author">
Bengt Halvorson - Senior Editor
</a>
</div>
</div>
</div>
<div class="item opacity-background  lazy-background " data-background="https://images.hgmsites.net/med/2022-tesla-model-s_100849988_m.jpg">
<div class="overlay"></div>
<div class="info">
<div class="date">
August 10, 2022
</div>
<div class="title">
<a href="/news/1136786_ralph-nader-nhtsa-order-removal-of-tesla-full-self-driving">Ralph Nader calls for NHTSA to order removal of Tesla Full Self-Driving</a>
</div>
<div class="comment">
<a href="/writer/10044742_stephen-edelstein" rel="author">
Stephen Edelstein - Contributing Writer
</a>
</div>
</div>
</div>
<div class="item opacity-background  lazy-background " data-background="https://images.hgmsites.net/med/2024-volkswagen-id-buzz_100832793_m.jpg">
<div class="overlay"></div>
<div class="info">
<div class="date">
August 12, 2022
</div>
<div class="title">
<a href="/news/1136799_eu-claims-revamped-us-ev-tax-credit-might-violate-wto-rules">EU claims revamped US EV tax credit might violate WTO rules</a>
</div>
<div class="comment">
<a href="/writer/10044742_stephen-edelstein" rel="author">
Stephen Edelstein - Contributing Writer
</a>
</div>
</div>
</div>
<div class="clear"></div>
</div>
 <div class="gcr-fixed-anchor"></div>
<div class="gcr-fixed-content">
<div class="photo-galleries-swiper">
<h3>Photos</h3>
<div class="pagination-container">
<div class="swiper-prev">&lt;</div>
<div class="swiper-counter"></div>
<div class="swiper-next">&gt;</div>
</div>
<div class="swiper-container">
<div class="swiper-wrapper">
<div class="swiper-slide">
<div class="swiper-image item">
<a href="/news/1136855_2023-kia-sportage-plug-in-hybrid-price-range" class="img-wrap">
<img class="lazy" data-id="100828347" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg3.ibsrv.net/ibimg/hgm/1350x759-1/100/828/2023-kia-sportage_100828347.jpg" alt="2023 Kia Sportage PHEV" data-srcset="https://cimg3.ibsrv.net/ibimg/hgm/1350x759-1/100/828/2023-kia-sportage_100828347.jpg 1350w, https://cimg3.ibsrv.net/ibimg/hgm/1200x675-1/100/828/2023-kia-sportage_100828347.jpg 1200w, https://cimg3.ibsrv.net/ibimg/hgm/1024x576-1/100/828/2023-kia-sportage_100828347.jpg 1024w, https://cimg3.ibsrv.net/ibimg/hgm/600x338-1/100/828/2023-kia-sportage_100828347.jpg 600w" sizes="(max-width: 2000px) 600px, calc(100vw - 0rem)">
</a>
<a href="/news/1136855_2023-kia-sportage-plug-in-hybrid-price-range" class="title">2023 Kia Sportage Plug-In Hybrid priced just under $40,000, goes 34 electric miles</a>
</div>
</div>
<div class="swiper-slide">
<div class="swiper-image item">
<a href="/news/1136845_us-built-mercedes-eqe-suv-teased-with-interior-photos-due-for-october-debut" class="img-wrap">
<img class="lazy" data-id="100851555" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg3.ibsrv.net/ibimg/hgm/1920x1080-1/100/851/2023-mercedes-benz-eqe-suv_100851555.jpg" alt="2023 Mercedes-Benz EQE SUV" data-srcset="https://cimg3.ibsrv.net/ibimg/hgm/1920x1080-1/100/851/2023-mercedes-benz-eqe-suv_100851555.jpg 1920w, https://cimg3.ibsrv.net/ibimg/hgm/1200x675-1/100/851/2023-mercedes-benz-eqe-suv_100851555.jpg 1200w, https://cimg3.ibsrv.net/ibimg/hgm/1024x576-1/100/851/2023-mercedes-benz-eqe-suv_100851555.jpg 1024w, https://cimg3.ibsrv.net/ibimg/hgm/600x338-1/100/851/2023-mercedes-benz-eqe-suv_100851555.jpg 600w" sizes="(max-width: 2000px) 600px, calc(100vw - 0rem)">
</a>
<a href="/news/1136845_us-built-mercedes-eqe-suv-teased-with-interior-photos-due-for-october-debut" class="title">US-built Mercedes EQE SUV teased with interior photos, due for October debut</a>
</div>
</div>
<div class="swiper-slide">
<div class="swiper-image item">
<a href="/news/1136846_preview-2023-dodge-hornet-plug-in-hybrid-30-miles-range-performance" class="img-wrap">
<img class="lazy" data-id="100851619" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg3.ibsrv.net/ibimg/hgm/1920x1080-1/100/851/2023-dodge-hornet_100851619.jpg" alt="2023 Dodge Hornet" data-srcset="https://cimg3.ibsrv.net/ibimg/hgm/1920x1080-1/100/851/2023-dodge-hornet_100851619.jpg 1920w, https://cimg3.ibsrv.net/ibimg/hgm/1200x675-1/100/851/2023-dodge-hornet_100851619.jpg 1200w, https://cimg3.ibsrv.net/ibimg/hgm/1024x576-1/100/851/2023-dodge-hornet_100851619.jpg 1024w, https://cimg3.ibsrv.net/ibimg/hgm/600x338-1/100/851/2023-dodge-hornet_100851619.jpg 600w" sizes="(max-width: 2000px) 600px, calc(100vw - 0rem)">
</a>
 <a href="/news/1136846_preview-2023-dodge-hornet-plug-in-hybrid-30-miles-range-performance" class="title">Preview: Dodge Hornet R/T plug-in hybrid stings with 30-mile electric range, muscle-car cues</a>
</div>
</div>
<div class="swiper-slide">
<div class="swiper-image item">
<a href="/news/1136834_polestar-6-electric-roadster-confirmed-for-production-in-2026-chasing-tesla-roadster-2-0" class="img-wrap">
<img class="lazy" data-id="100830975" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg3.ibsrv.net/ibimg/hgm/1920x1080-1/100/830/polestar-o2-concept_100830975.jpg" alt="Polestar O2 concept" data-srcset="https://cimg3.ibsrv.net/ibimg/hgm/1920x1080-1/100/830/polestar-o2-concept_100830975.jpg 1920w, https://cimg3.ibsrv.net/ibimg/hgm/1200x675-1/100/830/polestar-o2-concept_100830975.jpg 1200w, https://cimg3.ibsrv.net/ibimg/hgm/1024x576-1/100/830/polestar-o2-concept_100830975.jpg 1024w, https://cimg3.ibsrv.net/ibimg/hgm/600x338-1/100/830/polestar-o2-concept_100830975.jpg 600w" sizes="(max-width: 2000px) 600px, calc(100vw - 0rem)">
</a>
<a href="/news/1136834_polestar-6-electric-roadster-confirmed-for-production-in-2026-chasing-tesla-roadster-2-0" class="title">Polestar 6 electric roadster confirmed for production in 2026, chasing Tesla Roadster 2.0</a>
</div>
</div>
<div class="swiper-slide">
<div class="swiper-image item">
<a href="/news/1136813_xpeng-g9-suv-fastest-charging-mass-produced-ev" class="img-wrap">
<img class="lazy" data-id="100851475" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg3.ibsrv.net/ibimg/hgm/1266x712-1/100/851/xpeng-g9_100851475.jpg" alt="Xpeng G9" data-srcset="https://cimg3.ibsrv.net/ibimg/hgm/1266x712-1/100/851/xpeng-g9_100851475.jpg 1266w, https://cimg3.ibsrv.net/ibimg/hgm/1200x675-1/100/851/xpeng-g9_100851475.jpg 1200w, https://cimg3.ibsrv.net/ibimg/hgm/1024x576-1/100/851/xpeng-g9_100851475.jpg 1024w, https://cimg3.ibsrv.net/ibimg/hgm/600x338-1/100/851/xpeng-g9_100851475.jpg 600w" sizes="(max-width: 2000px) 600px, calc(100vw - 0rem)">
</a>
<a href="/news/1136813_xpeng-g9-suv-fastest-charging-mass-produced-ev" class="title">Top-tech Xpeng G9 SUV claimed to be world&#039;s fastest-charging mass-produced EV</a>
</div>
</div>
</div>
</div>
</div>
<div class="adv-spacer" id="ad-a-7"></div>
</div>
</aside>
</div>
</div>
</div>
</div>
<a href="#" class="footer-waypoint-anchor"></a>
<footer>
<div class="footer-content">
<div class="footer-logo">
<a href="/" title="Green Car Reports">
<div class="logo-type"></div>
</a>
</div>
<div class="footer-links">
<div class="footer-link-section1 gcr">
<div class="footer-link-section">
<h4>News</h4>
<ul>
<li><a class="foot-link" href="/news/charging">Charging</a></li>
<li><a class="foot-link" href="/news/mobility">Mobility</a></li>
<li><a class="foot-link" href="/news/sustainability">Sustainability</a></li>
<li><a class="foot-link" href="/news/gas-mileage">Gas Mileage </a></li>
<li><a class="foot-link" href="/news/hybrid-cars">Hybrids</a></li>
<li><a class="foot-link" href="/news/electric-cars">Electric Cars</a></li>
<li><a class="foot-link" href="/news/alternative-fuels">Alt Fuels</a></li>
<li><a class="foot-link" href="/news/diesel">Diesel Cars</a></li>
<li><a class="foot-link" href="/news/features">Features</a></li>
<li><a class="foot-link" href="/news">View All </a></li>
</ul>
</div>
</div>
<div class="footer-link-section2">
<div class="footer-link-section">
<h4>Media</h4>
<ul>
<li><a class="foot-link" href="/pictures">Photos</a></li>
<li><a class="foot-link" href="/videos">Videos</a></li>
</ul>
</div>
<div class="footer-link-section">
<h4>RSS</h4>
<ul>
<li><a class="foot-link" href="/rss-feeds">All Feeds</a></li>
<li><a class="foot-link" href="https://feeds.highgearmedia.com/?sites=GreenCarReports">Master Feed</a></li>
<li><a class="foot-link" href="https://feeds.highgearmedia.com/?sites=GreenCarReports&amp;tags=news">News</a></li>
<li><a class="foot-link" href="https://feeds.highgearmedia.com/?sites=GreenCarReports&amp;tags=first-drives">First Drives</a></li>
<li><a class="foot-link" href="https://feeds.highgearmedia.com/?sites=GreenCarReports&amp;tags=electric-cars">Electric Cars</a></li>
<li><a class="foot-link" href="https://feeds.highgearmedia.com/?sites=GreenCarReports&amp;tags=hybrid-cars">Hybrids</a></li>
<li><a class="foot-link" href="https://feeds.highgearmedia.com/?sites=GreenCarReports&amp;tags=buying-guides">Guides</a></li>
<li><a class="foot-link" href="https://feeds.highgearmedia.com/?sites=GreenCarReports&amp;tags=green-life">Green Life</a></li>
</ul>
</div>
<div class="footer-link-section">
<div>
<h4>Company</h4>
<ul>
<li><a class="foot-link" href="/aboutus">About Us</a></li>
<li><a class="foot-link" href="/aboutus#contact-us">Contact Us</a></li>
<li><a class="foot-link" href="http://ibauto.tumblr.com/">Press</a></li>
<li><a class="foot-link" href="https://www.internetbrands.com/ibterms/">Terms of Use</a></li>
<li><a class="foot-link" href="https://www.internetbrands.com/ibterms/supplementalcarrelatedterms/">Disclaimer</a></li>
<li><a class="foot-link" href="https://www.internetbrands.com/privacy/privacy-main.html">Privacy Policy</a></li>
<li><a class="foot-link" href="https://www.internetbrands.com/privacy/privacy-contact-form.php">Do Not Sell My Personal Information</a></li>
</ul>
</div>
<div class="footer-other-sites">
<h4>Our Other Sites</h4>
<ul>
<li><a class="foot-link" href="https://www.thecarconnection.com/">The Car Connection</a></li>
 <li><a class="foot-link" href="https://www.motorauthority.com/">Motor Authority</a></li>
</ul>
</div>
</div>
</div>
</div>
<div class="footer-social-app-btns">
<section class="social">
<div class="follow-us">
<h3>Follow Us Today:</h3>
<a class="social-btn" title="Like us on Facebook" href="https://www.facebook.com/GreenCarReports" target="_blank" onclick="hgm.socialFollow('Facebook', 'GreenCarReports'); return true;">
<span class="fab fa-facebook-f"></span>
</a>
<a class="social-btn" title="Follow us on Twitter" href="https://www.twitter.com/GreenCarReports" target="_blank" onclick="hgm.socialFollow('Twitter', 'GreenCarReports'); return true;">
<span class="fab fa-twitter"></span>
</a>
<a class="social-btn" title="Follow us on Instagram" href="https://www.instagram.com/greencarreports/" target="_blank" onclick="hgm.socialFollow('Instagram', 'greencarreports'); return true;">
<span class="fab fa-instagram"></span>
</a>
<a class="social-btn" title="Subscribe to our YouTube channel" href="https://www.youtube.com/user/greencarreports" target="_blank" onclick="hgm.socialFollow('YouTube', 'greencarreports'); return true;">
<span class="fab fa-youtube"></span>
</a>
<a class="social-btn" title="Follow us on Filpboard" href="https://www.flipboard.com/@GreenCarReports" target="_blank" onclick="hgm.socialFollow('Flipboard', 'GreenCarReports'); return true;">
<span class="fab fa-flipboard"></span>
</a>
</div>
</section>
</div>
</div>
<div class="copyright">
&copy; 2022 MH Sub I, LLC. All Rights Reserved.
Stock photography by <a href="https://www.izmocars.com/">izmostock.</a>
Read our <a href="//www.internetbrands.com/privacy/cookie-policy.html">Cookie Policy</a>.
</div>
</footer>
<div class="adv-spacer bottom sticky">
<div id="bottom-sticky"></div>
</div>
<div class="adv-body-shift  active "></div>
<div class="nav-menu" data-menu="news">
<div class="nav-menu-items 2">
<div class="nav-menu-col nav-menu-col-news">
<a href="/news/charging">Charging</a>
<a href="/news/mobility">Mobility</a>
<a href="/news/sustainability">Sustainability</a>
</div>
<div class="nav-menu-col nav-menu-col-news">
<a href="/news/gas-mileage">Gas Mileage </a>
<a href="/news/hybrid-cars">Hybrids</a>
<a href="/news/electric-cars">Electric Cars</a>
</div>
<div class="nav-menu-col nav-menu-col-news">
<a href="/news/alternative-fuels">Alt Fuels</a>
<a href="/news/diesel">Diesel Cars</a>
<a href="/news/features">Features</a>
</div>
<div class="nav-menu-col nav-menu-col-news">
<a href="/news">View All </a>
</div>
</div>
</div>
<div class="nav-menu" data-menu="newsletter">
<div class="nav-menu-items nav-signup">
<div class="heading">Green Car Reports Newsletter</div>
<div>Sign up to get the latest green car and environmental news, delivered to your inbox daily!</div>
<form data-pos="navigation" class="newsletter-signup-form" action="/api/newsletter-subscribe" method="post">
<input type="email" class="email" name="email" placeholder="Enter your email address…" required data-msg="Email is required">
<button class="red-button newsletter-signup-btn" type="submit">Sign Up Today!</button>
<div class="response_message"></div>
</form>
</div>
<div class="signup-consent">I agree to receive emails from Green Car Reports. I understand that I can unsubscribe at any time. <a href="https://www.internetbrands.com/privacy/privacy-main.html" target="_blank">Privacy Policy.</a></div>
</div>
<div class="nav-menu nav-menu-search" data-menu="search" data-engine="652055e23533417e3" data-placeholder="Search Green Car Reports...">
<div class="nav-search">
<gcse:searchbox-only enableHistory="true" autoCompleteMaxCompletions="10" autoCompleteMatchType='any' resultsUrl="/searchresults"></gcse:searchbox-only>
</div>
</div>
<div class="device-nav">
<a class="nav-link  cat-link " href="/news">News</a>
<div class="nav-categories">
<a href="/news/charging">Charging</a>
<a href="/news/mobility">Mobility</a>
<a href="/news/sustainability">Sustainability</a>
<a href="/news/gas-mileage">Gas Mileage </a>
<a href="/news/hybrid-cars">Hybrids</a>
<a href="/news/electric-cars">Electric Cars</a>
<a href="/news/alternative-fuels">Alt Fuels</a>
<a href="/news/diesel">Diesel Cars</a>
<a href="/news/features">Features</a>
<a href="/news">View All </a>
</div>
<a class="nav-link " href="/news/first-drives">First Drives</a>
<a class="nav-link " href="/news/electric-cars">Electric Cars</a>
<a class="nav-link " href="/news/hybrid-cars">Hybrids</a>
<a class="nav-link " href="/news/buying-guides">Guides</a>
<a class="nav-link " href="/news/green-life">Green Life</a>
<li class="mobile-newsletter">
<div class="newsletter-wrapper">
<div class="newsletter-title">Never Miss a Green Car Reports Story</div>
<form class="newsletter-signup-form" action="/api/newsletter-subscribe" method="post">
<input type="email" class="email" name="email" placeholder="Enter your email address…" required data-msg="Email is required">
<div class="signup-consent">
I agree to receive emails from Green Car Reports. I understand that I can unsubscribe at any time. <a href="https://www.internetbrands.com/privacy/privacy-main.html" target="_blank">Privacy Policy.</a>
</div>
<button class="red-button newsletter-signup-btn" type="submit">subscribe today</button>
<div class="response_message"></div>
</form>
</div>
</li>
</div>
<script src="/js/vendor.js?id=59b777a469a90a4656f8"></script>
<script src="/js/app.js?id=8f5dc332e8e2b8d8d42d"></script>
<script>
(function(){
        hgm.initArticles();
        hgmads.initFromDeferred();
            hgmads.initDynamicAds($('.article-body'));
            googletag.cmd.push(function () {
                hgmads.renderDynamicAds();
            });;
        hgm.bindLoadMore($('.article-list'), '/api/load-articles/', function ($html, page, pageCount) {
            hgm.replaceState(null, '/news/page-' + page);
            let nextSlotId = $('.nativo-slot:last').data('slot-id');
            nextSlotId = nextSlotId + 1;
            $html.find('.large:odd').each(function(index){
                $('<li class="nativo-slot" id="nativo-' + nextSlotId + '" data-slotId="' + nextSlotId + '"></li>').insertAfter(this);
                nextSlotId = nextSlotId + 1;
            });

            dataLayer.push({
                event: 'hgm.ajax.more-articles',
                category: 'News',
                page: page,
                pageCount: pageCount
            });
        });;
hgm.initSearch();
hgm.initSearch();
}());
</script>
<script src="/js/footer.js?id=49b61c568d21609d6300"></script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"fcb635eb66","applicationID":"135926744","transactionName":"MgcAYUMDDUFWAkJaDAtNI1ZFCwxcGBRYWA0KFQw=","queueTime":0,"applicationTime":127,"atts":"HkAXFwsZHh4VABQJGBgf","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
