<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge"><script type="text/javascript">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</script>
<meta name="viewport" content="width=device-width, initial-scale=1">
<script>
        dataLayer =  [{"make_name":["Ford"],"make_seo_name":["ford"],"model_name":["Mustang Mach-E"],"model_seo_name":["mustang-mach-e"],"tags":["technology","electric-cars"]}] ;
                (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
        new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
        j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
        'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
        })(window, document, 'script', 'dataLayer', 'GTM-M73XHX4');
    </script>
<title>Ford Mustang Mach-E electric SUV: 5 geeky details show Ford&#039;s commitment to EVs</title>
<meta name="description" content="Ford&#039;s electric-vehicle chief, Mark Kaufman, revealed more details about Ford&#039;s upcoming electric vehicle that will make it different than anything else from the Blue Oval."> <link rel="canonical" href="https://www.greencarreports.com/news/1128304_ford-mustang-mach-e-electric-suv-5-geeky-details-show-ford-s-commitment-to-evs">
<script type="application/ld+json">
{"@context":"https://schema.org","@type":"WebPage","@id":"https://www.greencarreports.com/news/1128304_ford-mustang-mach-e-electric-suv-5-geeky-details-show-ford-s-commitment-to-evs","url":"https://www.greencarreports.com/news/1128304_ford-mustang-mach-e-electric-suv-5-geeky-details-show-ford-s-commitment-to-evs","isPartOf":{"@type":"WebSite","@id":"https://www.greencarreports.com/#site"},"breadcrumb":{"@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://www.greencarreports.com/news","name":"News"}},{"@type":"ListItem","position":2,"item":{"@id":"https://www.greencarreports.com/news/electric-cars","name":"Electric Cars"}}]},"mainEntity":{"@type":"NewsArticle","@id":"https://www.greencarreports.com/news/1128304_ford-mustang-mach-e-electric-suv-5-geeky-details-show-ford-s-commitment-to-evs#this","url":"https://www.greencarreports.com/news/1128304_ford-mustang-mach-e-electric-suv-5-geeky-details-show-ford-s-commitment-to-evs","headline":"Ford Mustang Mach-E electric SUV: 5 geeky details show Ford's commitment to EVs","datePublished":"2020-05-28T15:00:00+0000","dateModified":"2020-05-28T17:14:37+0000","description":"Ford's electric-vehicle chief, Mark Kaufman, revealed more details about Ford's upcoming electric vehicle that will make it different than anything else from the Blue Oval.","author":{"@type":"Person","name":"Bengt Halvorson","jobTitle":"Senior Editor","image":"https://images.hgmsites.net/tny/avatar-image-for-bengt_100544847_0.jpg","url":"https://www.greencarreports.com/writer/10001004_bengt-halvorson"},"publisher":{"@type":"Organization","@id":"https://www.greencarreports.com/#organization"},"articleSection":"Electric Cars","keywords":"Electric Cars","image":{"@type":"ImageObject","@id":"https://images.hgmsites.net/lrg/2021-ford-mustang-mach-e_100723928_l.jpg#this","url":"https://images.hgmsites.net/lrg/2021-ford-mustang-mach-e_100723928_l.jpg","caption":"2021 Ford Mustang Mach-E","description":"","width":1024,"height":767,"uploadDate":"2019-11-18T02:24:04+0000"}}}
</script>
<meta property="fb:pages" content="143669659002741">
<meta property="fb:app_id" content="80517230974">
<meta property="og:site_name" content="Green Car Reports">
<meta property="og:type" content="article">
<meta property="og:url" content="https://www.greencarreports.com/news/1128304_ford-mustang-mach-e-electric-suv-5-geeky-details-show-ford-s-commitment-to-evs">
<meta property="og:title" content="Ford Mustang Mach-E electric SUV: 5 geeky details show Ford's commitment to EVs">
<meta property="og:description" content="Ford's electric-vehicle chief, Mark Kaufman, revealed more details about Ford's upcoming electric vehicle that will make it different than anything else from the Blue Oval.">
<meta property="og:image" content="https://images.hgmsites.net/hug/2021-ford-mustang-mach-e_100723928_h.jpg">
<meta property="twitter:card" content="summary_large_image">
<meta property="twitter:site" content="@GreenCarReports">
<meta property="twitter:creator" content="@ben_gt">
<meta property="twitter:title" content="Ford Mustang Mach-E electric SUV: 5 geeky details show Ford's commitment to EVs">
<meta property="twitter:description" content="Ford's electric-vehicle chief, Mark Kaufman, revealed more details about Ford's upcoming electric vehicle that will make it different than anything else from the Blue Oval.">
<meta property="twitter:image" content="https://images.hgmsites.net/hug/2021-ford-mustang-mach-e_100723928_h.jpg">
<link href="https://feeds.highgearmedia.com/?sites=GreenCarReports" rel="alternate" type="application/rss+xml" title="Green Car Reports News">
<link href="/favicon.ico" rel="shortcut icon" type="image/x-icon">
<link href="/css/app.css?id=4d3226b7be36f8f6fa15" rel="stylesheet">
<style>
.rail-box.most-popular{padding:0;background:transparent}.rail-box.most-popular:after{content:"";display:table;clear:both}.rail-box.most-popular .item{height:204px;color:#fff;padding:4em 2em;-webkit-box-sizing:border-box;box-sizing:border-box;position:relative;background-size:cover}@media (max-width:1023px){.rail-box.most-popular .item{width:33%;float:left}}@media (max-width:768px){.rail-box.most-popular .item{width:50%;float:left}}@media (max-width:414px){.rail-box.most-popular .item{width:100%}}.rail-box.most-popular .item .overlay{background-color:#000;opacity:.5}.rail-box.most-popular .item .info{display:-webkit-box;display:-ms-flexbox;display:flex;-webkit-box-orient:vertical;-webkit-box-direction:normal;-ms-flex-direction:column;flex-direction:column;-webkit-box-pack:justify;-ms-flex-pack:justify;justify-content:space-between;-webkit-box-sizing:border-box;box-sizing:border-box;position:absolute;width:86%;height:63%}@media (max-width:768px){.rail-box.most-popular .item .info{width:89%}}.rail-box.most-popular .item .info .comment,.rail-box.most-popular .item .info .date{text-transform:uppercase;font-size:12px;font-weight:400;line-height:1}.rail-box.most-popular .item .info .comment a,.rail-box.most-popular .item .info .title a{color:#fff}.rail-box.most-popular .item .info .title{font-size:18px;font-weight:600;line-height:1.25}@media (max-width:768px){.rail-box.most-popular .item .info .title{font-size:16.8px;font-weight:600;line-height:1.2}}
</style>
<script src="/js/head.js?id=6b7e38311ef801f85ac9"></script>
<script async src="https://confiant-integrations.global.ssl.fastly.net/cVCBi6sio0Kr78j5IZSJs1SQ8No/gpt_and_prebid/config.js"></script>
<script async src="https://js-sec.indexww.com/ht/p/184397-164216896053308.js"></script> <script async src="https://cdn.districtm.ca/merge/merge.116298.js"></script> <script async src="https://internetbrands-d.openx.net/w/1.0/jstag?nc=2922-GreenCarReports"></script> <script class="kxct" data-id="sh2lfhber" data-timing="async" data-version="3.0">
                    window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);
                    (function(){
                        function retrieve(n){
                            var k='kx'+'internetbrands_'+n, ls=(function(){
                                try {
                                    return window.localStorage;
                                } catch(e) {
                                    return null;
                                }
                            })();
                            if (ls) {
                                return ls[k] || '';
                            } else if (navigator.cookieEnabled) {
                                var m = document.cookie.match(k+'=([^;]*)');
                                return (m && unescape(m[1])) || '';
                            } else {
                                return '';
                            }
                        }
                        Krux.user = retrieve('user');
                        Krux.segments = retrieve('segs').split(',');
                    })();
                </script>
<script async src="https://cdn.krxd.net/controltag/sh2lfhber.js"></script>
<script>
    var gptadslots = [],
        googletag = googletag || {};
    googletag.cmd = googletag.cmd || [];
    (function(){
        var gads = document.createElement('script');
        var useSSL = 'https:' === document.location.protocol;
        gads.async = true;
        gads.type = 'text/javascript';
        gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
        var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(gads, node);
    })();
</script>
<script>
        hgmads.setAdUnitBasePath('/2922/greencarreports.tmus');
</script>
<script>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</script>
<script>
    !function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function()
        {q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];
        g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

    // initialize apstag and have apstag set bids on the googletag slots when they are returned to the page
    apstag.init({
        pubID:'3188',
        adServer:'googletag',
        bidTimeout:2e3
    });


</script>
<script>
        googletag.cmd.push(function() {
                                        hgmads.addStaticSlotById('ad-top');
                hgmads.addApsStaticSlot( {slotID:'ad-top' ,sizes:[[728, 90]], slotName:'/2922/greencarreports.tmus/newsarticle/728x90_top_ad-top'} );
                hgmads.addLazySlotById('ad-top');
                hgmads.addApsLazySlot( {slotID:'ad-top' ,sizes:[[728, 90]], slotName:'/2922/greencarreports.tmus/newsarticle/728x90_top_ad-top'} );
            
                                                var callbackFunction = new hgmads.CallbackFunctionContainer('ad-top', "$(window).trigger('resize.px.parallax')", "", 'false', 'slotRenderEnded', 'true');
                    hgmads.addCallback(callbackFunction);
                                    var callbackFunction = new hgmads.CallbackFunctionContainer('ad-top', "hgmads.startStickyTimer", "6", 'true', 'slotRenderEnded', 'true');
                    hgmads.addCallback(callbackFunction);
                                        hgmads.addTrottleInterval('ad-top', 2);
                                    hgmads.addLazySlotById('ad-a-2');
                hgmads.addApsLazySlot( {slotID:'ad-a-2' ,sizes:[[300, 250]], slotName:'/2922/greencarreports.tmus/newsarticle/300x250_content-bottom_ad-a-2'} );

            
                        hgmads.addTrottleInterval('ad-a-2', 2);
                                    hgmads.addStaticSlotById('ad-a-3');
                hgmads.addApsStaticSlot( {slotID:'ad-a-3' ,sizes:[[300, 250]], slotName:'/2922/greencarreports.tmus/newsarticle/300x250_d-side-rail-top_ad-a-3'} );
            
                        hgmads.addTrottleInterval('ad-a-3', 2);
                                    hgmads.addLazySlotById('ad-a-4');
                hgmads.addApsLazySlot( {slotID:'ad-a-4' ,sizes:[[300, 250]], slotName:'/2922/greencarreports.tmus/newsarticle/300x250_news-letter-center_ad-a-4'} );

            
                        hgmads.addTrottleInterval('ad-a-4', 2);
                                    hgmads.addLazySlotById('ad-a-5');
                hgmads.addApsLazySlot( {slotID:'ad-a-5' ,sizes:[[300, 250]], slotName:'/2922/greencarreports.tmus/newsarticle/300x250_d-side-rail-bottom_ad-a-5'} );

            
                                                var callbackFunction = new hgmads.CallbackFunctionContainer('ad-a-5', "hgmads.refreshOnScroll", "", 'true', 'slotRenderEnded', 'true');
                    hgmads.addCallback(callbackFunction);
                                        hgmads.addTrottleInterval('ad-a-5', 6);
                                    hgmads.addStaticSlotById('bottom-sticky');
                hgmads.addApsStaticSlot( {slotID:'bottom-sticky' ,sizes:[[320, 50]], slotName:'/2922/greencarreports.tmus/newsarticle/320x50_bottom-sticky_bottom-sticky'} );
                hgmads.addLazySlotById('bottom-sticky');
                hgmads.addApsLazySlot( {slotID:'bottom-sticky' ,sizes:[[320, 50]], slotName:'/2922/greencarreports.tmus/newsarticle/320x50_bottom-sticky_bottom-sticky'} );
            
                                                var callbackFunction = new hgmads.CallbackFunctionContainer('bottom-sticky', "hgmads.startStickyTimer", "0, bottom", 'true', 'slotRenderEnded', 'true');
                    hgmads.addCallback(callbackFunction);
                                    var callbackFunction = new hgmads.CallbackFunctionContainer('bottom-sticky', "hgmads.refreshOnScroll", "", 'true', 'slotRenderEnded', 'true');
                    hgmads.addCallback(callbackFunction);
                                        hgmads.addTrottleInterval('bottom-sticky', 5);
                                    hgmads.addStaticSlotById('ad-a-1');
                hgmads.addApsStaticSlot( {slotID:'ad-a-1' ,sizes:[[1, 1]], slotName:'/2922/greencarreports.tmus/newsarticle/1x1_OOP_ad-a-1'} );
            
                                                var callbackFunction = new hgmads.CallbackFunctionContainer('ad-a-1', "hgmads.disableByMediaQuery", "(max-width: 1350px)", 'true', 'renderStaticAds', 'true');
                    hgmads.addCallback(callbackFunction);
                                        hgmads.addTrottleInterval('ad-a-1', 2);
                }); // cmd push
                                                        hgmads.addWaypointSlot('ad-a-2', {fetchMarginPercent: '200%', renderMarginPercent: '150%'});
                                                                    hgmads.addWaypointSlot('ad-a-4', {fetchMarginPercent: '200%', renderMarginPercent: '150%'});
                                                hgmads.addWaypointSlot('ad-a-5', {fetchMarginPercent: '200%', renderMarginPercent: '150%'});
                                                                    googletag.cmd.push(function() {
            hgmads.renderStaticAds();
        });
    </script>
</head>
<body>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M73XHX4"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<header>
<div class="nav-container">
<nav>
<div class="mobile-menu"><a class="toggle-device-nav" href="#"></a></div>
<div class="logo"><a href="/" title="Green Car Reports"></a></div>
<div class="nav-items">
<ul>
<li><a class="nav-link" data-menu="news" href="/news">News</a></li>
<li><a class="nav-link" href="/news/first-drives">First Drives</a></li>
<li><a class="nav-link" href="/news/electric-cars">Electric Cars</a></li>
<li><a class="nav-link" href="/news/hybrid-cars">Hybrids</a></li>
<li><a class="nav-link" href="/news/buying-guides">Guides</a></li>
<li><a class="nav-link" href="/news/green-life">Green Life</a></li>
<li class="desktop-newsletter"><a class="nav-link-btn" data-menu="newsletter" href="javascript:void(0)" title="Newsletter Signup"><img src="/images/envelope.svg" />newsletter</a></li>
</ul>
</div>
<div class="search">
<a class="nav-link-search" data-menu="search" href="javascript:void(0)" title="Search"></a>
</div>
</nav>
</div>
<div class="adv-spacer-top-wraper">
<div class="adv-spacer top ">
<div id="ad-top"></div>
</div>
</div>
<div id="breadcrumbs">
<a href="/">Home</a>
<span> / </span>
<a href="/news">News</a>
<span> / </span>
<a href="/news/electric-cars">Electric Cars</a>
</div>
</header>
<div id="main">
<div class="hidden-slot" id="ad-a-1"></div>
<script>
        window.disqus_domain = 'https://www.greencarreports.com';
        window.disqus_shortname = 'greencarreports';
        window.disqus_key = 'NCF9QGiigz0WoG2RAdgNHu0h4WSUWoLkzI4RZJ6UisUx951obo7XTL1BigknDT9P';
    </script>
<script>
            var xpath = 'insertAfter(p[3])',
                sizes = [[300, 250]],
                zone = 'newsarticle',
                pos = 'm-center',
                sizeW = '300',
                sizeH = '250',
                adClasses = 'adv-spacer',
                adSizeMap = [],
                label = '',
                throttleInterval = 2;

            var targets = [];
            targets.push( {'kw': ["m-center"] });
            targets.push( {'sz': ["300x250"] });
                                        targets.push( {'tags': ["ford,technology,electric-cars,mustang-mach-e"]} );
                                                                targets.push( {'make': ["ford"]} );
                                        targets.push( {'model': ["mustang-mach-e"]} );
                                                        targets.push( {'page': ["blog-post-article"]});
                targets.push( {'variation': window.hgm_variation || ''});

                                                adSizeMap.push({'viewport':  [0,0] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [1280,800] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [600,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [800,600] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [320,300] ,'map': [[300,250]]  }) ;
                            
            var callbackFunctions = false;
            
            var wayPointConfig = false;
                        hgmads.addDynamicSlot(xpath, sizes, targets, zone, pos, sizeW, sizeH, adClasses, adSizeMap, label, callbackFunctions, throttleInterval, wayPointConfig);
        </script>
<script>
            var xpath = 'appendTo(.adv-container .adv-spacer-top)',
                sizes = [[300, 250]],
                zone = 'newsarticle',
                pos = 'd-media-pop-up-top_m-media-pop-up-bottom',
                sizeW = '300',
                sizeH = '250',
                adClasses = '',
                adSizeMap = [],
                label = '',
                throttleInterval = 2;

            var targets = [];
            targets.push( {'kw': ["d-media-pop-up-top_m-media-pop-up-bottom"] });
            targets.push( {'sz': ["300x250"] });
                                        targets.push( {'tags': ["ford,technology,electric-cars,mustang-mach-e"]} );
                                                                targets.push( {'make': ["ford"]} );
                                        targets.push( {'model': ["mustang-mach-e"]} );
                                                        targets.push( {'page': ["blog-post-article"]});
                targets.push( {'variation': window.hgm_variation || ''});

                                                adSizeMap.push({'viewport':  [0,0] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [1280,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [1280, 600] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [600,800] ,'map': [[320,50]]  }) ;
                                    adSizeMap.push({'viewport':  [800,600] ,'map': [[728,90]]  }) ;
                                    adSizeMap.push({'viewport':  [320,300] ,'map': [[320,50]]  }) ;
                            
            var callbackFunctions = false;
            
            var wayPointConfig = false;
                        hgmads.addDynamicSlot(xpath, sizes, targets, zone, pos, sizeW, sizeH, adClasses, adSizeMap, label, callbackFunctions, throttleInterval, wayPointConfig);
        </script>
<script>
            var xpath = 'appendTo(.adv-container .adv-spacer-bottom)',
                sizes = [[300, 250]],
                zone = 'newsarticle',
                pos = 'd-media-pop-up-bottom_m-media-pop-up-bottom',
                sizeW = '300',
                sizeH = '250',
                adClasses = '',
                adSizeMap = [],
                label = '',
                throttleInterval = 2;

            var targets = [];
            targets.push( {'kw': ["d-media-pop-up-bottom_m-media-pop-up-bottom"] });
            targets.push( {'sz': ["300x250"] });
                                        targets.push( {'tags': ["ford,technology,electric-cars,mustang-mach-e"]} );
                                                                targets.push( {'make': ["ford"]} );
                                        targets.push( {'model': ["mustang-mach-e"]} );
                                                        targets.push( {'page': ["blog-post-article"]});
                targets.push( {'variation': window.hgm_variation || ''});

                                                adSizeMap.push({'viewport':  [0,0] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [1280,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [1280, 600] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [600,800] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [800,600] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [320,300] ,'map': []  }) ;
                            
            var callbackFunctions = false;
            
            var wayPointConfig = false;
                        hgmads.addDynamicSlot(xpath, sizes, targets, zone, pos, sizeW, sizeH, adClasses, adSizeMap, label, callbackFunctions, throttleInterval, wayPointConfig);
        </script>
<script>
            var xpath = 'appendTo(.video-popup-sidebar .adv-spacer-top)',
                sizes = [[300, 250]],
                zone = 'newsarticle',
                pos = 'd-media-pop-up-top_m-media-pop-up-bottom',
                sizeW = '300',
                sizeH = '250',
                adClasses = '',
                adSizeMap = [],
                label = '',
                throttleInterval = 2;

            var targets = [];
            targets.push( {'kw': ["d-media-pop-up-top_m-media-pop-up-bottom"] });
            targets.push( {'sz': ["300x250"] });
                                        targets.push( {'tags': ["ford,technology,electric-cars,mustang-mach-e"]} );
                                                                targets.push( {'make': ["ford"]} );
                                        targets.push( {'model': ["mustang-mach-e"]} );
                                                        targets.push( {'page': ["blog-post-article"]});
                targets.push( {'variation': window.hgm_variation || ''});

                                                adSizeMap.push({'viewport':  [0,0] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [1280,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [600,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [800,600] ,'map': [[320,50]]  }) ;
                                    adSizeMap.push({'viewport':  [320,300] ,'map': [[320,50]]  }) ;
                            
            var callbackFunctions = false;
            
            var wayPointConfig = false;
                        hgmads.addDynamicSlot(xpath, sizes, targets, zone, pos, sizeW, sizeH, adClasses, adSizeMap, label, callbackFunctions, throttleInterval, wayPointConfig);
        </script>
<script>
            var xpath = 'appendTo(.video-popup-sidebar .adv-spacer-bottom)',
                sizes = [[300, 250]],
                zone = 'newsarticle',
                pos = 'd-media-pop-up-bottom_m-media-pop-up-bottom',
                sizeW = '300',
                sizeH = '250',
                adClasses = '',
                adSizeMap = [],
                label = '',
                throttleInterval = 2;

            var targets = [];
            targets.push( {'kw': ["d-media-pop-up-bottom_m-media-pop-up-bottom"] });
            targets.push( {'sz': ["300x250"] });
                                        targets.push( {'tags': ["ford,technology,electric-cars,mustang-mach-e"]} );
                                                                targets.push( {'make': ["ford"]} );
                                        targets.push( {'model': ["mustang-mach-e"]} );
                                                        targets.push( {'page': ["blog-post-article"]});
                targets.push( {'variation': window.hgm_variation || ''});

                                                adSizeMap.push({'viewport':  [0,0] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [1280,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [600,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [800,600] ,'map': [[320,50]]  }) ;
                                    adSizeMap.push({'viewport':  [320,300] ,'map': [[320,50]]  }) ;
                            
            var callbackFunctions = false;
            
            var wayPointConfig = false;
                        hgmads.addDynamicSlot(xpath, sizes, targets, zone, pos, sizeW, sizeH, adClasses, adSizeMap, label, callbackFunctions, throttleInterval, wayPointConfig);
        </script>
<div class="article-block" data-id="1128304" data-url="/news/1128304_ford-mustang-mach-e-electric-suv-5-geeky-details-show-ford-s-commitment-to-evs" data-title="Ford Mustang Mach-E electric SUV: 5 geeky details show Ford&#039;s commitment to EVs" data-next-id="1128301" data-infinite-scroll="false" data-min-comments="1">
<section class="hero-wrap-parallax parallax-window   gallery " data-image-src-h="https://images.hgmsites.net/hug/2021-ford-mustang-mach-e_100723928_h.jpg" data-image-src-l="https://images.hgmsites.net/lrg/2021-ford-mustang-mach-e_100723928_l.jpg" data-image-src-m="https://images.hgmsites.net/med/2021-ford-mustang-mach-e_100723928_m.jpg" data-image-src-s="https://images.hgmsites.net/sml/2021-ford-mustang-mach-e_100723928_s.jpg">
<div class="hero-nav prev"></div>
<div class="hero-nav next"></div>
<div class="overlay"></div>
<div class="hero-inner-wrap">
<div class="left-col">
<header class="title-wrap">
<h1 class="article-title"><span>Ford Mustang Mach-E electric SUV: 5 geeky details show Ford&#039;s commitment to EVs</span></h1>
<div class="portrait-wrapper">
<a href="/writer/10001004_bengt-halvorson" class="portrait">
<img src="https://images.hgmsites.net/sml/avatar-image-for-bengt_100544847_s.jpg" alt="Bengt Halvorson">
</a>
</div>
<a href="/writer/10001004_bengt-halvorson" rel="author" class="by-line">
Bengt Halvorson
</a>
<time datetime="2020-05-28T15:00:00+0000">
May 28, 2020
</time>
<a href="javascript:void(0)" class="comments-link">
<i class="icon fas fa-comments"></i><span>Comment Now!</span>
</a>
<div class="gallery-btn" data-article-id="1128304">
<span class="gallery-icon"></span>
View Gallery
</div>
</header>
</div>
<div class="right-col"></div>
</div>
</section>
<div class="article-wrap">
<div class="left-col">
<div class="highres-gallery">
<div class="highres-gallery-wrapper">
<div class="item gallery-image" data-image-id="100723928">
<img data-id="100723928" src="https://cimg0.ibsrv.net/ibimg/hgm/1920x1080-1/100/723/2021-ford-mustang-mach-e_100723928.jpg" alt="2021 Ford Mustang Mach-E" srcset="https://cimg0.ibsrv.net/ibimg/hgm/600x338-1/100/723/2021-ford-mustang-mach-e_100723928.jpg 600w, https://cimg0.ibsrv.net/ibimg/hgm/400x225-1/100/723/2021-ford-mustang-mach-e_100723928.jpg 400w, https://cimg0.ibsrv.net/ibimg/hgm/300x169-1/100/723/2021-ford-mustang-mach-e_100723928.jpg 300w, https://cimg0.ibsrv.net/ibimg/hgm/200x113-1/100/723/2021-ford-mustang-mach-e_100723928.jpg 200w, https://cimg0.ibsrv.net/ibimg/hgm/150x84-1/100/723/2021-ford-mustang-mach-e_100723928.jpg 150w" sizes="(min-width: 768px) 200px, (min-width: 300px) 300px, calc(50vw - 1em)">
</div>
<div class="item gallery-image" data-image-id="100723942">
<img data-id="100723942" src="https://cimg2.ibsrv.net/ibimg/hgm/1920x1080-1/100/723/2021-ford-mustang-mach-e_100723942.jpg" alt="2021 Ford Mustang Mach-E" srcset="https://cimg2.ibsrv.net/ibimg/hgm/600x338-1/100/723/2021-ford-mustang-mach-e_100723942.jpg 600w, https://cimg2.ibsrv.net/ibimg/hgm/400x225-1/100/723/2021-ford-mustang-mach-e_100723942.jpg 400w, https://cimg2.ibsrv.net/ibimg/hgm/300x169-1/100/723/2021-ford-mustang-mach-e_100723942.jpg 300w, https://cimg2.ibsrv.net/ibimg/hgm/200x113-1/100/723/2021-ford-mustang-mach-e_100723942.jpg 200w, https://cimg2.ibsrv.net/ibimg/hgm/150x84-1/100/723/2021-ford-mustang-mach-e_100723942.jpg 150w" sizes="(min-width: 768px) 200px, (min-width: 300px) 300px, calc(50vw - 1em)">
</div>
<div class="item gallery-image" data-image-id="100723938">
<img data-id="100723938" src="https://cimg2.ibsrv.net/ibimg/hgm/1920x1080-1/100/723/2021-ford-mustang-mach-e_100723938.jpg" alt="2021 Ford Mustang Mach-E" srcset="https://cimg2.ibsrv.net/ibimg/hgm/600x338-1/100/723/2021-ford-mustang-mach-e_100723938.jpg 600w, https://cimg2.ibsrv.net/ibimg/hgm/400x225-1/100/723/2021-ford-mustang-mach-e_100723938.jpg 400w, https://cimg2.ibsrv.net/ibimg/hgm/300x169-1/100/723/2021-ford-mustang-mach-e_100723938.jpg 300w, https://cimg2.ibsrv.net/ibimg/hgm/200x113-1/100/723/2021-ford-mustang-mach-e_100723938.jpg 200w, https://cimg2.ibsrv.net/ibimg/hgm/150x84-1/100/723/2021-ford-mustang-mach-e_100723938.jpg 150w" sizes="(min-width: 768px) 200px, (min-width: 300px) 300px, calc(50vw - 1em)">
</div>
<div class="item gallery-image" data-image-id="100723937">
<img data-id="100723937" src="https://cimg1.ibsrv.net/ibimg/hgm/1920x1080-1/100/723/2021-ford-mustang-mach-e_100723937.jpg" alt="2021 Ford Mustang Mach-E" srcset="https://cimg1.ibsrv.net/ibimg/hgm/600x338-1/100/723/2021-ford-mustang-mach-e_100723937.jpg 600w, https://cimg1.ibsrv.net/ibimg/hgm/400x225-1/100/723/2021-ford-mustang-mach-e_100723937.jpg 400w, https://cimg1.ibsrv.net/ibimg/hgm/300x169-1/100/723/2021-ford-mustang-mach-e_100723937.jpg 300w, https://cimg1.ibsrv.net/ibimg/hgm/200x113-1/100/723/2021-ford-mustang-mach-e_100723937.jpg 200w, https://cimg1.ibsrv.net/ibimg/hgm/150x84-1/100/723/2021-ford-mustang-mach-e_100723937.jpg 150w" sizes="(min-width: 768px) 200px, (min-width: 300px) 300px, calc(50vw - 1em)">
</div>
<div class="item gallery-image" data-image-id="100723936">
<img data-id="100723936" src="https://cimg0.ibsrv.net/ibimg/hgm/1920x1080-1/100/723/2021-ford-mustang-mach-e_100723936.jpg" alt="2021 Ford Mustang Mach-E" srcset="https://cimg0.ibsrv.net/ibimg/hgm/600x338-1/100/723/2021-ford-mustang-mach-e_100723936.jpg 600w, https://cimg0.ibsrv.net/ibimg/hgm/400x225-1/100/723/2021-ford-mustang-mach-e_100723936.jpg 400w, https://cimg0.ibsrv.net/ibimg/hgm/300x169-1/100/723/2021-ford-mustang-mach-e_100723936.jpg 300w, https://cimg0.ibsrv.net/ibimg/hgm/200x113-1/100/723/2021-ford-mustang-mach-e_100723936.jpg 200w, https://cimg0.ibsrv.net/ibimg/hgm/150x84-1/100/723/2021-ford-mustang-mach-e_100723936.jpg 150w" sizes="(min-width: 768px) 200px, (min-width: 300px) 300px, calc(50vw - 1em)">
</div>
<div class="item gallery-image count count-17">
<span class="primary-color">22</span>
<div>photos</div>
</div>
</div>
</div>
<header class="title-wrap">
<h1 class="article-title"><span>Ford Mustang Mach-E electric SUV: 5 geeky details show Ford&#039;s commitment to EVs</span></h1>
<div class="portrait-wrapper">
<a href="/writer/10001004_bengt-halvorson" class="portrait">
<img src="https://images.hgmsites.net/sml/avatar-image-for-bengt_100544847_s.jpg" alt="Bengt Halvorson">
</a>
</div>
<a href="/writer/10001004_bengt-halvorson" rel="author" class="by-line">
Bengt Halvorson
</a>
<time datetime="2020-05-28T15:00:00+0000">
May 28, 2020
</time>
<a href="javascript:void(0)" class="comments-link">
<i class="icon fas fa-comments"></i><span>Comment Now!</span>
</a>
</header>
<article class="content article-style  gcr-article ">
<section class="article-body">
<p dir="ltr">A special group within Ford, called Team Edison, has been navigating a daunting challenge—to thread the needle <a href="https://www.greencarreports.com/news/1126324_2021-ford-mustang-mach-e-electric-suv-how-project-went-from-milquetoast-to-mustang">between performance enthusiasts and tech-savvy electric-car fans</a>, assuring that the inner workings of a mammoth company wouldn’t stifle the project along the way. </p>
<p dir="ltr">That project, the <a href="https://www.greencarreports.com/news/1126066_2021-ford-mustang-mach-e-preview-electric-suv-targeting-300-mile-range">2021 Ford Mustang Mach-E</a>, remains due for first deliveries later this year. And even though Ford has already revealed <a href="https://www.greencarreports.com/news/1126112_five-things-we-didn-t-expect-in-the-2021-ford-mustang-mach-e-electric-suv">many interesting details</a> for this important EV—and <em>Green Car Reports</em> has already <a href="https://www.greencarreports.com/news/1126069_we-rode-in-the-2021-ford-mustang-mach-e-here-s-what-it-felt-like">had a ride in one</a>—we're still discovering new details about what makes this project so different.</p><div class="nativo-article-slot"></div>
<p dir="ltr">In a Q&amp;A session Wednesday with members of the automotive press, Mark Kaufman, the company’s global director of electrification, provided a number of rather geeky details about the Mach-E that show the company is spending extra effort to be used for a multitude of future EV models. Here are five such nuggets.</p>
<p dir="ltr"><strong>There are at least two battery “tunes”</strong></p>
<p dir="ltr">The Mach-E has to satisfy those who want a 300-mile range, while also satisfying those who buy the high-performance GT and use it mostly in its high-performance "Unbridled" mode. Within the Extended Range battery option, the team established a dividing line between the rear-wheel-drive version and the all-wheel-drive version, and corresponding differences in the battery design.</p>
<p dir="ltr">“The all-wheel drive delivers the performance, and because of that performance the team even had to design the battery and how the battery’s used a bit differently so that it can actually pull power out faster,” Kaufman said. “So there’s the tradeoff as the team approached it.”</p>
<p dir="ltr"></p><div class="image_wrapper"><img name="tccimg_100723941_l" title="2021 Ford Mustang Mach-E" src="data:image/png;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs=" alt="2021 Ford Mustang Mach-E" width="1024" height="768" data-width="1024" data-height="768" data-url="https://images.hgmsites.net/lrg/2021-ford-mustang-mach-e_100723941_l.jpg" data-src="https://images.hgmsites.net/lrg/2021-ford-mustang-mach-e_100723941_l.jpg" class="lazy"><p>2021 Ford Mustang Mach-E</p></div>
<p dir="ltr"><strong>It’s a rapid-prototyping prodigy</strong></p>
<p dir="ltr">Under CEO Jim Hackett, Ford has focused more on a strategy of rapid prototyping to get the best designs possible—and even pushing ideas out for testing on consumers very early in the process, when they are just sketches or loose mockups. Kaufman says that a lot of the early work Ford did with rapid prototyping, and in China, helped influence some of the design-interface aspects of the Mach-E, particularly the big 15.5-inch screen size. </p>
<p dir="ltr">Rapid prototyping for the Mach-E’s interface started about two and a half years ago, and early on they learned that customers appreciated still having a volume knob without having to look at the screen. Kaufman said that the clever solution the team came up with involves bypassing a potentially complex switch behind the screen and instead using very small “fingers” behind the knob that press and swipe against a particular zone of the screen. </p>
<div class="hgmLayout hgmLayout1x2"><div class="image_wrapper"><img name="tccimg_100723940_l" title="2021 Ford Mustang Mach-E" src="data:image/png;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs=" alt="2021 Ford Mustang Mach-E" width="1024" height="576" data-width="1024" data-height="576" data-url="https://images.hgmsites.net/lrg/2021-ford-mustang-mach-e_100723940_l.jpg" data-src="https://images.hgmsites.net/lrg/2021-ford-mustang-mach-e_100723940_l.jpg" class="lazy"><p>2021 Ford Mustang Mach-E</p></div><div class="image_wrapper"><img name="tccimg_100723939_l" title="2021 Ford Mustang Mach-E" src="data:image/png;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs=" alt="2021 Ford Mustang Mach-E" width="1024" height="768" data-width="1024" data-height="768" data-url="https://images.hgmsites.net/lrg/2021-ford-mustang-mach-e_100723939_l.jpg" data-src="https://images.hgmsites.net/lrg/2021-ford-mustang-mach-e_100723939_l.jpg" class="lazy"><p>2021 Ford Mustang Mach-E</p></div><div class="image_wrapper"><img name="tccimg_100723938_l" title="2021 Ford Mustang Mach-E" src="data:image/png;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs=" alt="2021 Ford Mustang Mach-E" width="1024" height="768" data-width="1024" data-height="768" data-url="https://images.hgmsites.net/lrg/2021-ford-mustang-mach-e_100723938_l.jpg" data-src="https://images.hgmsites.net/lrg/2021-ford-mustang-mach-e_100723938_l.jpg" class="lazy"><p>2021 Ford Mustang Mach-E</p></div></div>
<p dir="ltr"><strong>That big screen displays in html!</strong></p>
<p dir="ltr">The so-called Sync 4A system that makes its debut in the Mach-E is different than those in other current Ford vehicles, and rather than being hard-coded like Ford’s previous infotainment systems, it displays in the now-common HTML5, like the device you’re reading this on. Kaufman called it a breakthrough, as it lets the system customize the layout and move some of your most frequently used features to the foreground. It also allows for future upgrades that might completely change the look.</p>
<p dir="ltr"></p><div class="image_wrapper"><img name="tccimg_100724859_l" title="2021 Ford Mustang Mach-E, 2019 LA Auto Show" src="data:image/png;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs=" alt="2021 Ford Mustang Mach-E, 2019 LA Auto Show" width="1024" height="682" data-width="1024" data-height="682" data-url="https://images.hgmsites.net/lrg/2021-ford-mustang-mach-e_100724859_l.jpg" data-src="https://images.hgmsites.net/lrg/2021-ford-mustang-mach-e_100724859_l.jpg" class="lazy"><p>2021 Ford Mustang Mach-E, 2019 LA Auto Show</p></div>
<p dir="ltr"><strong>There’s a cybersecurity team behind the over-the-air updates</strong></p>
<p dir="ltr">Ford has an in-house cybersecurity team that’s simultaneously looking at complying with privacy laws but also making sure that the systems are being protected. “In some ways I would say it’s probably slowed us down just a little bit from where we’d like to be,” Kaufman said (just after discussing the <a href="https://www.greencarreports.com/news/1128123_2021-ford-mustang-mach-e-electric-suv-cues-a-shift-to-over-the-air-updates">Mach-E’s capability for regular over-the-air updates</a>). "We take our customer trust very seriously,” he added. </p>
<p dir="ltr"></p><div class="image_wrapper"><img name="tccimg_100723944_l" title="2021 Ford Mustang Mach-E" src="data:image/png;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs=" alt="2021 Ford Mustang Mach-E" width="1024" height="768" data-width="1024" data-height="768" data-url="https://images.hgmsites.net/lrg/2021-ford-mustang-mach-e_100723944_l.jpg" data-src="https://images.hgmsites.net/lrg/2021-ford-mustang-mach-e_100723944_l.jpg" class="lazy"><p>2021 Ford Mustang Mach-E</p></div>
<p dir="ltr"><strong>Ford’s Autopilot and Super Cruise rival: coming soon over the air?</strong></p>
<p dir="ltr">The Mach-E will be one of the first mass-produced models on the market—Tesla aside—to allow over-the-updates for top-level features like vehicle firmware. Ford expects to offer its first updates for the Mach-E within six months of first deliveries. Kaufman provided a further hint: Within the first six months it will have “an additional Driver Assist capability that can be downloaded.” </p>
<p dir="ltr">Kaufman didn’t say whether that’s alluding to the optional assist system that Ford plans to dispatch to the Mach-E, to rival <a href="https://www.greencarreports.com/news/1122230_tesla-autopilot-ranks-next-to-last-in-study-of-self-driving-systems">Tesla’s Autopilot and GM’s Super Cruise</a>, and delivered via electronic purchase. But it sure sounds like it.</p>
</section>
<section class="footer">
<div class="highres-gallery">
<div class="title">
High-Res Gallery:
<a href="#" onClick="hgm.openGallery(1128304, null, 100723928); return false;">
2021 Ford Mustang Mach-E
</a>
</div>
<div class="highres-gallery-wrapper">
<div class="item gallery-image" data-image-id="100723928">
<img class="lazy" data-id="100723928" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg0.ibsrv.net/ibimg/hgm/1920x1080-1/100/723/2021-ford-mustang-mach-e_100723928.jpg" alt="2021 Ford Mustang Mach-E" data-srcset="https://cimg0.ibsrv.net/ibimg/hgm/600x338-1/100/723/2021-ford-mustang-mach-e_100723928.jpg 600w, https://cimg0.ibsrv.net/ibimg/hgm/400x225-1/100/723/2021-ford-mustang-mach-e_100723928.jpg 400w, https://cimg0.ibsrv.net/ibimg/hgm/300x169-1/100/723/2021-ford-mustang-mach-e_100723928.jpg 300w, https://cimg0.ibsrv.net/ibimg/hgm/200x113-1/100/723/2021-ford-mustang-mach-e_100723928.jpg 200w, https://cimg0.ibsrv.net/ibimg/hgm/150x84-1/100/723/2021-ford-mustang-mach-e_100723928.jpg 150w" sizes="(min-width: 768px) 200px, (min-width: 300px) 300px, calc(50vw - 1em)">
</div>
<div class="item gallery-image" data-image-id="100723942">
<img class="lazy" data-id="100723942" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg2.ibsrv.net/ibimg/hgm/1920x1080-1/100/723/2021-ford-mustang-mach-e_100723942.jpg" alt="2021 Ford Mustang Mach-E" data-srcset="https://cimg2.ibsrv.net/ibimg/hgm/600x338-1/100/723/2021-ford-mustang-mach-e_100723942.jpg 600w, https://cimg2.ibsrv.net/ibimg/hgm/400x225-1/100/723/2021-ford-mustang-mach-e_100723942.jpg 400w, https://cimg2.ibsrv.net/ibimg/hgm/300x169-1/100/723/2021-ford-mustang-mach-e_100723942.jpg 300w, https://cimg2.ibsrv.net/ibimg/hgm/200x113-1/100/723/2021-ford-mustang-mach-e_100723942.jpg 200w, https://cimg2.ibsrv.net/ibimg/hgm/150x84-1/100/723/2021-ford-mustang-mach-e_100723942.jpg 150w" sizes="(min-width: 768px) 200px, (min-width: 300px) 300px, calc(50vw - 1em)">
</div>
<div class="item gallery-image" data-image-id="100723938">
<img class="lazy" data-id="100723938" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg2.ibsrv.net/ibimg/hgm/1920x1080-1/100/723/2021-ford-mustang-mach-e_100723938.jpg" alt="2021 Ford Mustang Mach-E" data-srcset="https://cimg2.ibsrv.net/ibimg/hgm/600x338-1/100/723/2021-ford-mustang-mach-e_100723938.jpg 600w, https://cimg2.ibsrv.net/ibimg/hgm/400x225-1/100/723/2021-ford-mustang-mach-e_100723938.jpg 400w, https://cimg2.ibsrv.net/ibimg/hgm/300x169-1/100/723/2021-ford-mustang-mach-e_100723938.jpg 300w, https://cimg2.ibsrv.net/ibimg/hgm/200x113-1/100/723/2021-ford-mustang-mach-e_100723938.jpg 200w, https://cimg2.ibsrv.net/ibimg/hgm/150x84-1/100/723/2021-ford-mustang-mach-e_100723938.jpg 150w" sizes="(min-width: 768px) 200px, (min-width: 300px) 300px, calc(50vw - 1em)">
</div>
<div class="item gallery-image" data-image-id="100723937">
<img class="lazy" data-id="100723937" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg1.ibsrv.net/ibimg/hgm/1920x1080-1/100/723/2021-ford-mustang-mach-e_100723937.jpg" alt="2021 Ford Mustang Mach-E" data-srcset="https://cimg1.ibsrv.net/ibimg/hgm/600x338-1/100/723/2021-ford-mustang-mach-e_100723937.jpg 600w, https://cimg1.ibsrv.net/ibimg/hgm/400x225-1/100/723/2021-ford-mustang-mach-e_100723937.jpg 400w, https://cimg1.ibsrv.net/ibimg/hgm/300x169-1/100/723/2021-ford-mustang-mach-e_100723937.jpg 300w, https://cimg1.ibsrv.net/ibimg/hgm/200x113-1/100/723/2021-ford-mustang-mach-e_100723937.jpg 200w, https://cimg1.ibsrv.net/ibimg/hgm/150x84-1/100/723/2021-ford-mustang-mach-e_100723937.jpg 150w" sizes="(min-width: 768px) 200px, (min-width: 300px) 300px, calc(50vw - 1em)">
</div>
<div class="item gallery-image" data-image-id="100723936">
<img class="lazy" data-id="100723936" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg0.ibsrv.net/ibimg/hgm/1920x1080-1/100/723/2021-ford-mustang-mach-e_100723936.jpg" alt="2021 Ford Mustang Mach-E" data-srcset="https://cimg0.ibsrv.net/ibimg/hgm/600x338-1/100/723/2021-ford-mustang-mach-e_100723936.jpg 600w, https://cimg0.ibsrv.net/ibimg/hgm/400x225-1/100/723/2021-ford-mustang-mach-e_100723936.jpg 400w, https://cimg0.ibsrv.net/ibimg/hgm/300x169-1/100/723/2021-ford-mustang-mach-e_100723936.jpg 300w, https://cimg0.ibsrv.net/ibimg/hgm/200x113-1/100/723/2021-ford-mustang-mach-e_100723936.jpg 200w, https://cimg0.ibsrv.net/ibimg/hgm/150x84-1/100/723/2021-ford-mustang-mach-e_100723936.jpg 150w" sizes="(min-width: 768px) 200px, (min-width: 300px) 300px, calc(50vw - 1em)">
</div>
<div class="item gallery-image" data-image-id="100723935">
<img class="lazy" data-id="100723935" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg3.ibsrv.net/ibimg/hgm/1920x1080-1/100/723/2021-ford-mustang-mach-e_100723935.jpg" alt="2021 Ford Mustang Mach-E" data-srcset="https://cimg3.ibsrv.net/ibimg/hgm/600x338-1/100/723/2021-ford-mustang-mach-e_100723935.jpg 600w, https://cimg3.ibsrv.net/ibimg/hgm/400x225-1/100/723/2021-ford-mustang-mach-e_100723935.jpg 400w, https://cimg3.ibsrv.net/ibimg/hgm/300x169-1/100/723/2021-ford-mustang-mach-e_100723935.jpg 300w, https://cimg3.ibsrv.net/ibimg/hgm/200x113-1/100/723/2021-ford-mustang-mach-e_100723935.jpg 200w, https://cimg3.ibsrv.net/ibimg/hgm/150x84-1/100/723/2021-ford-mustang-mach-e_100723935.jpg 150w" sizes="(min-width: 768px) 200px, (min-width: 300px) 300px, calc(50vw - 1em)">
</div>
</div>
</div>
</section>
<div class="article-tags">
<h3>Tags:</h3>
<a href="/news/technology">Car Tech</a>
<a href="/news/electric-cars">Electric Cars</a>
<a href="/news/mustang-mach-e">Ford Mustang Mach-E News</a>
<a href="/news/ford">Ford News</a>
</div>
<div class="article-contribute">
<h3>Contribute:</h3>
<ul>
<li><a href="/aboutus#contact-us">
<i class="icon fas fa-lightbulb"></i> Send us a tip
</a>
<li><a href="javascript:void(0)" class="comments-link">
<i class="icon fas fa-comments"></i><span>Comment</span>
</a>
<li><a href="/aboutus#contact-us">
<i class="icon fas fa-pencil-alt"></i> Contact the editor
</a>
</ul>
</div>
<div class="related-galleries">
<h3>Recommended Galleries</h3>
<div class="related-galleries-wrapper">
<div class="item">
<a href="/news/1128290_2021-bmw-530e-plug-in-hybrid-quicker-but-will-it-go-more-electric-miles" class="image">
<img class="lazy" data-id="100747718" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg2.ibsrv.net/ibimg/hgm/1919x1079-1/100/747/bmw-5-series_100747718.jpg" alt="2021 BMW 5-Series" data-srcset="https://cimg2.ibsrv.net/ibimg/hgm/900x506-1/100/747/bmw-5-series_100747718.jpg 900w, https://cimg2.ibsrv.net/ibimg/hgm/450x253-1/100/747/bmw-5-series_100747718.jpg 450w" sizes="(min-width: 768px) 450px, (min-width: 1024px) 313px, 300px">
</a>
<div class="title">
<a href="/news/1128290_2021-bmw-530e-plug-in-hybrid-quicker-but-will-it-go-more-electric-miles">2021 BMW 530e plug-in hybrid: Quicker, but will it go more electric miles?</a>
</div>
</div>
<div class="item">
<a href="/news/1128270_musk-tesla-cybertruck-won-t-be-downsized-but-smaller-follow-up-truck-a-possibility" class="image">
<img class="lazy" data-id="100747541" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg1.ibsrv.net/ibimg/hgm/1600x900-1/100/747/elon-musk-and-jay-leno-in-tesla-cybertruck_100747541.jpg" alt="Elon Musk and Jay Leno in Tesla Cybertruck" data-srcset="https://cimg1.ibsrv.net/ibimg/hgm/900x506-1/100/747/elon-musk-and-jay-leno-in-tesla-cybertruck_100747541.jpg 900w, https://cimg1.ibsrv.net/ibimg/hgm/450x253-1/100/747/elon-musk-and-jay-leno-in-tesla-cybertruck_100747541.jpg 450w" sizes="(min-width: 768px) 450px, (min-width: 1024px) 313px, 300px">
</a>
<div class="title">
<a href="/news/1128270_musk-tesla-cybertruck-won-t-be-downsized-but-smaller-follow-up-truck-a-possibility">Musk: Tesla Cybertruck won&#039;t be downsized, but smaller follow-up truck a possibility</a>
</div>
</div>
<div class="item">
<a href="/news/1128251_hyundai-kona-electric-the-new-favored-police-patrol-car-for-europe" class="image">
<img class="lazy" data-id="100747362" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg2.ibsrv.net/ibimg/hgm/1920x1080-1/100/747/hyundai-kona-electric-police-cars-in-switzerland_100747362.jpg" alt="Hyundai Kona Electric police cars in Switzerland" data-srcset="https://cimg2.ibsrv.net/ibimg/hgm/900x506-1/100/747/hyundai-kona-electric-police-cars-in-switzerland_100747362.jpg 900w, https://cimg2.ibsrv.net/ibimg/hgm/450x253-1/100/747/hyundai-kona-electric-police-cars-in-switzerland_100747362.jpg 450w" sizes="(min-width: 768px) 450px, (min-width: 1024px) 313px, 300px">
</a>
<div class="title">
<a href="/news/1128251_hyundai-kona-electric-the-new-favored-police-patrol-car-for-europe">Hyundai Kona Electric: The new favored police patrol car for Europe?</a>
</div>
</div>
<div class="item">
<a href="/news/1128254_how-the-sono-sion-electric-car-will-use-every-body-panel-as-a-solar-panel" class="image">
<img class="lazy" data-id="100653154" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg2.ibsrv.net/ibimg/hgm/1070x602-1/100/653/sono-sion-solar-charged-electric-car-solar-panels_100653154.jpg" alt="Sono Sion solar charged electric car solar panels " data-srcset="https://cimg2.ibsrv.net/ibimg/hgm/900x506-1/100/653/sono-sion-solar-charged-electric-car-solar-panels_100653154.jpg 900w, https://cimg2.ibsrv.net/ibimg/hgm/450x253-1/100/653/sono-sion-solar-charged-electric-car-solar-panels_100653154.jpg 450w" sizes="(min-width: 768px) 450px, (min-width: 1024px) 313px, 300px">
</a>
<div class="title">
<a href="/news/1128254_how-the-sono-sion-electric-car-will-use-every-body-panel-as-a-solar-panel">How the Sono Sion electric car will use every body panel as a solar panel</a>
</div>
</div>
</div>
</div>
<div class="adv-spacer">
<div id="ad-a-2"></div>
</div>
<div style="margin-top: 2em" class="footer-block">
<div class="share-this">
<h3>Share This Article:</h3>
<a class="social-btn fab fa-facebook-f facebook" href="javascript:void(0)" title="Share this article on Facebook" onclick="window.open('https://www.facebook.com/sharer.php?t=Ford%20Mustang%20Mach-E%20electric%20SUV%3A%205%20geeky%20details%20show%20Ford%27s%20commitment%20to%20EVs&u=https%3A%2F%2Fwww.greencarreports.com%2Fnews%2F1128304_ford-mustang-mach-e-electric-suv-5-geeky-details-show-ford-s-commitment-to-evs', 'social', 'toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=700, height=300'); hgm.socialShare('Facebook', 'https://www.greencarreports.com/news/1128304_ford-mustang-mach-e-electric-suv-5-geeky-details-show-ford-s-commitment-to-evs');">
</a>
<a class="social-btn fab fa-twitter twitter" href="javascript:void(0)" title="Tweet this article" onclick="window.open('https://twitter.com/intent/tweet?text=Ford%20Mustang%20Mach-E%20electric%20SUV%3A%205%20geeky%20details%20show%20Ford%27s%20commitment%20to%20EVs&url=https%3A%2F%2Fwww.greencarreports.com%2Fnews%2F1128304_ford-mustang-mach-e-electric-suv-5-geeky-details-show-ford-s-commitment-to-evs', 'social', 'toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=700, height=300'); hgm.socialShare('Twitter', 'https://www.greencarreports.com/news/1128304_ford-mustang-mach-e-electric-suv-5-geeky-details-show-ford-s-commitment-to-evs');">
</a>
<a class="social-btn fab fa-linkedin-in linkedin" href="javascript:void(0)" title="Share this article on LinkedIn" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true?title=Ford%20Mustang%20Mach-E%20electric%20SUV%3A%205%20geeky%20details%20show%20Ford%27s%20commitment%20to%20EVs&url=https%3A%2F%2Fwww.greencarreports.com%2Fnews%2F1128304_ford-mustang-mach-e-electric-suv-5-geeky-details-show-ford-s-commitment-to-evs&source=GreenCarReports.com', 'social', 'toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=700, height=300'); hgm.socialShare('LinkedIn', 'https://www.greencarreports.com/news/1128304_ford-mustang-mach-e-electric-suv-5-geeky-details-show-ford-s-commitment-to-evs');">
</a>
<a class="social-btn fab fa-flipboard flipboard" href="javascript:void(0)" title="Flip this article" onclick="window.open('https://share.flipboard.com/bookmarklet/popout?text=Ford%20Mustang%20Mach-E%20electric%20SUV%3A%205%20geeky%20details%20show%20Ford%27s%20commitment%20to%20EVs&url=https%3A%2F%2Fwww.greencarreports.com%2Fnews%2F1128304_ford-mustang-mach-e-electric-suv-5-geeky-details-show-ford-s-commitment-to-evs', 'social', 'toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=700, height=300'); hgm.socialShare('Flipboard', 'https://www.greencarreports.com/news/1128304_ford-mustang-mach-e-electric-suv-5-geeky-details-show-ford-s-commitment-to-evs');">
</a>
<a class="social-btn far fa-envelope email" href="javascript:void(0)" title="Email this article" onclick="window.open('mailto:?subject=Ford%20Mustang%20Mach-E%20electric%20SUV%3A%205%20geeky%20details%20show%20Ford%27s%20commitment%20to%20EVs&body=Hi%20There%2C%0A%0AI%20thought%20you%20might%20like%20this%20article%3A%0A%0A%20%20%20%20Ford%20Mustang%20Mach-E%20electric%20SUV%3A%205%20geeky%20details%20show%20Ford%27s%20commitment%20to%20EVs%0A%20%20%20%20https%3A%2F%2Fwww.greencarreports.com%2Fnews%2F1128304_ford-mustang-mach-e-electric-suv-5-geeky-details-show-ford-s-commitment-to-evs%0A%0ACheers%21%0A', 'social', 'toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=700, height=300'); hgm.socialShare('Email', 'https://www.greencarreports.com/news/1128304_ford-mustang-mach-e-electric-suv-5-geeky-details-show-ford-s-commitment-to-evs');">
</a>
</div>
</div>
<div class="footer-block">
<div id="article-author">
<h3>connect with the editor:</h3>
<a href="/writer/10001004_bengt-halvorson">
<img src="https://images.hgmsites.net/sml/avatar-image-for-bengt_100544847_s.jpg" class="portrait" alt="Bengt Halvorson">
</a>
<a href="/writer/10001004_bengt-halvorson" rel="author" class="by-line">
Bengt Halvorson - Senior Editor
</a>
<a href="https://twitter.com/ben_gt" onclick="hgm.socialFollow('Twitter', 'ben_gt'); return true;" target="_blank" title="Bengt Halvorson’s Twitter profile">
<img class="social" src="/images/twitter.png" alt="Twitter">
</a>
</div>
<div class="follow-us">
<h3>Follow Us Today:</h3>
<a class="social-btn" title="Like us on Facebook" href="https://www.facebook.com/GreenCarReports" target="_blank" onclick="hgm.socialFollow('Facebook', 'GreenCarReports'); return true;">
<span class="fab fa-facebook-f"></span>
</a>
<a class="social-btn" title="Follow us on Twitter" href="https://www.twitter.com/GreenCarReports" target="_blank" onclick="hgm.socialFollow('Twitter', 'GreenCarReports'); return true;">
<span class="fab fa-twitter"></span>
</a>
<a class="social-btn" title="Follow us on Instagram" href="https://www.instagram.com/greencarreports/" target="_blank" onclick="hgm.socialFollow('Instagram', 'greencarreports'); return true;">
<span class="fab fa-instagram"></span>
</a>
<a class="social-btn" title="Subscribe to our YouTube channel" href="https://www.youtube.com/user/greencarreports" target="_blank" onclick="hgm.socialFollow('YouTube', 'greencarreports'); return true;">
<span class="fab fa-youtube"></span>
</a>
<a class="social-btn" title="Follow us on Filpboard" href="https://www.flipboard.com/@GreenCarReports" target="_blank" onclick="hgm.socialFollow('Flipboard', 'GreenCarReports'); return true;">
<span class="fab fa-flipboard"></span>
</a>
</div>
</div>
<div class="newsletter-signup  newsletter-signup-wide ">
<h3>Green Car Reports Newsletter</h3>
<p>
Sign up to get the latest green car and environmental news, delivered to your inbox daily!
</p>
<form data-pos="wide" class="newsletter-signup-form" action="/api/newsletter-subscribe" method="post">
<input class="newsletter-email" type="email" name="email" placeholder="Enter your email address…" required data-msg="Email is required">
<button class="red-button newsletter-signup-btn" type="submit">Sign Up Today!</button>
<div class="response_message"></div>
</form>
<p>
I agree to receive emails from Green Car Reports. I understand that I can unsubscribe at any time. <a href="https://www.internetbrands.com/privacy/privacy-main.html" target="_blank">Privacy Policy.</a>
</p>
</div>
<div id="disqus_thread"></div>
</article>
</div>
<div class="right-col gcr-rail ">
<aside>
<div class="adv-spacer" id="ad-a-3"></div>
<div class="related-articles">
<h2 class="title">Related Articles</h2>
<ul class="block-list rail-related-list">
<li>
<a class="block-image" href="/news/1128301_will-lordstown-motors-outsell-electric-trucks-from-gm-ford-and-rivian">
<img class="lazy" data-id="100747592" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg0.ibsrv.net/ibimg/hgm/1920x1080-1/100/747/lordstown-endurance_100747592.jpg" alt="Lordstown Endurance" data-srcset="https://cimg0.ibsrv.net/ibimg/hgm/200x113-1/100/747/lordstown-endurance_100747592.jpg 200w, https://cimg0.ibsrv.net/ibimg/hgm/100x56-1/100/747/lordstown-endurance_100747592.jpg 100w" sizes="100px">
</a>
<a class="block-link" href="/news/1128301_will-lordstown-motors-outsell-electric-trucks-from-gm-ford-and-rivian">
Will Lordstown Motors outsell electric trucks from GM, Ford, and Rivian?
</a>
</li>
<li>
<a class="block-image" href="/news/1128300_france-is-making-evs-and-plug-in-hybrids-the-basis-for-9-billion-program">
<img class="lazy" data-id="100567417" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg1.ibsrv.net/ibimg/hgm/1920x1080-1/100/567/2017-renault-zoe_100567417.jpg" alt="2017 Renault Zoe" data-srcset="https://cimg1.ibsrv.net/ibimg/hgm/200x113-1/100/567/2017-renault-zoe_100567417.jpg 200w, https://cimg1.ibsrv.net/ibimg/hgm/100x56-1/100/567/2017-renault-zoe_100567417.jpg 100w" sizes="100px">
</a>
<a class="block-link" href="/news/1128300_france-is-making-evs-and-plug-in-hybrids-the-basis-for-9-billion-program">
France is making EVs and plug-in hybrids the basis for $9 billion program
</a>
</li>
<li>
<a class="block-image" href="/news/1128297_tesla-lowers-prices-on-all-but-model-y-appears-to-drop-free-supercharging">
<img class="lazy" data-id="100736265" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg1.ibsrv.net/ibimg/hgm/1920x1080-1/100/736/2020-tesla-model-3_100736265.jpg" alt="2020 Tesla Model 3" data-srcset="https://cimg1.ibsrv.net/ibimg/hgm/200x113-1/100/736/2020-tesla-model-3_100736265.jpg 200w, https://cimg1.ibsrv.net/ibimg/hgm/100x56-1/100/736/2020-tesla-model-3_100736265.jpg 100w" sizes="100px">
</a>
<a class="block-link" href="/news/1128297_tesla-lowers-prices-on-all-but-model-y-appears-to-drop-free-supercharging">
Tesla lowers prices on all but Model Y, appears to drop free Supercharging
</a>
</li>
<li>
<a class="block-image" href="/news/1128271_location-is-everything-for-high-power-dc-fast-charging">
<img class="lazy" data-id="100682415" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg3.ibsrv.net/ibimg/hgm/1920x1080-1/100/682/electrify-america-dc-fast-chargers-at-san-francisco-premium-outlets-livermore-california_100682415.jpg" alt="Electrify America DC fast chargers at San Francisco Premium Outlets, Livermore, California" data-srcset="https://cimg3.ibsrv.net/ibimg/hgm/200x113-1/100/682/electrify-america-dc-fast-chargers-at-san-francisco-premium-outlets-livermore-california_100682415.jpg 200w, https://cimg3.ibsrv.net/ibimg/hgm/100x56-1/100/682/electrify-america-dc-fast-chargers-at-san-francisco-premium-outlets-livermore-california_100682415.jpg 100w" sizes="100px">
</a>
<a class="block-link" href="/news/1128271_location-is-everything-for-high-power-dc-fast-charging">
Location is everything for high-power DC fast charging
</a>
</li>
<li>
<a class="block-image" href="/news/1128269_where-will-sales-of-electric-cars-hybrids-land-after-the-vehicle-sales-free-fall">
<img class="lazy" data-id="100743997" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg1.ibsrv.net/ibimg/hgm/1920x1080-1/100/743/mercedes-benz-plug-in-hybrids-at-ionity-charging-stations_100743997.jpg" alt="Mercedes-Benz plug-in hybrids at Ionity charging stations" data-srcset="https://cimg1.ibsrv.net/ibimg/hgm/200x113-1/100/743/mercedes-benz-plug-in-hybrids-at-ionity-charging-stations_100743997.jpg 200w, https://cimg1.ibsrv.net/ibimg/hgm/100x56-1/100/743/mercedes-benz-plug-in-hybrids-at-ionity-charging-stations_100743997.jpg 100w" sizes="100px">
</a>
<a class="block-link" href="/news/1128269_where-will-sales-of-electric-cars-hybrids-land-after-the-vehicle-sales-free-fall">
Where will sales of electric cars, hybrids land after the vehicle-sales...
</a>
</li>
<li>
<a class="block-image" href="/news/1128264_super-flat-ree-skateboard-ev-platform-will-get-suspension-help-from-kyb">
<img class="lazy" data-id="100747389" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg1.ibsrv.net/ibimg/hgm/1920x1080-1/100/747/ree-modular-ev-platform_100747389.jpg" alt="REE modular EV platform" data-srcset="https://cimg1.ibsrv.net/ibimg/hgm/200x113-1/100/747/ree-modular-ev-platform_100747389.jpg 200w, https://cimg1.ibsrv.net/ibimg/hgm/100x56-1/100/747/ree-modular-ev-platform_100747389.jpg 100w" sizes="100px">
</a>
<a class="block-link" href="/news/1128264_super-flat-ree-skateboard-ev-platform-will-get-suspension-help-from-kyb">
Super-flat REE skateboard EV platform will get suspension help from KYB
</a>
</li>
</ul>
</div>
<div class="adv-spacer" id="ad-a-4"></div>
<h3>Most Popular</h3>
<div class="rail-box most-popular">
<div class="item opacity-background  lazy-background " data-background="https://images.hgmsites.net/med/2020-hyundai-sonata_100745651_m.jpg">
<div class="overlay"></div>
<div class="info">
<div class="date">
May 23, 2020
</div>
<div class="title">
<a href="/news/1128266_toyota-all-hybrid-models-solar-car-updates-evs-for-uber-and-lyft-the-week-in-reverse">Toyota all-hybrid models, solar car updates, EVs for Uber and Lyft: The Week in Reverse</a>
</div>
<div class="comment">
<a href="/writer/10001004_bengt-halvorson" rel="author">
Bengt Halvorson - Senior Editor
</a>
</div>
</div>
</div>
<div class="item opacity-background  lazy-background " data-background="https://images.hgmsites.net/med/musk-and-leno-in-tesla-cybertruck_100747543_m.jpg">
<div class="overlay"></div>
<div class="info">
<div class="date">
May 24, 2020
</div>
<div class="title">
<a href="/news/1128270_musk-tesla-cybertruck-won-t-be-downsized-but-smaller-follow-up-truck-a-possibility">Musk: Tesla Cybertruck won&#039;t be downsized, but smaller follow-up truck a possibility</a>
</div>
<div class="comment">
<a href="/writer/10001004_bengt-halvorson" rel="author">
Bengt Halvorson - Senior Editor
</a>
</div>
</div>
 </div>
<div class="item opacity-background  lazy-background " data-background="https://images.hgmsites.net/med/sono-sion-solar-charged-electric-car-solar-panels_100653154_m.jpg">
<div class="overlay"></div>
<div class="info">
<div class="date">
May 22, 2020
</div>
<div class="title">
<a href="/news/1128254_how-the-sono-sion-electric-car-will-use-every-body-panel-as-a-solar-panel">How the Sono Sion electric car will use every body panel as a solar panel</a>
</div>
<div class="comment">
<a href="/writer/10001004_bengt-halvorson" rel="author">
Bengt Halvorson - Senior Editor
</a>
</div>
</div>
</div>
<div class="item opacity-background  lazy-background " data-background="https://images.hgmsites.net/med/hyundai-kona-electric-police-cars-in-switzerland_100747362_m.jpg">
<div class="overlay"></div>
<div class="info">
<div class="date">
May 22, 2020
</div>
<div class="title">
<a href="/news/1128251_hyundai-kona-electric-the-new-favored-police-patrol-car-for-europe">Hyundai Kona Electric: The new favored police patrol car for Europe?</a>
</div>
<div class="comment">
<a href="/writer/10044742_stephen-edelstein" rel="author">
Stephen Edelstein - Contributing Writer
</a>
</div>
</div>
</div>
<div class="item opacity-background  lazy-background " data-background="https://images.hgmsites.net/med/ree-modular-ev-platform_100747389_m.jpg">
<div class="overlay"></div>
<div class="info">
<div class="date">
May 26, 2020
</div>
<div class="title">
<a href="/news/1128264_super-flat-ree-skateboard-ev-platform-will-get-suspension-help-from-kyb">Super-flat REE skateboard EV platform will get suspension help from KYB </a>
</div>
<div class="comment">
<a href="/writer/10044742_stephen-edelstein" rel="author">
Stephen Edelstein - Contributing Writer
</a>
</div>
</div>
</div>
<div class="item opacity-background  lazy-background " data-background="https://images.hgmsites.net/med/e5-electric-oil-tanker_100747536_m.jpg">
<div class="overlay"></div>
<div class="info">
<div class="date">
May 25, 2020
</div>
<div class="title">
<a href="/news/1128265_electric-oil-tankers-a-slick-use-of-renewable-energy">Electric oil tankers: A slick use of renewable energy?</a>
</div>
<div class="comment">
<a href="/writer/10044742_stephen-edelstein" rel="author">
Stephen Edelstein - Contributing Writer
</a>
</div>
</div>
</div>
<div class="clear"></div>
</div>
 <div class="gcr-fixed-anchor"></div>
<div class="gcr-fixed-content">
<div class="photo-galleries-swiper">
<h3>Photos</h3>
<div class="pagination-container">
<div class="swiper-prev">&lt;</div>
<div class="swiper-counter"></div>
<div class="swiper-next">&gt;</div>
</div>
<div class="swiper-container">
<div class="swiper-wrapper">
<div class="swiper-slide">
<div class="swiper-image item">
<a href="/news/1128304_ford-mustang-mach-e-electric-suv-5-geeky-details-show-ford-s-commitment-to-evs" class="img-wrap">
<img class="lazy" data-id="100723928" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg0.ibsrv.net/ibimg/hgm/1920x1080-1/100/723/2021-ford-mustang-mach-e_100723928.jpg" alt="2021 Ford Mustang Mach-E" data-srcset="https://cimg0.ibsrv.net/ibimg/hgm/1920x1080-1/100/723/2021-ford-mustang-mach-e_100723928.jpg 1920w, https://cimg0.ibsrv.net/ibimg/hgm/1200x675-1/100/723/2021-ford-mustang-mach-e_100723928.jpg 1200w, https://cimg0.ibsrv.net/ibimg/hgm/1024x576-1/100/723/2021-ford-mustang-mach-e_100723928.jpg 1024w, https://cimg0.ibsrv.net/ibimg/hgm/600x338-1/100/723/2021-ford-mustang-mach-e_100723928.jpg 600w" sizes="(max-width: 2000px) 600px, calc(100vw - 0rem)">
</a>
<a href="/news/1128304_ford-mustang-mach-e-electric-suv-5-geeky-details-show-ford-s-commitment-to-evs" class="title">Ford Mustang Mach-E electric SUV: 5 geeky details show Ford&#039;s commitment to EVs</a>
</div>
</div>
<div class="swiper-slide">
<div class="swiper-image item">
<a href="/news/1128290_2021-bmw-530e-plug-in-hybrid-quicker-but-will-it-go-more-electric-miles" class="img-wrap">
<img class="lazy" data-id="100747718" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg2.ibsrv.net/ibimg/hgm/1919x1079-1/100/747/bmw-5-series_100747718.jpg" alt="2021 BMW 5-Series" data-srcset="https://cimg2.ibsrv.net/ibimg/hgm/1919x1079-1/100/747/bmw-5-series_100747718.jpg 1919w, https://cimg2.ibsrv.net/ibimg/hgm/1200x675-1/100/747/bmw-5-series_100747718.jpg 1200w, https://cimg2.ibsrv.net/ibimg/hgm/1024x576-1/100/747/bmw-5-series_100747718.jpg 1024w, https://cimg2.ibsrv.net/ibimg/hgm/600x338-1/100/747/bmw-5-series_100747718.jpg 600w" sizes="(max-width: 2000px) 600px, calc(100vw - 0rem)">
</a>
<a href="/news/1128290_2021-bmw-530e-plug-in-hybrid-quicker-but-will-it-go-more-electric-miles" class="title">2021 BMW 530e plug-in hybrid: Quicker, but will it go more electric miles?</a>
</div>
</div>
<div class="swiper-slide">
<div class="swiper-image item">
<a href="/news/1128270_musk-tesla-cybertruck-won-t-be-downsized-but-smaller-follow-up-truck-a-possibility" class="img-wrap">
<img class="lazy" data-id="100747543" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg3.ibsrv.net/ibimg/hgm/1582x890-1/100/747/musk-and-leno-in-tesla-cybertruck_100747543.jpg" alt="Musk and Leno in Tesla Cybertruck" data-srcset="https://cimg3.ibsrv.net/ibimg/hgm/1582x890-1/100/747/musk-and-leno-in-tesla-cybertruck_100747543.jpg 1582w, https://cimg3.ibsrv.net/ibimg/hgm/1200x675-1/100/747/musk-and-leno-in-tesla-cybertruck_100747543.jpg 1200w, https://cimg3.ibsrv.net/ibimg/hgm/1024x576-1/100/747/musk-and-leno-in-tesla-cybertruck_100747543.jpg 1024w, https://cimg3.ibsrv.net/ibimg/hgm/600x338-1/100/747/musk-and-leno-in-tesla-cybertruck_100747543.jpg 600w" sizes="(max-width: 2000px) 600px, calc(100vw - 0rem)">
</a>
<a href="/news/1128270_musk-tesla-cybertruck-won-t-be-downsized-but-smaller-follow-up-truck-a-possibility" class="title">Musk: Tesla Cybertruck won&#039;t be downsized, but smaller follow-up truck a possibility</a>
</div>
</div>
<div class="swiper-slide">
<div class="swiper-image item">
<a href="/news/1128251_hyundai-kona-electric-the-new-favored-police-patrol-car-for-europe" class="img-wrap">
<img class="lazy" data-id="100747362" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg2.ibsrv.net/ibimg/hgm/1920x1080-1/100/747/hyundai-kona-electric-police-cars-in-switzerland_100747362.jpg" alt="Hyundai Kona Electric police cars in Switzerland" data-srcset="https://cimg2.ibsrv.net/ibimg/hgm/1920x1080-1/100/747/hyundai-kona-electric-police-cars-in-switzerland_100747362.jpg 1920w, https://cimg2.ibsrv.net/ibimg/hgm/1200x675-1/100/747/hyundai-kona-electric-police-cars-in-switzerland_100747362.jpg 1200w, https://cimg2.ibsrv.net/ibimg/hgm/1024x576-1/100/747/hyundai-kona-electric-police-cars-in-switzerland_100747362.jpg 1024w, https://cimg2.ibsrv.net/ibimg/hgm/600x338-1/100/747/hyundai-kona-electric-police-cars-in-switzerland_100747362.jpg 600w" sizes="(max-width: 2000px) 600px, calc(100vw - 0rem)">
</a>
<a href="/news/1128251_hyundai-kona-electric-the-new-favored-police-patrol-car-for-europe" class="title">Hyundai Kona Electric: The new favored police patrol car for Europe?</a>
</div>
</div>
<div class="swiper-slide">
<div class="swiper-image item">
<a href="/news/1128254_how-the-sono-sion-electric-car-will-use-every-body-panel-as-a-solar-panel" class="img-wrap">
<img class="lazy" data-id="100653154" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg2.ibsrv.net/ibimg/hgm/1070x602-1/100/653/sono-sion-solar-charged-electric-car-solar-panels_100653154.jpg" alt="Sono Sion solar charged electric car solar panels " data-srcset="https://cimg2.ibsrv.net/ibimg/hgm/1070x602-1/100/653/sono-sion-solar-charged-electric-car-solar-panels_100653154.jpg 1070w, https://cimg2.ibsrv.net/ibimg/hgm/1024x576-1/100/653/sono-sion-solar-charged-electric-car-solar-panels_100653154.jpg 1024w, https://cimg2.ibsrv.net/ibimg/hgm/600x338-1/100/653/sono-sion-solar-charged-electric-car-solar-panels_100653154.jpg 600w" sizes="(max-width: 2000px) 600px, calc(100vw - 0rem)">
</a>
<a href="/news/1128254_how-the-sono-sion-electric-car-will-use-every-body-panel-as-a-solar-panel" class="title">How the Sono Sion electric car will use every body panel as a solar panel</a>
</div>
</div>
</div>
</div>
</div>
<div class="adv-spacer" id="ad-a-5"></div>
</div>
</aside>
</div>
</div>
</div>
</div>
<a href="#" class="footer-waypoint-anchor"></a>
<footer>
<div class="footer-content">
<div class="footer-logo">
<a href="/" title="Green Car Reports">
<div class="logo-type"></div>
</a>
</div>
<div class="footer-links">
<div class="footer-link-section1 gcr">
<div class="footer-link-section">
<h4>News</h4>
<ul>
<li><a class="foot-link" href="/news/charging">Charging</a></li>
 <li><a class="foot-link" href="/news/mobility">Mobility</a></li>
<li><a class="foot-link" href="/news/sustainability">Sustainability</a></li>
<li><a class="foot-link" href="/news/gas-mileage">Gas Mileage </a></li>
<li><a class="foot-link" href="/news/hybrid-cars">Hybrids</a></li>
<li><a class="foot-link" href="/news/electric-cars">Electric Cars</a></li>
<li><a class="foot-link" href="/news/alternative-fuels">Alt Fuels</a></li>
<li><a class="foot-link" href="/news/diesel">Diesel Cars</a></li>
<li><a class="foot-link" href="/news/features">Features</a></li>
<li><a class="foot-link" href="/news">View All </a></li>
</ul>
</div>
</div>
<div class="footer-link-section2">
<div class="footer-link-section">
<h4>Media</h4>
<ul>
<li><a class="foot-link" href="/pictures">Photos</a></li>
<li><a class="foot-link" href="/videos">Videos</a></li>
</ul>
</div>
<div class="footer-link-section">
<h4>RSS</h4>
<ul>
<li><a class="foot-link" href="/rss-feeds">All Feeds</a></li>
<li><a class="foot-link" href="https://feeds.highgearmedia.com/?sites=GreenCarReports">Master Feed</a></li>
<li><a class="foot-link" href="https://feeds.highgearmedia.com/?sites=GreenCarReports&amp;tags=news">News</a></li>
<li><a class="foot-link" href="https://feeds.highgearmedia.com/?sites=GreenCarReports&amp;tags=first-drives">First Drives</a></li>
<li><a class="foot-link" href="https://feeds.highgearmedia.com/?sites=GreenCarReports&amp;tags=electric-cars">Electric Cars</a></li>
<li><a class="foot-link" href="https://feeds.highgearmedia.com/?sites=GreenCarReports&amp;tags=hybrid-cars">Hybrids</a></li>
<li><a class="foot-link" href="https://feeds.highgearmedia.com/?sites=GreenCarReports&amp;tags=buying-guides">Guides</a></li>
<li><a class="foot-link" href="https://feeds.highgearmedia.com/?sites=GreenCarReports&amp;tags=green-life">Green Life</a></li>
</ul>
</div>
<div class="footer-link-section">
<div>
<h4>Company</h4>
<ul>
<li><a class="foot-link" href="/aboutus">About Us</a></li>
<li><a class="foot-link" href="/aboutus#contact-us">Contact Us</a></li>
<li><a class="foot-link" href="http://ibauto.tumblr.com/">Press</a></li>
<li><a class="foot-link" href="https://www.internetbrands.com/ibterms/">Terms of Use</a></li>
<li><a class="foot-link" href="https://www.internetbrands.com/ibterms/supplementalcarrelatedterms/">Disclaimer</a></li>
<li><a class="foot-link" href="https://www.internetbrands.com/privacy/privacy-main.html">Privacy Policy</a></li>
<li><a class="foot-link" href="https://www.internetbrands.com/privacy/privacy-contact-form.php">Do Not Sell My Personal Information</a></li>
</ul>
</div>
<div class="footer-other-sites">
<h4>Our Other Sites</h4>
<ul>
<li><a class="foot-link" href="https://www.thecarconnection.com/">The Car Connection</a></li>
<li><a class="foot-link" href="https://www.motorauthority.com/">Motor Authority</a></li>
</ul>
</div>
</div>
</div>
</div>
<div class="footer-social-app-btns">
<section class="social">
<div class="follow-us">
<h3>Follow Us Today:</h3>
<a class="social-btn" title="Like us on Facebook" href="https://www.facebook.com/GreenCarReports" target="_blank" onclick="hgm.socialFollow('Facebook', 'GreenCarReports'); return true;">
<span class="fab fa-facebook-f"></span>
</a>
<a class="social-btn" title="Follow us on Twitter" href="https://www.twitter.com/GreenCarReports" target="_blank" onclick="hgm.socialFollow('Twitter', 'GreenCarReports'); return true;">
<span class="fab fa-twitter"></span>
</a>
<a class="social-btn" title="Follow us on Instagram" href="https://www.instagram.com/greencarreports/" target="_blank" onclick="hgm.socialFollow('Instagram', 'greencarreports'); return true;">
<span class="fab fa-instagram"></span>
</a>
<a class="social-btn" title="Subscribe to our YouTube channel" href="https://www.youtube.com/user/greencarreports" target="_blank" onclick="hgm.socialFollow('YouTube', 'greencarreports'); return true;">
<span class="fab fa-youtube"></span>
</a>
<a class="social-btn" title="Follow us on Filpboard" href="https://www.flipboard.com/@GreenCarReports" target="_blank" onclick="hgm.socialFollow('Flipboard', 'GreenCarReports'); return true;">
<span class="fab fa-flipboard"></span>
</a>
</div>
</section>
</div>
</div>
<div class="copyright">
&copy; 2020 MH Sub I, LLC. All Rights Reserved.
Stock photography by <a href="https://www.izmocars.com/">izmostock.</a>
Read our <a href="//www.internetbrands.com/privacy/cookie-policy.html">Cookie Policy</a>.
</div>
</footer>
<div class="adv-spacer bottom">
<div id="bottom-sticky"></div>
</div>
<div class="adv-body-shift  active "></div>
<div class="nav-menu" data-menu="news">
<div class="nav-menu-items 2">
<div class="nav-menu-col nav-menu-col-news">
<a href="/news/charging">Charging</a>
<a href="/news/mobility">Mobility</a>
<a href="/news/sustainability">Sustainability</a>
</div>
<div class="nav-menu-col nav-menu-col-news">
<a href="/news/gas-mileage">Gas Mileage </a>
<a href="/news/hybrid-cars">Hybrids</a>
<a href="/news/electric-cars">Electric Cars</a>
</div>
<div class="nav-menu-col nav-menu-col-news">
<a href="/news/alternative-fuels">Alt Fuels</a>
<a href="/news/diesel">Diesel Cars</a>
<a href="/news/features">Features</a>
 </div>
<div class="nav-menu-col nav-menu-col-news">
<a href="/news">View All </a>
</div>
</div>
</div>
<div class="nav-menu" data-menu="newsletter">
<div class="nav-menu-items nav-signup">
<div class="heading">Green Car Reports Newsletter</div>
<div>Sign up to get the latest green car and environmental news, delivered to your inbox daily!</div>
<form data-pos="navigation" class="newsletter-signup-form" action="/api/newsletter-subscribe" method="post">
<input type="email" class="email" name="email" placeholder="Enter your email address…" required data-msg="Email is required">
<button class="red-button newsletter-signup-btn" type="submit">Sign Up Today!</button>
<div class="response_message"></div>
</form>
</div>
<div class="signup-consent">I agree to receive emails from Green Car Reports. I understand that I can unsubscribe at any time. <a href="https://www.internetbrands.com/privacy/privacy-main.html" target="_blank">Privacy Policy.</a></div>
</div>
<div class="nav-menu nav-menu-search" data-menu="search" data-engine="001937828977938864696:tstejjfkb_g" data-placeholder="Search Green Car Reports...">
<div class="nav-search">
<gcse:searchbox-only enableHistory="true" autoCompleteMaxCompletions="10" autoCompleteMatchType='any' resultsUrl="/searchresults"></gcse:searchbox-only>
</div>
</div>
<div class="device-nav">
<a class="nav-link  cat-link " href="/news">News</a>
<div class="nav-categories">
<a href="/news/charging">Charging</a>
<a href="/news/mobility">Mobility</a>
<a href="/news/sustainability">Sustainability</a>
<a href="/news/gas-mileage">Gas Mileage </a>
<a href="/news/hybrid-cars">Hybrids</a>
<a href="/news/electric-cars">Electric Cars</a>
<a href="/news/alternative-fuels">Alt Fuels</a>
<a href="/news/diesel">Diesel Cars</a>
<a href="/news/features">Features</a>
<a href="/news">View All </a>
</div>
<a class="nav-link " href="/news/first-drives">First Drives</a>
<a class="nav-link " href="/news/electric-cars">Electric Cars</a>
<a class="nav-link " href="/news/hybrid-cars">Hybrids</a>
<a class="nav-link " href="/news/buying-guides">Guides</a>
<a class="nav-link " href="/news/green-life">Green Life</a>
<li class="mobile-newsletter">
<div class="newsletter-wrapper">
<div class="newsletter-title">Never Miss a Green Car Reports Story</div>
<form class="newsletter-signup-form" action="/api/newsletter-subscribe" method="post">
<input type="email" class="email" name="email" placeholder="Enter your email address…" required data-msg="Email is required">
<div class="signup-consent">
I agree to receive emails from Green Car Reports. I understand that I can unsubscribe at any time. <a href="https://www.internetbrands.com/privacy/privacy-main.html" target="_blank">Privacy Policy.</a>
</div>
<button class="red-button newsletter-signup-btn" type="submit">subscribe today</button>
<div class="response_message"></div>
</form>
</div>
</li>
</div>
<script src="/js/vendor.js?id=497cadd5c6e8922bd00c"></script>
<script src="/js/app.js?id=a788ea1d7854720dac51"></script>
<script>
(function(){
        hgm.initArticles();
        hgmads.initFromDeferred();
            hgmads.initDynamicAds($('.article-body'));
            googletag.cmd.push(function () {
                hgmads.renderDynamicAds();
            });;
        $('.silk-arrow').click(function() {
        $('.silk-container').animate({
           height: "toggle"
        }, 200, function() {
                // Animation complete.
        });
        $('.silk-arrow .fa-angle-up').toggle();
        $('.silk-arrow .fa-angle-down').toggle();
    });
hgm.initSearch();
hgm.initSearch();
}());
</script>
<script src="/js/footer.js?id=a28ce39f85f1249fdb31"></script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"fcb635eb66","applicationID":"135926744","transactionName":"MgcAYUMDDUFWAkJaDAtNI1ZFCwxcGA9TRBBIAxBBWAEPVw==","queueTime":0,"applicationTime":229,"atts":"HkAXFwsZHh4VABQJGBgf","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
