<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge"><script type="text/javascript">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</script>
<meta name="viewport" content="width=device-width, initial-scale=1">
<script>
        dataLayer =  [{"tags":["news","racing","electric-cars"]}] ;
                (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
        new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
        j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
        'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
        })(window, document, 'script', 'dataLayer', 'GTM-M73XHX4');
    </script>
<title>&quot;Big Daddy&quot; drag racer Don Garlits sets electric dragster record</title>
<meta name="description" content="Drag-racer Don Garlits broke another record in an all-electric race car last Saturday, July 20, 2019, on the anniversary of the moon landing."> <link rel="canonical" href="https://www.greencarreports.com/news/1124259_big-daddy-drag-racer-don-garlits-sets-electric-dragster-record">
<script type="application/ld+json">
{"@context":"https://schema.org","@type":"WebPage","@id":"https://www.greencarreports.com/news/1124259_big-daddy-drag-racer-don-garlits-sets-electric-dragster-record","url":"https://www.greencarreports.com/news/1124259_big-daddy-drag-racer-don-garlits-sets-electric-dragster-record","isPartOf":{"@type":"WebSite","@id":"https://www.greencarreports.com/#site"},"breadcrumb":{"@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://www.greencarreports.com/news","name":"News"}},{"@type":"ListItem","position":2,"item":{"@id":"https://www.greencarreports.com/news/racing","name":"Racing"}}]},"mainEntity":{"@type":"NewsArticle","@id":"https://www.greencarreports.com/news/1124259_big-daddy-drag-racer-don-garlits-sets-electric-dragster-record#this","url":"https://www.greencarreports.com/news/1124259_big-daddy-drag-racer-don-garlits-sets-electric-dragster-record","headline":"\"Big Daddy\" drag racer Don Garlits sets electric dragster record","datePublished":"2019-07-28T12:00:00+0000","dateModified":"2019-07-28T06:42:49+0000","description":"Drag-racer Don Garlits broke another record in an all-electric race car last Saturday, July 20, 2019, on the anniversary of the moon landing.","author":{"@type":"Person","name":"Eric C. Evarts","jobTitle":null,"image":"https://images.hgmsites.net/tny/avatar-image-for-eevarts_100649159_0.jpg","url":"https://www.greencarreports.com/writer/10064169_eric-c-evarts"},"publisher":{"@type":"Organization","@id":"https://www.greencarreports.com/#organization"},"articleSection":"Racing","keywords":"Racing","image":{"@type":"ImageObject","@id":"https://images.hgmsites.net/lrg/top-fuel-winner-don-big-daddy-garlitz-sets-a-new-record-for-electric-drag-racing-youtube-capture_100709872_l.jpg#this","url":"https://images.hgmsites.net/lrg/top-fuel-winner-don-big-daddy-garlitz-sets-a-new-record-for-electric-drag-racing-youtube-capture_100709872_l.jpg","caption":"Top-fuel winner Don \"Big Daddy\" Garlitz sets a new record for electric drag racing [YouTube capture]","description":"","width":1024,"height":341,"uploadDate":"2019-07-26T20:57:38+0000"},"video":{"@type":"VideoObject","@id":"https://www.youtube.com/watch?v=rPT3zZuzIpk","url":"https://www.youtube.com/watch?v=rPT3zZuzIpk","thumbnailUrl":"https://i.ytimg.com/vi/rPT3zZuzIpk/hqdefault.jpg","name":"\"Big Daddy\" drag racer Don Garlits sets electric dragster record","description":"Drag-racer Don Garlits broke another record in an all-electric race car last Saturday, July 20, 2019, on the anniversary of the moon landing.","uploadDate":"2019-07-28T12:00:00+0000"}}}
</script>
<meta property="fb:pages" content="143669659002741">
<meta property="fb:app_id" content="80517230974">
<meta property="og:site_name" content="Green Car Reports">
<meta property="og:type" content="article">
<meta property="og:url" content="https://www.greencarreports.com/news/1124259_big-daddy-drag-racer-don-garlits-sets-electric-dragster-record">
<meta property="og:title" content="&quot;Big Daddy&quot; drag racer Don Garlits sets electric dragster record">
<meta property="og:description" content="Drag-racer Don Garlits broke another record in an all-electric race car last Saturday, July 20, 2019, on the anniversary of the moon landing.">
<meta property="og:image" content="https://images.hgmsites.net/hug/top-fuel-winner-don-big-daddy-garlitz-sets-a-new-record-for-electric-drag-racing-youtube-capture_100709872_h.jpg">
<meta property="twitter:card" content="summary_large_image">
<meta property="twitter:site" content="@GreenCarReports">
<meta property="twitter:title" content="&quot;Big Daddy&quot; drag racer Don Garlits sets electric dragster record">
<meta property="twitter:description" content="Drag-racer Don Garlits broke another record in an all-electric race car last Saturday, July 20, 2019, on the anniversary of the moon landing.">
<meta property="twitter:image" content="https://images.hgmsites.net/hug/top-fuel-winner-don-big-daddy-garlitz-sets-a-new-record-for-electric-drag-racing-youtube-capture_100709872_h.jpg">
<link href="https://feeds.highgearmedia.com/?sites=GreenCarReports" rel="alternate" type="application/rss+xml" title="Green Car Reports News">
<link href="/favicon.ico" rel="shortcut icon" type="image/x-icon">
<link href="/css/app.css?id=a6e221920b487802d7b2" rel="stylesheet">
<style>
.rail-box.most-popular{padding:0;background:transparent}.rail-box.most-popular:after{content:"";display:table;clear:both}.rail-box.most-popular .item{height:204px;color:#fff;padding:4em 2em;-webkit-box-sizing:border-box;box-sizing:border-box;position:relative;background-size:100% 100%}@media (max-width:1023px){.rail-box.most-popular .item{width:33%;float:left}}@media (max-width:768px){.rail-box.most-popular .item{width:50%;float:left}}@media (max-width:414px){.rail-box.most-popular .item{width:100%}}.rail-box.most-popular .item .overlay{background-color:#000;opacity:.5}.rail-box.most-popular .item .info{display:-webkit-box;display:-ms-flexbox;display:flex;-webkit-box-orient:vertical;-webkit-box-direction:normal;-ms-flex-direction:column;flex-direction:column;-webkit-box-pack:justify;-ms-flex-pack:justify;justify-content:space-between;-webkit-box-sizing:border-box;box-sizing:border-box;position:absolute;width:86%;height:63%}@media (max-width:768px){.rail-box.most-popular .item .info{width:89%}}.rail-box.most-popular .item .info .comment,.rail-box.most-popular .item .info .date{text-transform:uppercase;font-size:12px;font-weight:400;line-height:1}.rail-box.most-popular .item .info .comment a,.rail-box.most-popular .item .info .title a{color:#fff}.rail-box.most-popular .item .info .title{font-size:18px;font-weight:600;line-height:1.25}@media (max-width:768px){.rail-box.most-popular .item .info .title{font-size:16.8px;font-weight:600;line-height:1.2}}
</style>
<script src="/js/head.js?id=6b7e38311ef801f85ac9"></script>
<script async src="https://js-sec.indexww.com/ht/p/184397-164216896053308.js"></script> <script async src="https://cdn.districtm.ca/merge/merge.116298.js"></script> <script async src="https://internetbrands-d.openx.net/w/1.0/jstag?nc=2922-GreenCarReports"></script> <script class="kxct" data-id="sh2lfhber" data-timing="async" data-version="3.0">
                    window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);
                    (function(){
                        function retrieve(n){
                            var k='kx'+'internetbrands_'+n, ls=(function(){
                                try {
                                    return window.localStorage;
                                } catch(e) {
                                    return null;
                                }
                            })();
                            if (ls) {
                                return ls[k] || '';
                            } else if (navigator.cookieEnabled) {
                                var m = document.cookie.match(k+'=([^;]*)');
                                return (m && unescape(m[1])) || '';
                            } else {
                                return '';
                            }
                        }
                        Krux.user = retrieve('user');
                        Krux.segments = retrieve('segs').split(',');
                    })();
                </script>
<script async src="https://cdn.krxd.net/controltag/sh2lfhber.js"></script>
<script>
    var gptadslots = [],
        googletag = googletag || {};
    googletag.cmd = googletag.cmd || [];
    (function(){
        var gads = document.createElement('script');
        var useSSL = 'https:' === document.location.protocol;
        gads.async = true;
        gads.type = 'text/javascript';
        gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
        var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(gads, node);
    })();
</script>
<script>
        hgmads.setAdUnitBasePath('/2922/greencarreports.tmus');
</script>
<script>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</script>
<script>
    !function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function()
        {q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];
        g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

    // initialize apstag and have apstag set bids on the googletag slots when they are returned to the page
    apstag.init({
        pubID:'3188',
        adServer:'googletag',
        bidTimeout:2e3
    });


</script>
<script>
        googletag.cmd.push(function() {
                                        hgmads.addStaticSlotById('ad-top');
                hgmads.addApsStaticSlot( {slotID:'ad-top' ,sizes:[[728, 90]], slotName:'/2922/greencarreports.tmus/newsarticle/728x90_top_ad-top'} );
                hgmads.addLazySlotById('ad-top');
                hgmads.addApsLazySlot( {slotID:'ad-top' ,sizes:[[728, 90]], slotName:'/2922/greencarreports.tmus/newsarticle/728x90_top_ad-top'} );
            
                                                var callbackFunction = new hgmads.CallbackFunctionContainer('ad-top', "$(window).trigger('resize.px.parallax')", "", 'false', 'slotRenderEnded', 'true');
                    hgmads.addCallback(callbackFunction);
                                    var callbackFunction = new hgmads.CallbackFunctionContainer('ad-top', "hgmads.startStickyTimer", "6", 'true', 'slotRenderEnded', 'true');
                    hgmads.addCallback(callbackFunction);
                                        hgmads.addTrottleInterval('ad-top', 2);
                                    hgmads.addLazySlotById('ad-a-2');
                hgmads.addApsLazySlot( {slotID:'ad-a-2' ,sizes:[[300, 250]], slotName:'/2922/greencarreports.tmus/newsarticle/300x250_content-bottom_ad-a-2'} );

            
                        hgmads.addTrottleInterval('ad-a-2', 2);
                                    hgmads.addStaticSlotById('ad-a-3');
                hgmads.addApsStaticSlot( {slotID:'ad-a-3' ,sizes:[[300, 250]], slotName:'/2922/greencarreports.tmus/newsarticle/300x250_d-side-rail-top_ad-a-3'} );
            
                        hgmads.addTrottleInterval('ad-a-3', 2);
                                    hgmads.addLazySlotById('ad-a-4');
                hgmads.addApsLazySlot( {slotID:'ad-a-4' ,sizes:[[300, 250]], slotName:'/2922/greencarreports.tmus/newsarticle/300x250_news-letter-center_ad-a-4'} );

            
                        hgmads.addTrottleInterval('ad-a-4', 2);
                                    hgmads.addLazySlotById('ad-a-5');
                hgmads.addApsLazySlot( {slotID:'ad-a-5' ,sizes:[[300, 250]], slotName:'/2922/greencarreports.tmus/newsarticle/300x250_d-side-rail-bottom_ad-a-5'} );

            
                                                var callbackFunction = new hgmads.CallbackFunctionContainer('ad-a-5', "hgmads.refreshOnScroll", "", 'true', 'slotRenderEnded', 'true');
                    hgmads.addCallback(callbackFunction);
                                        hgmads.addTrottleInterval('ad-a-5', 6);
                                    hgmads.addStaticSlotById('bottom-sticky');
                hgmads.addApsStaticSlot( {slotID:'bottom-sticky' ,sizes:[[320, 50]], slotName:'/2922/greencarreports.tmus/newsarticle/320x50_bottom-sticky_bottom-sticky'} );
                hgmads.addLazySlotById('bottom-sticky');
                hgmads.addApsLazySlot( {slotID:'bottom-sticky' ,sizes:[[320, 50]], slotName:'/2922/greencarreports.tmus/newsarticle/320x50_bottom-sticky_bottom-sticky'} );
            
                                                var callbackFunction = new hgmads.CallbackFunctionContainer('bottom-sticky', "hgmads.startStickyTimer", "0, bottom", 'true', 'slotRenderEnded', 'true');
                    hgmads.addCallback(callbackFunction);
                                    var callbackFunction = new hgmads.CallbackFunctionContainer('bottom-sticky', "hgmads.refreshOnScroll", "", 'true', 'slotRenderEnded', 'true');
                    hgmads.addCallback(callbackFunction);
                                        hgmads.addTrottleInterval('bottom-sticky', 5);
                                    hgmads.addStaticSlotById('ad-a-1');
                hgmads.addApsStaticSlot( {slotID:'ad-a-1' ,sizes:[[1, 1]], slotName:'/2922/greencarreports.tmus/newsarticle/1x1_OOP_ad-a-1'} );
            
                                                var callbackFunction = new hgmads.CallbackFunctionContainer('ad-a-1', "hgmads.disableByMediaQuery", "(max-width: 1350px)", 'true', 'renderStaticAds', 'true');
                    hgmads.addCallback(callbackFunction);
                                        hgmads.addTrottleInterval('ad-a-1', 2);
                }); // cmd push
                                                        hgmads.addWaypointSlot('ad-a-2', {fetchMarginPercent: '200%', renderMarginPercent: '150%'});
                                                                    hgmads.addWaypointSlot('ad-a-4', {fetchMarginPercent: '200%', renderMarginPercent: '150%'});
                                                hgmads.addWaypointSlot('ad-a-5', {fetchMarginPercent: '200%', renderMarginPercent: '150%'});
                                                                    googletag.cmd.push(function() {
            hgmads.renderStaticAds();
        });
    </script>
</head>
<body>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M73XHX4"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<header>
<div class="nav-container">
<nav>
<div class="mobile-menu"><a class="toggle-device-nav" href="#"></a></div>
 <div class="logo"><a href="/" title="Green Car Reports"></a></div>
<div class="nav-items">
<ul>
<li><a class="nav-link" data-menu="news" href="/news">News</a></li>
<li><a class="nav-link" href="/news/first-drives">First Drives</a></li>
<li><a class="nav-link" href="/news/electric-cars">Electric Cars</a></li>
<li><a class="nav-link" href="/news/hybrid-cars">Hybrids</a></li>
<li><a class="nav-link" href="/news/buying-guides">Guides</a></li>
<li><a class="nav-link" href="/news/green-life">Green Life</a></li>
<li class="desktop-newsletter"><a class="nav-link-btn" data-menu="newsletter" href="javascript:void(0)" title="Newsletter Signup"><img src="/images/envelope.svg" />newsletter</a></li>
</ul>
</div>
<div class="search">
<a class="nav-link-search" data-menu="search" href="javascript:void(0)" title="Search"></a>
</div>
</nav>
</div>
<div class="adv-spacer-top-wraper">
<div class="adv-spacer top ">
<div id="ad-top"></div>
</div>
</div>
<div id="breadcrumbs">
<a href="/">Home</a>
<span> / </span>
<a href="/news">News</a>
<span> / </span>
<a href="/news/racing">Racing</a>
</div>
</header>
<div id="main">
<div class="hidden-slot" id="ad-a-1"></div>
<script>
        window.disqus_domain = 'https://www.greencarreports.com';
        window.disqus_shortname = 'greencarreports';
        window.disqus_key = 'NCF9QGiigz0WoG2RAdgNHu0h4WSUWoLkzI4RZJ6UisUx951obo7XTL1BigknDT9P';
    </script>
<script>
            var xpath = 'insertAfter(p[3])',
                sizes = [[300, 250]],
                zone = 'newsarticle',
                pos = 'm-center',
                sizeW = '300',
                sizeH = '250',
                adClasses = 'adv-spacer',
                adSizeMap = [],
                label = '',
                throttleInterval = 2;

            var targets = [];
            targets.push( {'kw': ["m-center"] });
            targets.push( {'sz': ["300x250"] });
                                        targets.push( {'tags': ["news,racing,electric-cars"]} );
                                                    targets.push( {'page': ["blog-post-article"]});
                targets.push( {'variation': window.hgm_variation || ''});

                                                adSizeMap.push({'viewport':  [0,0] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [1280,800] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [600,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [800,600] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [320,300] ,'map': [[300,250]]  }) ;
                            
            var callbackFunctions = false;
            
            var wayPointConfig = false;
                        hgmads.addDynamicSlot(xpath, sizes, targets, zone, pos, sizeW, sizeH, adClasses, adSizeMap, label, callbackFunctions, throttleInterval, wayPointConfig);
        </script>
<script>
            var xpath = 'appendTo(.adv-container .adv-spacer-top)',
                sizes = [[300, 250]],
                zone = 'newsarticle',
                pos = 'd-media-pop-up-top_m-media-pop-up-bottom',
                sizeW = '300',
                sizeH = '250',
                adClasses = '',
                adSizeMap = [],
                label = '',
                throttleInterval = 2;

            var targets = [];
            targets.push( {'kw': ["d-media-pop-up-top_m-media-pop-up-bottom"] });
            targets.push( {'sz': ["300x250"] });
                                        targets.push( {'tags': ["news,racing,electric-cars"]} );
                                                    targets.push( {'page': ["blog-post-article"]});
                targets.push( {'variation': window.hgm_variation || ''});

                                                adSizeMap.push({'viewport':  [0,0] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [1280,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [1280, 600] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [600,800] ,'map': [[320,50]]  }) ;
                                    adSizeMap.push({'viewport':  [800,600] ,'map': [[728,90]]  }) ;
                                    adSizeMap.push({'viewport':  [320,300] ,'map': [[320,50]]  }) ;
                            
            var callbackFunctions = false;
            
            var wayPointConfig = false;
                        hgmads.addDynamicSlot(xpath, sizes, targets, zone, pos, sizeW, sizeH, adClasses, adSizeMap, label, callbackFunctions, throttleInterval, wayPointConfig);
        </script>
<script>
            var xpath = 'appendTo(.adv-container .adv-spacer-bottom)',
                sizes = [[300, 250]],
                zone = 'newsarticle',
                pos = 'd-media-pop-up-bottom_m-media-pop-up-bottom',
                sizeW = '300',
                sizeH = '250',
                adClasses = '',
                adSizeMap = [],
                label = '',
                throttleInterval = 2;

            var targets = [];
            targets.push( {'kw': ["d-media-pop-up-bottom_m-media-pop-up-bottom"] });
            targets.push( {'sz': ["300x250"] });
                                        targets.push( {'tags': ["news,racing,electric-cars"]} );
                                                    targets.push( {'page': ["blog-post-article"]});
                targets.push( {'variation': window.hgm_variation || ''});

                                                adSizeMap.push({'viewport':  [0,0] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [1280,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [1280, 600] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [600,800] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [800,600] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [320,300] ,'map': []  }) ;
                            
            var callbackFunctions = false;
            
            var wayPointConfig = false;
                        hgmads.addDynamicSlot(xpath, sizes, targets, zone, pos, sizeW, sizeH, adClasses, adSizeMap, label, callbackFunctions, throttleInterval, wayPointConfig);
        </script>
<script>
            var xpath = 'appendTo(.video-popup-sidebar .adv-spacer-top)',
                sizes = [[300, 250]],
                zone = 'newsarticle',
                pos = 'd-media-pop-up-top_m-media-pop-up-bottom',
                sizeW = '300',
                sizeH = '250',
                adClasses = '',
                adSizeMap = [],
                label = '',
                throttleInterval = 2;

            var targets = [];
            targets.push( {'kw': ["d-media-pop-up-top_m-media-pop-up-bottom"] });
            targets.push( {'sz': ["300x250"] });
                                        targets.push( {'tags': ["news,racing,electric-cars"]} );
                                                    targets.push( {'page': ["blog-post-article"]});
                targets.push( {'variation': window.hgm_variation || ''});

                                                adSizeMap.push({'viewport':  [0,0] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [1280,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [600,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [800,600] ,'map': [[320,50]]  }) ;
                                    adSizeMap.push({'viewport':  [320,300] ,'map': [[320,50]]  }) ;
                            
            var callbackFunctions = false;
            
            var wayPointConfig = false;
                        hgmads.addDynamicSlot(xpath, sizes, targets, zone, pos, sizeW, sizeH, adClasses, adSizeMap, label, callbackFunctions, throttleInterval, wayPointConfig);
        </script>
<script>
            var xpath = 'appendTo(.video-popup-sidebar .adv-spacer-bottom)',
                sizes = [[300, 250]],
                zone = 'newsarticle',
                pos = 'd-media-pop-up-bottom_m-media-pop-up-bottom',
                sizeW = '300',
                sizeH = '250',
                adClasses = '',
                adSizeMap = [],
                label = '',
                throttleInterval = 2;

            var targets = [];
            targets.push( {'kw': ["d-media-pop-up-bottom_m-media-pop-up-bottom"] });
            targets.push( {'sz': ["300x250"] });
                                        targets.push( {'tags': ["news,racing,electric-cars"]} );
                                                    targets.push( {'page': ["blog-post-article"]});
                targets.push( {'variation': window.hgm_variation || ''});

                                                adSizeMap.push({'viewport':  [0,0] ,'map': []  }) ;
                                    adSizeMap.push({'viewport':  [1280,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [600,800] ,'map': [[300,250]]  }) ;
                                    adSizeMap.push({'viewport':  [800,600] ,'map': [[320,50]]  }) ;
                                    adSizeMap.push({'viewport':  [320,300] ,'map': [[320,50]]  }) ;
                            
            var callbackFunctions = false;
            
            var wayPointConfig = false;
                        hgmads.addDynamicSlot(xpath, sizes, targets, zone, pos, sizeW, sizeH, adClasses, adSizeMap, label, callbackFunctions, throttleInterval, wayPointConfig);
        </script>
<div class="article-block" data-id="1124259" data-url="/news/1124259_big-daddy-drag-racer-don-garlits-sets-electric-dragster-record" data-title="&quot;Big Daddy&quot; drag racer Don Garlits sets electric dragster record" data-next-id="1124260" data-infinite-scroll="false" data-min-comments="1">
<section class="hero-wrap-parallax parallax-window  video   gallery " data-image-src-h="https://images.hgmsites.net/hug/top-fuel-winner-don-big-daddy-garlitz-sets-a-new-record-for-electric-drag-racing-youtube-capture_100709872_h.jpg" data-image-src-l="https://images.hgmsites.net/lrg/top-fuel-winner-don-big-daddy-garlitz-sets-a-new-record-for-electric-drag-racing-youtube-capture_100709872_l.jpg" data-image-src-m="https://images.hgmsites.net/med/top-fuel-winner-don-big-daddy-garlitz-sets-a-new-record-for-electric-drag-racing-youtube-capture_100709872_m.jpg" data-image-src-s="https://images.hgmsites.net/sml/top-fuel-winner-don-big-daddy-garlitz-sets-a-new-record-for-electric-drag-racing-youtube-capture_100709872_s.jpg">
<div class="hero-nav prev"></div>
<div class="hero-nav next"></div>
<div class="overlay"></div>
<div class="hero-inner-wrap">
<div class="left-col">
<header class="title-wrap">
<h1 class="article-title"><span>&quot;Big Daddy&quot; drag racer Don Garlits sets electric dragster record</span></h1>
<div class="portrait-wrapper">
<a href="/writer/10064169_eric-c-evarts" class="portrait">
<img src="https://images.hgmsites.net/sml/avatar-image-for-eevarts_100649159_s.jpg" alt="Eric C. Evarts">
</a>
</div>
<a href="/writer/10064169_eric-c-evarts" rel="author" class="by-line">
Eric C. Evarts
</a>
<time datetime="2019-07-28T12:00:00+0000">
July 28, 2019
</time>
<a href="javascript:void(0)" class="comments-link">
<i class="icon fas fa-comments"></i><span>Comment Now!</span>
</a>
<div class="gallery-btn" data-article-id="1124259">
<span class="gallery-icon"></span>
View Gallery
</div>
</header>
</div>
<div class="right-col"></div>
</div>
<div class="video-btn" data-id="rPT3zZuzIpk" data-video="&lt;iframe id=&quot;videoPlayerYouTube&quot; src=&quot;https://www.youtube.com/embed/rPT3zZuzIpk&quot; width=&quot;auto&quot; height=&quot;auto&quot; frameborder=&quot;0&quot; allowfullscreen=&quot;1&quot;&gt;&lt;/iframe&gt;" data-pageview="/video/youtube/rPT3zZuzIpk/big-daddy-drag-racer-don-garlits-sets-electric-dragster-record" data-excerpt="On the 50th anniversary of mankind&#039;s first moon landing, last Saturday, another kind of new record hit the electric car community. Legendary drag-racer Don Garlits, who was setting racing records..." data-url="/news/1124259_big-daddy-drag-racer-don-garlits-sets-electric-dragster-record" data-facebook='            &lt;a class=&quot;social-btn fab fa-facebook-f facebook&quot; href=&quot;javascript:void(0)&quot; title=&quot;Share this article on Facebook&quot;
                onclick=&quot;window.open(&#039;https://www.facebook.com/sharer.php?t=%22Big%20Daddy%22%20drag%20racer%20Don%20Garlits%20sets%20electric%20dragster%20record&amp;u=%2Fnews%2F1124259_big-daddy-drag-racer-don-garlits-sets-electric-dragster-record&#039;, &#039;social&#039;, &#039;toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=700, height=300&#039;); hgm.socialShare(&#039;Facebook&#039;, &#039;/news/1124259_big-daddy-drag-racer-don-garlits-sets-electric-dragster-record&#039;);&quot;&gt;
            &lt;/a&gt;' data-twitter='            &lt;a class=&quot;social-btn fab fa-twitter twitter&quot; href=&quot;javascript:void(0)&quot; title=&quot;Tweet this article&quot;
                onclick=&quot;window.open(&#039;https://twitter.com/intent/tweet?text=%22Big%20Daddy%22%20drag%20racer%20Don%20Garlits%20sets%20electric%20dragster%20record&amp;url=%2Fnews%2F1124259_big-daddy-drag-racer-don-garlits-sets-electric-dragster-record&#039;, &#039;social&#039;, &#039;toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=700, height=300&#039;); hgm.socialShare(&#039;Twitter&#039;, &#039;/news/1124259_big-daddy-drag-racer-don-garlits-sets-electric-dragster-record&#039;);&quot;&gt;
            &lt;/a&gt;' data-email='            &lt;a class=&quot;social-btn far fa-envelope email&quot; href=&quot;javascript:void(0)&quot; title=&quot;Email this article&quot;
                onclick=&quot;window.open(&#039;mailto:?subject=%22Big%20Daddy%22%20drag%20racer%20Don%20Garlits%20sets%20electric%20dragster%20record&amp;body=Hi%20There%2C%0A%0AI%20thought%20you%20might%20like%20this%20article%3A%0A%0A%20%20%20%20%22Big%20Daddy%22%20drag%20racer%20Don%20Garlits%20sets%20electric%20dragster%20record%0A%20%20%20%20%2Fnews%2F1124259_big-daddy-drag-racer-don-garlits-sets-electric-dragster-record%0A%0ACheers%21%0A&#039;, &#039;social&#039;, &#039;toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=700, height=300&#039;); hgm.socialShare(&#039;Email&#039;, &#039;/news/1124259_big-daddy-drag-racer-don-garlits-sets-electric-dragster-record&#039;);&quot;&gt;
            &lt;/a&gt;'>
<span class="play-icon fas fa-play-circle"></span>
</div>
</section>
<div class="article-wrap">
<div class="left-col">
<header class="title-wrap">
<h1 class="article-title"><span>&quot;Big Daddy&quot; drag racer Don Garlits sets electric dragster record</span></h1>
<div class="portrait-wrapper">
<a href="/writer/10064169_eric-c-evarts" class="portrait">
<img src="https://images.hgmsites.net/sml/avatar-image-for-eevarts_100649159_s.jpg" alt="Eric C. Evarts">
</a>
</div>
<a href="/writer/10064169_eric-c-evarts" rel="author" class="by-line">
Eric C. Evarts
</a>
<time datetime="2019-07-28T12:00:00+0000">
July 28, 2019
</time>
<a href="javascript:void(0)" class="comments-link">
<i class="icon fas fa-comments"></i><span>Comment Now!</span>
</a>
</header>
<article class="content article-style  gcr-article ">
<section class="article-body">
<p>On the 50th anniversary of mankind's first moon landing, last Saturday, another kind of new record hit the electric car community. </p>
<p>Legendary drag-racer Don Garlits, who was setting racing records before the moon landing, set <a href="https://www.hotrod.com/articles/don-garlits-sets-new-electric-dragster-record-florida-chasing-200mph/">two new speed records in an electric dragster in the quarter mile</a>, one for a time of 7.235 seconds, and the other for a trap speed of 189.04 mph at the end of the quarter mile, <em>Hot Rod Magazine</em> reports. </p><div class="nativo-article-slot"></div>
<p>While those results, on two subsequent runs at Palm Beach International Raceway, each set records, the team missed their ultimate goal of hitting 200 mph in the quarter mile after the car broke an axle in a third attempt. </p>
<p>In addition to his eight national drag racing championships in the sport's fastest Top Fuel class, the 87-year-old Garlits—known as "Big Daddy" in the sport—also held the previous record for a quarter mile pass in an electric dragster set in 2014 at 184 mph.</p>
<p>That car used many of Garlits' well-known innovations, such as an aerodynamic (and protective) canopy over the cockpit and a "spoon" front end with wide fenders covering smaller front wheels. </p>
<p></p><div class="image_wrapper"><img name="tccimg_100474324_l" title="Don Garlits broke the 200 mph mark 50 years ago" src="data:image/png;base64,R0lGODlhAQABAAD/ACwAAAAAAQABAAACADs=" alt="Don Garlits broke the 200 mph mark 50 years ago" width="1024" height="479" data-width="1024" data-height="479" data-url="https://images.hgmsites.net/lrg/don-garlits-broke-the-200-mph-mark-50-years-ago_100474324_l.jpg" data-src="https://images.hgmsites.net/lrg/don-garlits-broke-the-200-mph-mark-50-years-ago_100474324_l.jpg" class="lazy"><p>Don Garlits broke the 200 mph mark 50 years ago</p></div>
<p>For the latest attempt at 200 mph, Garlits and his team went back to basics, stripping 1,000 pounds out of the dragster, getting it down to 1,500 pounds and giving it a more classic look.</p>
<p>The dragster uses a wound, 800-horsepower motor from an electric speed-record-setting motorcycle. While its massive 1,500 pound-feet of torque output proved too much for the axle Garlits used, the motor brought some new excitement to the drag-racing stands. After the sun set for the last run, spectators could see current arcing through the motor as Garlits smoked the tires to warm them for the final run.</p>
<p>"Big Daddy" isn't the only drag racer interested in electric power. Drag strips have <a href="https://www.greencarreports.com/news/1110669_souths-good-ol-boy-drag-racers-whupped-by-tesla-not-happy-about-it">hosted plenty of Teslas at weekend grudge nights</a>. And the National Hot Rod Association, the sport's main sanctioning body, is considering <a href="https://www.greencarreports.com/news/1117468_not-exactly-top-fuel-electric-cars-come-to-top-level-drag-racing">opening a class for electric dragsters</a>. Top funny-car driver Bob Tasca III, who also owns a large chain of car dealerships, says he's looking forward to their arrival.</p>
</section>
<section class="footer">
</section>
<div class="article-tags">
<h3>Tags:</h3>
<a href="/news/electric-cars">Electric Cars</a>
<a href="/news/news">News</a>
<a href="/news/racing">Racing</a>
</div>
<div class="article-contribute">
<h3>Contribute:</h3>
<ul>
<li><a href="/contactus">
<i class="icon fas fa-lightbulb"></i> Send us a tip
</a>
<li><a href="javascript:void(0)" class="comments-link">
<i class="icon fas fa-comments"></i><span>Comment</span>
</a>
<li><a href="/contactus">
<i class="icon fas fa-pencil-alt"></i> Contact the editor
</a>
</ul>
</div>
<div class="related-galleries">
<h3>Recommended Galleries</h3>
<div class="related-galleries-wrapper">
<div class="item">
<a href="/news/1124223_2020-chevrolet-silverado-diesel-fuel-economy" class="image">
<img class="lazy" data-id="100705015" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg3.ibsrv.net/ibimg/hgm/1920x1080-1/100/705/2020-chevrolet-silverado-1500_100705015.jpg" alt="2020 Chevrolet Silverado 1500 diesel" data-srcset="https://cimg3.ibsrv.net/ibimg/hgm/900x506-1/100/705/2020-chevrolet-silverado-1500_100705015.jpg 900w, https://cimg3.ibsrv.net/ibimg/hgm/450x253-1/100/705/2020-chevrolet-silverado-1500_100705015.jpg 450w" sizes="(min-width: 768px) 450px, (min-width: 1024px) 313px, 300px">
</a>
<div class="title">
<a href="/news/1124223_2020-chevrolet-silverado-diesel-fuel-economy">2020 Chevrolet Silverado diesel tops pickup truck mpg race</a>
</div>
</div>
<div class="item">
<a href="/news/1124208_bmw-doubles-battery-production-in-us-for-coming-x3-and-x5-plug-in-hybrids" class="image">
<img class="lazy" data-id="100669610" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg2.ibsrv.net/ibimg/hgm/1920x1080-1/100/669/bmw-x5-series_100669610.jpg" alt="2021 BMW X5 xDrive45e iPerformance" data-srcset="https://cimg2.ibsrv.net/ibimg/hgm/900x506-1/100/669/bmw-x5-series_100669610.jpg 900w, https://cimg2.ibsrv.net/ibimg/hgm/450x253-1/100/669/bmw-x5-series_100669610.jpg 450w" sizes="(min-width: 768px) 450px, (min-width: 1024px) 313px, 300px">
</a>
<div class="title">
<a href="/news/1124208_bmw-doubles-battery-production-in-us-for-coming-x3-and-x5-plug-in-hybrids">BMW doubles battery production in US for coming X3 and X5 plug-in hybrids</a>
</div>
</div>
<div class="item">
<a href="/news/1124171_electric-ford-f-150-prototype-shown-towing-a-freight-train" class="image">
<img class="lazy" data-id="100709174" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg2.ibsrv.net/ibimg/hgm/1920x1080-1/100/709/ford-f-150_100709174.jpg" alt="Ford F-Series electric truck prototype" data-srcset="https://cimg2.ibsrv.net/ibimg/hgm/900x506-1/100/709/ford-f-150_100709174.jpg 900w, https://cimg2.ibsrv.net/ibimg/hgm/450x253-1/100/709/ford-f-150_100709174.jpg 450w" sizes="(min-width: 768px) 450px, (min-width: 1024px) 313px, 300px">
</a>
<div class="title">
<a href="/news/1124171_electric-ford-f-150-prototype-shown-towing-a-freight-train">Electric Ford F-150 prototype shown towing a freight train</a>
</div>
</div>
<div class="item">
<a href="/news/1124160_first-drive-review-is-2019-porsche-cayenne-e-hybrid-electric-enough" class="image">
<img class="lazy" data-id="100708753" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg1.ibsrv.net/ibimg/hgm/1920x1080-1/100/708/2019-porsche-cayenne_100708753.jpg" alt="2019 Porsche Cayenne E-Hybrid" data-srcset="https://cimg1.ibsrv.net/ibimg/hgm/900x506-1/100/708/2019-porsche-cayenne_100708753.jpg 900w, https://cimg1.ibsrv.net/ibimg/hgm/450x253-1/100/708/2019-porsche-cayenne_100708753.jpg 450w" sizes="(min-width: 768px) 450px, (min-width: 1024px) 313px, 300px">
</a>
<div class="title">
<a href="/news/1124160_first-drive-review-is-2019-porsche-cayenne-e-hybrid-electric-enough">First drive review: Is 2019 Porsche Cayenne E-Hybrid electric enough?</a>
</div>
</div>
</div>
</div>
<div class="adv-spacer">
<div id="ad-a-2"></div>
</div>
<div style="margin-top: 2em" class="footer-block">
<div class="share-this">
<h3>Share This Article:</h3>
<a class="social-btn fab fa-facebook-f facebook" href="javascript:void(0)" title="Share this article on Facebook" onclick="window.open('https://www.facebook.com/sharer.php?t=%22Big%20Daddy%22%20drag%20racer%20Don%20Garlits%20sets%20electric%20dragster%20record&u=https%3A%2F%2Fwww.greencarreports.com%2Fnews%2F1124259_big-daddy-drag-racer-don-garlits-sets-electric-dragster-record', 'social', 'toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=700, height=300'); hgm.socialShare('Facebook', 'https://www.greencarreports.com/news/1124259_big-daddy-drag-racer-don-garlits-sets-electric-dragster-record');">
</a>
<a class="social-btn fab fa-twitter twitter" href="javascript:void(0)" title="Tweet this article" onclick="window.open('https://twitter.com/intent/tweet?text=%22Big%20Daddy%22%20drag%20racer%20Don%20Garlits%20sets%20electric%20dragster%20record&url=https%3A%2F%2Fwww.greencarreports.com%2Fnews%2F1124259_big-daddy-drag-racer-don-garlits-sets-electric-dragster-record', 'social', 'toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=700, height=300'); hgm.socialShare('Twitter', 'https://www.greencarreports.com/news/1124259_big-daddy-drag-racer-don-garlits-sets-electric-dragster-record');">
</a>
<a class="social-btn fab fa-linkedin-in linkedin" href="javascript:void(0)" title="Share this article on LinkedIn" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true?title=%22Big%20Daddy%22%20drag%20racer%20Don%20Garlits%20sets%20electric%20dragster%20record&url=https%3A%2F%2Fwww.greencarreports.com%2Fnews%2F1124259_big-daddy-drag-racer-don-garlits-sets-electric-dragster-record&source=GreenCarReports.com', 'social', 'toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=700, height=300'); hgm.socialShare('LinkedIn', 'https://www.greencarreports.com/news/1124259_big-daddy-drag-racer-don-garlits-sets-electric-dragster-record');">
</a>
<a class="social-btn far fa-envelope email" href="javascript:void(0)" title="Email this article" onclick="window.open('mailto:?subject=%22Big%20Daddy%22%20drag%20racer%20Don%20Garlits%20sets%20electric%20dragster%20record&body=Hi%20There%2C%0A%0AI%20thought%20you%20might%20like%20this%20article%3A%0A%0A%20%20%20%20%22Big%20Daddy%22%20drag%20racer%20Don%20Garlits%20sets%20electric%20dragster%20record%0A%20%20%20%20https%3A%2F%2Fwww.greencarreports.com%2Fnews%2F1124259_big-daddy-drag-racer-don-garlits-sets-electric-dragster-record%0A%0ACheers%21%0A', 'social', 'toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=700, height=300'); hgm.socialShare('Email', 'https://www.greencarreports.com/news/1124259_big-daddy-drag-racer-don-garlits-sets-electric-dragster-record');">
</a>
</div>
</div>
<div class="footer-block">
<div id="article-author">
<h3>connect with the editor:</h3>
<a href="/writer/10064169_eric-c-evarts">
<img src="https://images.hgmsites.net/sml/avatar-image-for-eevarts_100649159_s.jpg" class="portrait" alt="Eric C. Evarts">
</a>
<a href="/writer/10064169_eric-c-evarts" rel="author" class="by-line">
Eric C. Evarts - Contributor
</a>
</div>
<div class="follow-us">
<h3>Follow Us Today:</h3>
<a class="social-btn" title="Like us on Facebook" href="https://www.facebook.com/GreenCarReports" target="_blank" onclick="hgm.socialFollow('Facebook', 'GreenCarReports'); return true;">
<span class="fab fa-facebook-f"></span>
</a>
<a class="social-btn" title="Follow us on Twitter" href="https://www.twitter.com/GreenCarReports" target="_blank" onclick="hgm.socialFollow('Twitter', 'GreenCarReports'); return true;">
<span class="fab fa-twitter"></span>
</a>
<a class="social-btn" title="Follow us on Instagram" href="https://www.instagram.com/greencarreports/" target="_blank" onclick="hgm.socialFollow('Instagram', 'greencarreports'); return true;">
<span class="fab fa-instagram"></span>
</a>
<a class="social-btn" title="Subscribe to our YouTube channel" href="https://www.youtube.com/user/greencarreports" target="_blank" onclick="hgm.socialFollow('YouTube', 'greencarreports'); return true;">
<span class="fab fa-youtube"></span>
</a>
</div>
</div>
<div class="newsletter-signup  newsletter-signup-wide ">
<h3>Green Car Reports Newsletter</h3>
<p>
Sign up to get the latest green car and environmental news, delivered to your inbox daily!
</p>
<form data-pos="wide" class="newsletter-signup-form" action="/api/newsletter-subscribe" method="post">
<input class="newsletter-email" type="email" name="email" placeholder="Enter your email address…" required data-msg="Email is required">
<button class="red-button newsletter-signup-btn" type="submit">Sign Up Today!</button>
<div class="response_message"></div>
</form>
<p>
I agree to receive emails from the site. I can withdraw my consent at any time by unsubscribing.
</p>
</div>
<div id="disqus_thread"></div>
</article>
</div>
<div class="right-col gcr-rail ">
<aside>
<div id="ad-a-3"></div>
<div class="related-articles">
<h2 class="title">Related Articles</h2>
<ul class="block-list rail-related-list">
<li>
<a class="block-image" href="/news/1124230_tesla-cto-and-battery-mastermind-jb-straubel-exits">
<img class="lazy" data-id="100559713" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg1.ibsrv.net/ibimg/hgm/1920x1080-1/100/559/tour-of-tesla-battery-gigafactory-for-invited-owners-reno-nevada-july-2016_100559713.jpg" alt="Tesla CTO JB Straubel and CEO Elon Musk presenting at gigafactory tour, Reno, Nevada, July 2016" data-srcset="https://cimg1.ibsrv.net/ibimg/hgm/200x113-1/100/559/tour-of-tesla-battery-gigafactory-for-invited-owners-reno-nevada-july-2016_100559713.jpg 200w, https://cimg1.ibsrv.net/ibimg/hgm/100x56-1/100/559/tour-of-tesla-battery-gigafactory-for-invited-owners-reno-nevada-july-2016_100559713.jpg 100w" sizes="100px">
</a>
<a class="block-link" href="/news/1124230_tesla-cto-and-battery-mastermind-jb-straubel-exits">
Tesla CTO and battery mastermind JB Straubel exits
</a>
</li>
<li>
<a class="block-image" href="/news/1124231_california-could-soon-close-one-of-the-dirtiest-diesel-emissions-loopholes">
<img class="lazy" data-id="100658178" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg2.ibsrv.net/ibimg/hgm/1200x675-1/100/658/fitzgerald-glider-kits-headquarters-in-crossville-tennessee_100658178.jpg" alt="Fitzgerald Glider Kits headquarters in Crossville, Tennessee" data-srcset="https://cimg2.ibsrv.net/ibimg/hgm/200x113-1/100/658/fitzgerald-glider-kits-headquarters-in-crossville-tennessee_100658178.jpg 200w, https://cimg2.ibsrv.net/ibimg/hgm/100x56-1/100/658/fitzgerald-glider-kits-headquarters-in-crossville-tennessee_100658178.jpg 100w" sizes="100px">
</a>
<a class="block-link" href="/news/1124231_california-could-soon-close-one-of-the-dirtiest-diesel-emissions-loopholes">
California could soon close one of the dirtiest diesel-emissions loopholes
</a>
</li>
<li>
<a class="block-image" href="/news/1124260_tesla-losses-cleaner-trucks-nissan-leaf-bmw-batteries-california-deals-the-week-in-reverse">
<img class="lazy" data-id="100709172" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg0.ibsrv.net/ibimg/hgm/1920x1080-1/100/709/ford-f-150_100709172.jpg" alt="Ford F-Series electric truck prototype" data-srcset="https://cimg0.ibsrv.net/ibimg/hgm/200x113-1/100/709/ford-f-150_100709172.jpg 200w, https://cimg0.ibsrv.net/ibimg/hgm/100x56-1/100/709/ford-f-150_100709172.jpg 100w" sizes="100px">
</a>
<a class="block-link" href="/news/1124260_tesla-losses-cleaner-trucks-nissan-leaf-bmw-batteries-california-deals-the-week-in-reverse">
Tesla losses, cleaner trucks, Nissan Leaf charging, California deals: The...
</a>
</li>
<li>
<a class="block-image" href="/news/1124223_2020-chevrolet-silverado-diesel-fuel-economy">
<img class="lazy" data-id="100705015" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg3.ibsrv.net/ibimg/hgm/1920x1080-1/100/705/2020-chevrolet-silverado-1500_100705015.jpg" alt="2020 Chevrolet Silverado 1500 diesel" data-srcset="https://cimg3.ibsrv.net/ibimg/hgm/200x113-1/100/705/2020-chevrolet-silverado-1500_100705015.jpg 200w, https://cimg3.ibsrv.net/ibimg/hgm/100x56-1/100/705/2020-chevrolet-silverado-1500_100705015.jpg 100w" sizes="100px">
</a>
<a class="block-link" href="/news/1124223_2020-chevrolet-silverado-diesel-fuel-economy">
2020 Chevrolet Silverado diesel tops pickup truck mpg race
</a>
</li>
<li>
 <a class="block-image" href="/news/1124245_tesla-cto-2020-chevy-silverado-diesel-mpg-tire-energy-cleaning-up-trucks-todays-car-news">
<img class="lazy" data-id="100679781" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg1.ibsrv.net/ibimg/hgm/2000x1125-1/100/679/2019-chevrolet-silverado-1500_100679781.jpg" alt="2019 Chevrolet Silverado 1500" data-srcset="https://cimg1.ibsrv.net/ibimg/hgm/200x113-1/100/679/2019-chevrolet-silverado-1500_100679781.jpg 200w, https://cimg1.ibsrv.net/ibimg/hgm/100x56-1/100/679/2019-chevrolet-silverado-1500_100679781.jpg 100w" sizes="100px">
</a>
<a class="block-link" href="/news/1124245_tesla-cto-2020-chevy-silverado-diesel-mpg-tire-energy-cleaning-up-trucks-todays-car-news">
Tesla CTO, 2020 Chevy Silverado diesel mpg, tire energy, cleaning up...
</a>
</li>
<li>
<a class="block-image" href="/news/1124210_tesla-q2-2019-profitability-model-y-china-built-model-3">
<img class="lazy" data-id="100695316" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg0.ibsrv.net/ibimg/hgm/1920x1080-1/100/695/tesla-model-y_100695316.jpg" alt="Tesla Model Y" data-srcset="https://cimg0.ibsrv.net/ibimg/hgm/200x113-1/100/695/tesla-model-y_100695316.jpg 200w, https://cimg0.ibsrv.net/ibimg/hgm/100x56-1/100/695/tesla-model-y_100695316.jpg 100w" sizes="100px">
</a>
<a class="block-link" href="/news/1124210_tesla-q2-2019-profitability-model-y-china-built-model-3">
Amid scrutiny, Tesla sees higher margins ahead for Model Y, China-built...
</a>
</li>
</ul>
</div>
<div id="ad-a-4"></div>
<h3>Most Popular</h3>
<div class="rail-box most-popular">
<div class="item opacity-background  lazy-background " data-background="https://images.hgmsites.net/med/ford-f-150_100709173_m.jpg">
<div class="overlay"></div>
<div class="info">
<div class="date">
July 23, 2019
</div>
<div class="title">
<a href="/news/1124171_electric-ford-f-150-prototype-shown-towing-a-freight-train">Electric Ford F-150 prototype shown towing a freight train</a>
</div>
<div class="comment">
<a href="/writer/10064169_eric-c-evarts" rel="author">
Eric C. Evarts - Contributor
</a>
</div>
</div>
</div>
<div class="item opacity-background  lazy-background " data-background="https://images.hgmsites.net/med/2019-nissan-leaf_100685576_m.jpg">
<div class="overlay"></div>
<div class="info">
<div class="date">
July 24, 2019
</div>
<div class="title">
<a href="/news/1124182_report-us-nissan-leaf-owners-to-get-update-allowing-subsequent-fast-charges">Report: US Nissan Leaf owners to get update allowing subsequent fast charges–updated</a>
</div>
<div class="comment">
<a href="/writer/10064169_eric-c-evarts" rel="author">
Eric C. Evarts - Contributor
</a>
 </div>
</div>
</div>
<div class="item opacity-background  lazy-background " data-background="https://images.hgmsites.net/med/2019-porsche-cayenne_100708753_m.jpg">
<div class="overlay"></div>
<div class="info">
<div class="date">
July 23, 2019
</div>
<div class="title">
<a href="/news/1124160_first-drive-review-is-2019-porsche-cayenne-e-hybrid-electric-enough">First drive review: Is 2019 Porsche Cayenne E-Hybrid electric enough?</a>
</div>
<div class="comment">
<a href="/writer/10001004_bengt-halvorson" rel="author">
Bengt Halvorson - Senior Editor
</a>
</div>
</div>
</div>
<div class="item opacity-background  lazy-background " data-background="https://images.hgmsites.net/med/ford-f-150_100709174_m.jpg">
<div class="overlay"></div>
<div class="info">
<div class="date">
July 23, 2019
</div>
<div class="title">
<a href="/news/1124173_electric-ford-f-150-porsche-cayenne-e-hybrid-honda-electric-cars-todays-car-news">Electric Ford F-150, Porsche Cayenne E-Hybrid, Honda electric cars: Today&#039;s Car News</a>
</div>
<div class="comment">
<a href="/writer/10064169_eric-c-evarts" rel="author">
Eric C. Evarts - Contributor
</a>
</div>
</div>
</div>
<div class="item opacity-background  lazy-background " data-background="https://images.hgmsites.net/med/bmw-x3-xdrive30e_100694698_m.jpg">
<div class="overlay"></div>
<div class="info">
<div class="date">
July 25, 2019
</div>
<div class="title">
<a href="/news/1124218_california-deal-tesla-losses-bmw-batteries-rogue-hybrid-gone-todays-car-news">California deal, Tesla losses, BMW batteries, Rogue Hybrid gone: Today&#039;s Car News</a>
</div>
<div class="comment">
<a href="/writer/10064169_eric-c-evarts" rel="author">
Eric C. Evarts - Contributor
</a>
</div>
</div>
</div>
<div class="item opacity-background  lazy-background " data-background="https://images.hgmsites.net/med/2020-chevrolet-silverado-1500_100705015_m.jpg">
<div class="overlay"></div>
<div class="info">
<div class="date">
July 26, 2019
</div>
<div class="title">
<a href="/news/1124223_2020-chevrolet-silverado-diesel-fuel-economy">2020 Chevrolet Silverado diesel tops pickup truck mpg race</a>
</div>
<div class="comment">
<a href="/writer/10064169_eric-c-evarts" rel="author">
Eric C. Evarts - Contributor
</a>
</div>
</div>
</div>
<div class="clear"></div>
</div>
<div class="gcr-fixed-anchor"></div>
<div class="gcr-fixed-content">
<div class="photo-galleries-swiper">
<h3>Photos</h3>
<div class="pagination-container">
<div class="swiper-prev">&lt;</div>
<div class="swiper-counter"></div>
<div class="swiper-next">&gt;</div>
</div>
<div class="swiper-container">
<div class="swiper-wrapper">
<div class="swiper-slide">
<div class="swiper-image item">
<a href="/news/1124223_2020-chevrolet-silverado-diesel-fuel-economy" class="img-wrap">
<img class="lazy" data-id="100705015" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg3.ibsrv.net/ibimg/hgm/1920x1080-1/100/705/2020-chevrolet-silverado-1500_100705015.jpg" alt="2020 Chevrolet Silverado 1500 diesel" data-srcset="https://cimg3.ibsrv.net/ibimg/hgm/1920x1080-1/100/705/2020-chevrolet-silverado-1500_100705015.jpg 1920w, https://cimg3.ibsrv.net/ibimg/hgm/1200x675-1/100/705/2020-chevrolet-silverado-1500_100705015.jpg 1200w, https://cimg3.ibsrv.net/ibimg/hgm/1024x576-1/100/705/2020-chevrolet-silverado-1500_100705015.jpg 1024w, https://cimg3.ibsrv.net/ibimg/hgm/600x338-1/100/705/2020-chevrolet-silverado-1500_100705015.jpg 600w" sizes="(max-width: 2000px) 600px, calc(100vw - 0rem)">
</a>
<a href="/news/1124223_2020-chevrolet-silverado-diesel-fuel-economy" class="title">2020 Chevrolet Silverado diesel tops pickup truck mpg race</a>
</div>
</div>
<div class="swiper-slide">
<div class="swiper-image item">
<a href="/news/1124208_bmw-doubles-battery-production-in-us-for-coming-x3-and-x5-plug-in-hybrids" class="img-wrap">
<img class="lazy" data-id="100669606" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg2.ibsrv.net/ibimg/hgm/1920x1080-1/100/669/bmw-x5-series_100669606.jpg" alt="2021 BMW X5 xDrive45e iPerformance" data-srcset="https://cimg2.ibsrv.net/ibimg/hgm/1920x1080-1/100/669/bmw-x5-series_100669606.jpg 1920w, https://cimg2.ibsrv.net/ibimg/hgm/1200x675-1/100/669/bmw-x5-series_100669606.jpg 1200w, https://cimg2.ibsrv.net/ibimg/hgm/1024x576-1/100/669/bmw-x5-series_100669606.jpg 1024w, https://cimg2.ibsrv.net/ibimg/hgm/600x338-1/100/669/bmw-x5-series_100669606.jpg 600w" sizes="(max-width: 2000px) 600px, calc(100vw - 0rem)">
</a>
<a href="/news/1124208_bmw-doubles-battery-production-in-us-for-coming-x3-and-x5-plug-in-hybrids" class="title">BMW doubles battery production in US for coming X3 and X5 plug-in hybrids</a>
</div>
</div>
<div class="swiper-slide">
<div class="swiper-image item">
<a href="/news/1124171_electric-ford-f-150-prototype-shown-towing-a-freight-train" class="img-wrap">
<img class="lazy" data-id="100709173" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg1.ibsrv.net/ibimg/hgm/1920x1080-1/100/709/ford-f-150_100709173.jpg" alt="Ford F-Series electric truck prototype" data-srcset="https://cimg1.ibsrv.net/ibimg/hgm/1920x1080-1/100/709/ford-f-150_100709173.jpg 1920w, https://cimg1.ibsrv.net/ibimg/hgm/1200x675-1/100/709/ford-f-150_100709173.jpg 1200w, https://cimg1.ibsrv.net/ibimg/hgm/1024x576-1/100/709/ford-f-150_100709173.jpg 1024w, https://cimg1.ibsrv.net/ibimg/hgm/600x338-1/100/709/ford-f-150_100709173.jpg 600w" sizes="(max-width: 2000px) 600px, calc(100vw - 0rem)">
</a>
<a href="/news/1124171_electric-ford-f-150-prototype-shown-towing-a-freight-train" class="title">Electric Ford F-150 prototype shown towing a freight train</a>
</div>
</div>
<div class="swiper-slide">
<div class="swiper-image item">
<a href="/news/1124160_first-drive-review-is-2019-porsche-cayenne-e-hybrid-electric-enough" class="img-wrap">
<img class="lazy" data-id="100708753" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg1.ibsrv.net/ibimg/hgm/1920x1080-1/100/708/2019-porsche-cayenne_100708753.jpg" alt="2019 Porsche Cayenne E-Hybrid" data-srcset="https://cimg1.ibsrv.net/ibimg/hgm/1920x1080-1/100/708/2019-porsche-cayenne_100708753.jpg 1920w, https://cimg1.ibsrv.net/ibimg/hgm/1200x675-1/100/708/2019-porsche-cayenne_100708753.jpg 1200w, https://cimg1.ibsrv.net/ibimg/hgm/1024x576-1/100/708/2019-porsche-cayenne_100708753.jpg 1024w, https://cimg1.ibsrv.net/ibimg/hgm/600x338-1/100/708/2019-porsche-cayenne_100708753.jpg 600w" sizes="(max-width: 2000px) 600px, calc(100vw - 0rem)">
</a>
<a href="/news/1124160_first-drive-review-is-2019-porsche-cayenne-e-hybrid-electric-enough" class="title">First drive review: Is 2019 Porsche Cayenne E-Hybrid electric enough?</a>
</div>
</div>
<div class="swiper-slide">
<div class="swiper-image item">
<a href="/news/1124135_faster-shifts-could-make-2020-hyundai-sonata-hybrid-more-fun" class="img-wrap">
<img class="lazy" data-id="100708774" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 16 9 '%3E%3C/svg%3E" data-src="https://cimg2.ibsrv.net/ibimg/hgm/600x338-1/100/708/2020-hyundai-sonata-hybrid_100708774.jpg" alt="2020 Hyundai Sonata Hybrid" data-srcset="https://cimg2.ibsrv.net/ibimg/hgm/600x338-1/100/708/2020-hyundai-sonata-hybrid_100708774.jpg 600w" sizes="(max-width: 2000px) 600px, calc(100vw - 0rem)">
</a>
<a href="/news/1124135_faster-shifts-could-make-2020-hyundai-sonata-hybrid-more-fun" class="title">Faster shifts could make 2020 Hyundai Sonata Hybrid more fun</a>
</div>
</div>
</div>
</div>
</div>
<div id="ad-a-5"></div>
</div>
</aside>
</div>
</div>
</div>
</div>
<a href="#" class="footer-waypoint-anchor"></a>
<footer>
<div class="footer-content">
<div class="footer-logo">
<a href="/" title="Green Car Reports">
<div class="logo-type"></div>
</a>
</div>
<div class="footer-links">
<div class="footer-link-section1 gcr">
<div class="footer-link-section">
<h4>News</h4>
<ul>
<li><a class="foot-link" href="/news/charging">Charging</a></li>
<li><a class="foot-link" href="/news/mobility">Mobility</a></li>
<li><a class="foot-link" href="/news/sustainability">Sustainability</a></li>
<li><a class="foot-link" href="/news/gas-mileage">Gas Mileage </a></li>
<li><a class="foot-link" href="/news/hybrid-cars">Hybrids</a></li>
<li><a class="foot-link" href="/news/electric-cars">Electric Cars</a></li>
<li><a class="foot-link" href="/news/alternative-fuels">Alt Fuels</a></li>
 <li><a class="foot-link" href="/news/diesel">Diesel Cars</a></li>
<li><a class="foot-link" href="/news/features">Features</a></li>
<li><a class="foot-link" href="/news">View All </a></li>
</ul>
</div>
</div>
<div class="footer-link-section2">
<div class="footer-link-section">
<h4>Media</h4>
<ul>
<li><a class="foot-link" href="/pictures">Photos</a></li>
<li><a class="foot-link" href="/videos">Videos</a></li>
</ul>
</div>
<div class="footer-link-section">
<h4>RSS</h4>
<ul>
<li><a class="foot-link" href="/rss-feeds">All Feeds</a></li>
<li><a class="foot-link" href="https://feeds.highgearmedia.com/?sites=GreenCarReports">Master Feed</a></li>
<li><a class="foot-link" href="https://feeds.highgearmedia.com/?sites=GreenCarReports&amp;tags=news">News</a></li>
<li><a class="foot-link" href="https://feeds.highgearmedia.com/?sites=GreenCarReports&amp;tags=first-drives">First Drives</a></li>
<li><a class="foot-link" href="https://feeds.highgearmedia.com/?sites=GreenCarReports&amp;tags=electric-cars">Electric Cars</a></li>
<li><a class="foot-link" href="https://feeds.highgearmedia.com/?sites=GreenCarReports&amp;tags=hybrid-cars">Hybrids</a></li>
<li><a class="foot-link" href="https://feeds.highgearmedia.com/?sites=GreenCarReports&amp;tags=buying-guides">Guides</a></li>
<li><a class="foot-link" href="https://feeds.highgearmedia.com/?sites=GreenCarReports&amp;tags=green-life">Green Life</a></li>
</ul>
</div>
<div class="footer-link-section">
<div>
<h4>Company</h4>
<ul>
<li><a class="foot-link" href="/aboutus">About Us</a></li>
<li><a class="foot-link" href="/contactus">Contact Us</a></li>
<li><a class="foot-link" href="http://ibauto.tumblr.com/">Press</a></li>
<li><a class="foot-link" href="https://www.internetbrands.com/ibterms/">Legal</a></li>
<li><a class="foot-link" href="https://www.internetbrands.com/ibterms/supplementalcarrelatedterms/">Disclaimer</a></li>
<li><a class="foot-link" href="https://www.internetbrands.com/privacy/privacy-highlights.html">Privacy Policy</a></li>
</ul>
</div>
<div class="footer-other-sites">
<h4>Our Other Sites</h4>
<ul>
<li><a class="foot-link" href="https://www.thecarconnection.com/">The Car Connection</a></li>
<li><a class="foot-link" href="https://www.motorauthority.com/">Motor Authority</a></li>
</ul>
</div>
</div>
</div>
</div>
<div class="footer-social-app-btns">
<section class="social">
<div class="follow-us">
<h3>Follow Us Today:</h3>
<a class="social-btn" title="Like us on Facebook" href="https://www.facebook.com/GreenCarReports" target="_blank" onclick="hgm.socialFollow('Facebook', 'GreenCarReports'); return true;">
<span class="fab fa-facebook-f"></span>
</a>
<a class="social-btn" title="Follow us on Twitter" href="https://www.twitter.com/GreenCarReports" target="_blank" onclick="hgm.socialFollow('Twitter', 'GreenCarReports'); return true;">
<span class="fab fa-twitter"></span>
</a>
<a class="social-btn" title="Follow us on Instagram" href="https://www.instagram.com/greencarreports/" target="_blank" onclick="hgm.socialFollow('Instagram', 'greencarreports'); return true;">
<span class="fab fa-instagram"></span>
</a>
<a class="social-btn" title="Subscribe to our YouTube channel" href="https://www.youtube.com/user/greencarreports" target="_blank" onclick="hgm.socialFollow('YouTube', 'greencarreports'); return true;">
<span class="fab fa-youtube"></span>
</a>
</div>
</section>
</div>
</div>
<div class="copyright">
&copy; 2019 MH Sub I, LLC. All Rights Reserved.
Stock photography by <a href="https://www.izmocars.com/">izmostock.</a>
Read our <a href="//www.internetbrands.com/privacy/cookie-policy.html">Cookie Policy</a>.
</div>
</footer>
<div class="adv-spacer bottom">
<div id="bottom-sticky"></div>
</div>
<div class="adv-body-shift  active "></div>
<div class="nav-menu" data-menu="news">
<div class="nav-menu-items 2">
<div class="nav-menu-col nav-menu-col-news">
<a href="/news/charging">Charging</a>
<a href="/news/mobility">Mobility</a>
<a href="/news/sustainability">Sustainability</a>
</div>
<div class="nav-menu-col nav-menu-col-news">
<a href="/news/gas-mileage">Gas Mileage </a>
<a href="/news/hybrid-cars">Hybrids</a>
<a href="/news/electric-cars">Electric Cars</a>
</div>
<div class="nav-menu-col nav-menu-col-news">
<a href="/news/alternative-fuels">Alt Fuels</a>
<a href="/news/diesel">Diesel Cars</a>
<a href="/news/features">Features</a>
</div>
<div class="nav-menu-col nav-menu-col-news">
<a href="/news">View All </a>
</div>
</div>
</div>
<div class="nav-menu" data-menu="newsletter">
<div class="nav-menu-items nav-signup">
<div class="heading">Green Car Reports Newsletter</div>
<div>Sign up to get the latest green car and environmental news, delivered to your inbox daily!</div>
<form data-pos="navigation" class="newsletter-signup-form" action="/api/newsletter-subscribe" method="post">
<input type="email" class="email" name="email" placeholder="Enter your email address…" required data-msg="Email is required">
<button class="red-button newsletter-signup-btn" type="submit">Sign Up Today!</button>
<div class="response_message"></div>
</form>
</div>
<div class="signup-consent">I agree to receive emails from the site. I can withdraw my consent at any time by unsubscribing.</div>
</div>
<div class="nav-menu nav-menu-search" data-menu="search" data-engine="001937828977938864696:tstejjfkb_g" data-placeholder="Search Green Car Reports...">
<div class="nav-search">
<gcse:searchbox-only enableHistory="true" autoCompleteMaxCompletions="10" autoCompleteMatchType='any' resultsUrl="/searchresults"></gcse:searchbox-only>
</div>
</div>
<div class="device-nav">
<a class="nav-link  cat-link " href="/news">News</a>
<div class="nav-categories">
<a href="/news/charging">Charging</a>
<a href="/news/mobility">Mobility</a>
<a href="/news/sustainability">Sustainability</a>
<a href="/news/gas-mileage">Gas Mileage </a>
<a href="/news/hybrid-cars">Hybrids</a>
<a href="/news/electric-cars">Electric Cars</a>
<a href="/news/alternative-fuels">Alt Fuels</a>
<a href="/news/diesel">Diesel Cars</a>
<a href="/news/features">Features</a>
<a href="/news">View All </a>
</div>
<a class="nav-link " href="/news/first-drives">First Drives</a>
<a class="nav-link " href="/news/electric-cars">Electric Cars</a>
<a class="nav-link " href="/news/hybrid-cars">Hybrids</a>
<a class="nav-link " href="/news/buying-guides">Guides</a>
<a class="nav-link " href="/news/green-life">Green Life</a>
<li class="mobile-newsletter">
<div class="newsletter-wrapper">
<div class="newsletter-title">Never Miss a Green Car Reports Story</div>
<form class="newsletter-signup-form" action="/api/newsletter-subscribe" method="post">
<input type="email" class="email" name="email" placeholder="Enter your email address…" required data-msg="Email is required">
<br>
<button class="red-button newsletter-signup-btn" type="submit">subscribe today</button>
<div class="response_message"></div>
</form>
</div>
</li>
</div>
<script src="/js/vendor.js?id=497cadd5c6e8922bd00c"></script>
<script src="/js/app.js?id=8f0d74fb5a6d6e6d01fb"></script>
<script>
(function(){
        hgm.initArticles();
        hgmads.initFromDeferred();
            hgmads.initDynamicAds($('.article-body'));
            googletag.cmd.push(function () {
                hgmads.renderDynamicAds();
            });;
hgm.initSearch();
hgm.initSearch();
}());
</script>
<script src="/js/footer.js?id=ec965114dd03d3a40dc3"></script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"fcb635eb66","applicationID":"135926744","transactionName":"MgcAYUMDDUFWAkJaDAtNI1ZFCwxcGA9TRBBIAxBBWAEPVw==","queueTime":0,"applicationTime":107,"atts":"HkAXFwsZHh4VABQJGBgf","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
