<!DOCTYPE html>
<html version="HTML+RDFa 1.0" xmlns:og="https://ogp.me/ns#" lang="en" data-site-id="40016" data-tmplt="77267" data-site="77267" data-addr="10.16.88.191" data-time="2019-05-28T09:06:58-0700" data-env="production" data-debug="false" data-layout="desktop">
<head>
<script>
            var traffic = 0.5;

            (function (w, d) {
                if (!/bot|google|baidu|bing|msn|duckduckbot|teoma|slurp|yandex|facebot|facebookexternalhit/i.test(navigator.userAgent)) {
                    var m = /(?:^|; )hgm.test=([^;]*)/.exec(d.cookie),
                        c = m ? m[1] : null;
                    if (!c) {
                        c = Math.random() > traffic ? 'a' : 'b';
                        d.cookie = 'hgm.test=' + c + '; expires=Sun, 31 Mar 2020 00:00:00 GMT; path=/';
                    }
                    if (traffic === 1 || c === 'b') {
                        w.location = w.location.href.replace('www.', 'www2.');
                    }
                }
            }(window, document));
        </script>
<script type='text/javascript' src='//cdn.districtm.ca/merge/all.ib.hg.js'></script>
<script>var _sf_startpt = (new Date()).getTime();</script>
<meta name="description" content="GM is planning an electric-car charging network. Chinese self-driving electric-car startup reveals more details about its upcoming models. Opel announces its first independent electric car. And our latest Twitter poll asks readers what's most important to them in fast-charging their electric cars. All this and more on Green Car Reports. General Motors...">
<meta charset="utf-8"><script type="text/javascript">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</script>
<meta property="fb:pages" content="143669659002741">
<meta property="fb:app_id" content="80517230974">
<meta property="og:site_name" content="Green Car Reports">
<meta property="og:type" content="article">
<meta property="og:title" content="Byton details, GM chargers, Opel electric, what readers want in fast charging: Today's Car News">
<meta property="og:url" content="https://www.greencarreports.com/news/1123290_byton-details-gm-chargers-opel-electric-what-readers-want-in-fast-charging-todays-car-news">
<meta property="og:image" content="https://images.hgmsites.net/hug/byton-m-byte-and-k-byte_100685161_h.jpg">
<meta property="og:description" content="GM is planning an electric-car charging network. Chinese self-driving electric-car startup reveals more details about its upcoming models. Opel announces its first independent electric car. And our latest Twitter poll asks readers what's most important to them in fast-charging their electric cars. All this and more on Green Car Reports. General Motors...">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@GreenCarReports">
<meta name="twitter:url" content="https://www.greencarreports.com/news/1123290_byton-details-gm-chargers-opel-electric-what-readers-want-in-fast-charging-todays-car-news">
<meta name="twitter:title" content="Byton details, GM chargers, Opel electric, what readers want in fast charging: Today's Car News">
<meta name="twitter:description" content="GM is planning an electric-car charging network. Chinese self-driving electric-car startup reveals more details about its upcoming models. Opel announces its first independent electric car. And our latest Twitter poll asks readers what's most important to them in fast-charging their electric cars. All this and more on Green Car Reports. General Motors...">
<meta name="twitter:image" content="https://images.hgmsites.net/lrg/byton-m-byte-and-k-byte_100685161_l.jpg">
<meta name="medium" content="news">
<meta name="google-site-verification" content="_jpgj7Gdl0aOLALvFlH2NqCQaJ8xdEH9Ixzhf0MNVLc">
<meta name="y_key" content="681bdcf9b8a767f9">
<meta name="msvalidate.01" content="7EF21B5F5DFF73B793E5432E9F541F94"><title>Byton details, GM chargers, Opel electric, what readers want in fast charging: Today's Car News</title><script type="application/ld+json">
{"@context":"https://schema.org","@type":"WebPage","@id":"https://www.greencarreports.com/news/1123290_byton-details-gm-chargers-opel-electric-what-readers-want-in-fast-charging-todays-car-news","url":"https://www.greencarreports.com/news/1123290_byton-details-gm-chargers-opel-electric-what-readers-want-in-fast-charging-todays-car-news","isPartOf":{"@type":"WebSite","@id":"https://www.greencarreports.com/#site"},"breadcrumb":{"@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://www.greencarreports.com/news","name":"News"}},{"@type":"ListItem","position":2,"item":{"@id":"https://www.greencarreports.com/news/today-in-car-news","name":"Today in Car News"}}]},"mainEntity":{"@type":"NewsArticle","@id":"https://www.greencarreports.com/news/1123290_byton-details-gm-chargers-opel-electric-what-readers-want-in-fast-charging-todays-car-news#this","url":"https://www.greencarreports.com/news/1123290_byton-details-gm-chargers-opel-electric-what-readers-want-in-fast-charging-todays-car-news","headline":"Byton details, GM chargers, Opel electric, what readers want in fast charging: Today's Car News","datePublished":"2019-05-28T08:30:00-0700","dateModified":"2019-05-28T08:41:13-0700","description":"GM is planning an electric-car charging network. Chinese self-driving electric-car startup reveals more details about its upcoming models. Opel announces its first independent electric car. And our latest Twitter poll asks readers what's most important to them in fast-charging their electric cars. All this and more on Green Car Reports. General Motors...","author":{"@type":"Person","name":"Eric C. Evarts","jobTitle":null,"image":"https://images.hgmsites.net/tny/avatar-image-for-eevarts_100649159_0.jpg","url":"https://www.greencarreports.com/writer/10064169_eric-c-evarts"},"publisher":{"@type":"Organization","@id":"https://www.greencarreports.com/#organization"},"articleSection":"Today in Car News","keywords":"Today in Car News","image":{"@type":"ImageObject","@id":"https://images.hgmsites.net/lrg/byton-m-byte-and-k-byte_100685161_l.jpg#this","url":"https://images.hgmsites.net/lrg/byton-m-byte-and-k-byte_100685161_l.jpg","caption":"Byton M-Byte and K-Byte","description":"","width":1024,"height":576,"uploadDate":"2019-01-06T22:39:33-0800"}}}
</script><script class="kxct" data-id="sh2lfhber" data-timing="async" data-version="3.0">
    window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);
    (function(){
        function retrieve(n){
            var k='kx'+'internetbrands_'+n, ls=(function(){
                try {
                    return window.localStorage;
                } catch(e) {
                    return null;
                }
            })();
            if (ls) {
                return ls[k] || '';
            } else if (navigator.cookieEnabled) {
                var m = document.cookie.match(k+'=([^;]*)');
                return (m && unescape(m[1])) || '';
            } else {
                return '';
            }
        }
        Krux.user = retrieve('user');
        Krux.segments = retrieve('segs').split(',');
        var k=document.createElement('script');k.type='text/javascript';k.async=true;
        k.src='https://cdn.krxd.net/controltag/sh2lfhber.js';
        var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(k,s);
    })();
</script>
<script async src="https://js-sec.indexww.com/ht/p/184397-164216896053308.js"></script>
<link href="https://feeds.highgearmedia.com/?sites=GreenCarReports" rel="alternate" type="application/rss+xml" title="Green Car Reports News">
<link href="https://images.hgmsites.net/hug/byton-m-byte-and-k-byte_100685161_h.jpg" rel="image_src">
<link href="https://www.greencarreports.com/news/1123290_byton-details-gm-chargers-opel-electric-what-readers-want-in-fast-charging-todays-car-news" rel="canonical">
<link href="/favicon.ico" rel="shortcut icon" type="image/x-icon">
<link href="/css_cache/547640.css" media="all" rel="stylesheet" type="text/css">
<link href="/css_cache/547734.css" media="all" rel="stylesheet" type="text/css">
<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.7.1/jquery.min.js"></script>
<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jqueryui/1.8.16/jquery-ui.min.js"></script>
<script type="text/javascript">
//<!--
$(document).ready(function() {
    sociallinks('itemid1123290_top');
});
//-->

</script>
<script type="text/javascript">
    
$(function () { hgm.social.fb.init('', null, '80517230974', false); });    
</script>
<script type="text/javascript">
    
$(function() { hgm.social.twttr.init('GreenCarReports'); });    
</script>
<script type="text/javascript" src="/js_cache/547637.js"></script>
<script type="text/javascript" src="/js_cache/547642.js"></script><script src="/ad.min.js"></script>
<script>
    
    var _gaq = _gaq || [];
    _gaq.push(
        ['_setAccount', 'UA-5588332-2'],
        // FIXME This doesn't take preview flag into account which may affect isPageMobile() result
        ['_setCustomVar', 1, 'Template', 'Desktop', 3],
        ['_setCustomVar', 3, 'Blocker Enabled', typeof sadfq2v3raesxf2dxx3r2348 == 'undefined' ? 'Yes' : 'No', 3],
        ['_setCustomVar', 4, 'Disabled Pixel ', (typeof disabledPixel == 'undefined' || disabledPixel == '') ? 'None' : disabledPixel, 3],
                    ['_trackPageview' ]
            );
    (function() {
        var ga = document.createElement('script');
        ga.type = 'text/javascript';
        ga.async = true;
        // ga.src = ('https:' === document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
        ga.src = 'https://stats.g.doubleclick.net/dc.js';
        document.documentElement.firstChild.appendChild(ga);
    }());
</script>
<script>
    var axel = Math.random() + "";
    var ord = axel * 1000000000000000000;
</script>
<!--[if lt IE 9 ]>
    <link rel="stylesheet" type="text/css" href="/css/ie7+.css"/>
<![endif]-->

<script src="//internetbrands-d.openx.net/w/1.0/jstag?nc=2922-GreenCarReports"></script>
<script>
    var gptadslots = [],
        apstagslots = [],
        googletag = googletag || {};
    googletag.cmd = googletag.cmd || [];
    (function(){
        var gads = document.createElement('script');
        var useSSL = 'https:' === document.location.protocol;
        gads.async = true;
        gads.type = 'text/javascript';
        gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
        var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(gads, node);
    })();
</script><script>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</script>
<script>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function()
    {q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];
        g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

    // initialize apstag and have apstag set bids on the googletag slots when they are returned to the page  
    apstag.init({    
        pubID:'3188',    
        adServer:'googletag',    
        bidTimeout:2e3
    });

//apstag.debug('anable');

    // request the bids for the four googletag slots  
googletag.cmd.push(function() {
    apstag.fetchBids({    
        slots: apstagslots
    },function(bids){
        hgm.debug("apstag request for the apstag :", bids);
        // trigger the first request to DFP 
        googletag.cmd.push(function(){  
            apstag.setDisplayBids();        });
    });
});
</script></head>
<body>
<script>
    // Google Tag Manager data
    dataLayer = [];
            dataLayer.push({"enable_inline_ads":true});
        if (typeof disabledPixel !== 'undefined') {
        dataLayer.push({'pixelToDisable': disabledPixel});
    }
</script>

<div id="body-inner">
<div id="global-container">

<script>
        var COMSCORE_CLIENT_ID = '7533348',
            _comscore = _comscore || [];

        _comscore.push({ c1: "2", c2: "7533348" });
        (function() {
            var s = document.createElement("script"),
                el = document.getElementsByTagName("script")[0];
            s.async = true;
            s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
            el.parentNode.insertBefore(s, el);
        })();
    </script>
<noscript>
        <img src="https://sb.scorecardresearch.com/p?c1=2&amp;c2=7533348&amp;c3=&amp;c4=&amp;c5=&amp;c6=&amp;c15=&amp;cj=1" />
    </noscript>
 <script type="text/javascript">
    if($.browser.msie && $.browser.version == "7.0") {
        var ie_box = "<div class='ie6_message_wrapper'>    \n\
        <div class='ie6_message'>  <h3>You are using an old browser which this site does not support, please upgrade to a modern browser.</h3>\n\
        <a href='https://www.mozilla.com/en-US/firefox/new/' class='firefox'></a> \n\
        <a href='https://www.apple.com/safari/' class='safari'></a>\n\
        <a href='https://www.microsoft.com/windows/internet-explorer/default.aspx' class='explorer'></a>\n\
        <a href='https://www.opera.com/browser/' class='opera'></a>\n\<a href='https://www.google.com/chrome/index.html' class='chrome'></a>\n\
        </div></div>";
        $("#ad-1").before(ie_box);
    }
</script>
<div id="masthead">
<div id="masterhead-inner" class="centerColumn">

<div class="header-logo"><a class="header-logo" href="/" title="Green Car Reports">Green Car Reports</a></div>
<div id="primary-nav">
<div id="primarynav-inner">
<div class="topnav-link">
<div class="vLine"></div>
<a href="/news" class="navlink">
<span class="navTxt">News</span>
</a>
<div id="submenu-news" class="submenu-dd">
<div class="submenu-outer">
<div id="submenu-news-item">
<div class="news-item">
<a class="category" href="/news/today-in-car-news">
Today in Car News </a>
<span class="date">37 minutes ago</span>
<a class="title" href="/news/1123290_byton-details-gm-chargers-opel-electric-what-readers-want-in-fast-charging-todays-car-news">
Byton details, GM chargers, Opel electric, what... </a>
<a class="image-link" href="/news/1123290_byton-details-gm-chargers-opel-electric-what-readers-want-in-fast-charging-todays-car-news" title="Byton details, GM chargers, Opel electric, what readers want in fast charging: Today's Car News">
<img class="fitfill" src="https://images.hgmsites.net/sml/byton-m-byte-and-k-byte_100685161_s.jpg" alt="Byton details, GM chargers, Opel electric, what readers want in fast charging: Today's Car News" /> </a>
</div>
<div class="news-item">
<a class="category" href="/news/electric-cars">
Electric Cars </a>
<span class="date">an hour ago</span>
<a class="title" href="/news/1123289_gm-plans-its-own-nationwide-charging-network-with-bechtel">
GM plans its own nationwide charging network with... </a>
<a class="image-link" href="/news/1123289_gm-plans-its-own-nationwide-charging-network-with-bechtel" title="GM plans its own nationwide charging network with Bechtel">
<img class="fitfill" src="https://images.hgmsites.net/sml/2019-chevrolet-bolt-ev-at-public-charging-station_100694027_s.jpg" alt="GM plans its own nationwide charging network with Bechtel" /> </a>
</div>
<div class="news-item">
<a class="category" href="/news/electric-cars">
Electric Cars </a>
<span class="date">2 hours ago</span>
<a class="title" href="/news/1123273_what-matters-most-when-fast-charging-on-a-road-trip-take-our-twitter-poll">
What matters most when fast-charging on a road... </a>
<a class="image-link" href="/news/1123273_what-matters-most-when-fast-charging-on-a-road-trip-take-our-twitter-poll" title="What matters most when fast-charging on a road trip? Take our Twitter poll">
<img class="fitfill" src="https://images.hgmsites.net/sml/2019-audi-e-tron_100701701_s.jpg" alt="What matters most when fast-charging on a road trip? Take our Twitter poll" /> </a>
</div>
</div>
<div id="submenu-topics">
<ul>
<li>
<a class="more-news-title" href="/news/1123270_corsa-e-electric-hatchback-is-part-of-opels-first-move-independent-of-gm">
Corsa-e electric hatchback is part of Opel's... </a>
</li>
<li>
<a class="more-news-title" href="/news/1123276_byton-readies-for-china-production-of-45k-us-bound-electric-suv">
Byton readies for China production of $45K... </a>
</li>
<li>
<a class="more-news-title" href="/news/1123279_fiat-chrysler-submits-offer-for-renault-merger-could-jump-start-electric-car-development">
Fiat Chrysler submits offer for Renault merger... </a>
</li>
<li>
<a class="more-news-title" href="/news/1123264_bay-area-residents-can-get-4000-credit-on-used-plug-ins">
Bay Area residents can get $4,000 credit on used... </a>
</li>
</ul>
</div>
</div>
<div class="moreLink">
<a title="More News" href="/news">More News &#187;</a>
</div>
</div>
</div>
<div class="topnav-link" id="first-drives">
<div class="vLine"></div>
<a href="/news/first-drives" class="navlink"><span class="navTxt">First Drives</span></a>
<div id="submenu-ace" class="submenu-dd">
<h3>First Drives</h3>
<div class="moreLink">
<a title="Read more" href="/news/first-drives">More &#187;</a>
</div>
<div class="news-item">
<a class="title" href="/news/1123097_first-drive-review-2020-mercedes-benz-eqc-electric-crossover-charges-ahead-luxury-first">
First drive review: 2020 Mercedes-Benz EQC... </a>
<span class="date">May 15, 2019</span>
<a class="image-link" href="/news/1123097_first-drive-review-2020-mercedes-benz-eqc-electric-crossover-charges-ahead-luxury-first" title="First drive review: 2020 Mercedes-Benz EQC electric crossover charges ahead, luxury first">
<img class="fitfill" src="https://images.hgmsites.net/sml/2020-mercedes-benz-eqc_100701156_s.jpg" alt="First drive review: 2020 Mercedes-Benz EQC electric crossover charges ahead, luxury first" /> </a>
</div>
<div class="news-item">
<a class="title" href="/news/1122510_2020-kia-soul-ev-first-drive-243-electric-miles-in-the-box">
2020 Kia Soul EV first drive review: 243 electric... </a>
<span class="date">April 9, 2019</span>
<a class="image-link" href="/news/1122510_2020-kia-soul-ev-first-drive-243-electric-miles-in-the-box" title="2020 Kia Soul EV first drive review: 243 electric miles in the box">
<img class="fitfill" src="https://images.hgmsites.net/sml/2020-kia-soul-ev-first-drive--south-korea--april-2019_100697162_s.jpg" alt="2020 Kia Soul EV first drive review: 243 electric miles in the box" /> </a>
</div>
<div class="news-item last">
<a class="title" href="/news/1121294_2019-kia-niro-ev-first-drive-of-239-mile-electric-crossover">
2019 Kia Niro EV: first drive of 239-mile... </a>
<span class="date">February 4, 2019</span>
<a class="image-link" href="/news/1121294_2019-kia-niro-ev-first-drive-of-239-mile-electric-crossover" title="2019 Kia Niro EV: first drive of 239-mile electric crossover">
<img class="fitfill" src="https://images.hgmsites.net/sml/2019-kia-niro-ev-first-drive--santa-cruz-ca--february-2019_100690307_s.jpg" alt="2019 Kia Niro EV: first drive of 239-mile electric crossover" /> </a>
</div>
</div>
</div>
<div class="topnav-link">
<div class="vLine"></div>
<a href="/news/buying-guides" class="navlink"><span class="navTxt">Guides</span></a>
<div id="submenu-guides" class="submenu-dd">
<div class="submenu-outer">
<h3><a href="/news/buying-guides">Green Car Guides</a></h3>
<div class="moreLink">
<a title="More Green Car Guides" href="/news/buying-guides">More &#187;</a>
</div>
<div id="submenu-guide-item">
<div class="news-item ">
<a class="category" href="/news/buying-guides">
Buying Guides </a>
<span class="date">April 19, 2019</span>
<a class="title" href="/news/1122699_2019-nissan-leaf-plus-vs-2019-chevrolet-bolt-ev-which-electric-car-is-best">
2019 Nissan Leaf Plus vs. 2019 Chevrolet Bolt EV... </a>
<a class="image-link" href="/news/1122699_2019-nissan-leaf-plus-vs-2019-chevrolet-bolt-ev-which-electric-car-is-best" title="2019 Nissan Leaf Plus vs. 2019 Chevrolet Bolt EV: Which electric car is best?">
<img class="fitfill" src="https://images.hgmsites.net/sml/chevy-bolt-ev-vs-nissan-leaf-plus_100699453_s.jpg" alt="2019 Nissan Leaf Plus vs. 2019 Chevrolet Bolt EV: Which electric car is best?" /> </a>
</div>
<div class="news-item ">
<a class="category" href="/news/buying-guides">
Buying Guides </a>
<span class="date">April 10, 2019</span>
<a class="title" href="/news/1122538_2019-hyundai-kona-electric-costs-500-more-than-it-did-last-month">
2019 Hyundai Kona Electric costs $500 more than... </a>
<a class="image-link" href="/news/1122538_2019-hyundai-kona-electric-costs-500-more-than-it-did-last-month" title="2019 Hyundai Kona Electric costs $500 more than it did last month">
<img class="fitfill" src="https://images.hgmsites.net/sml/2019-hyundai-kona-electric_100694737_s.jpg" alt="2019 Hyundai Kona Electric costs $500 more than it did last month" /> </a>
</div>
<div class="news-item last">
<a class="category" href="/news/buying-guides">
Buying Guides </a>
<span class="date">March 18, 2019</span>
<a class="title" href="/news/1121860_2020-tesla-model-y-latest-price-range-specs-for-new-crossover-suv">
2020 Tesla Model Y: Latest price, range, specs... </a>
<a class="image-link" href="/news/1121860_2020-tesla-model-y-latest-price-range-specs-for-new-crossover-suv" title="2020 Tesla Model Y: Latest price, range, specs for new crossover SUV">
<img class="fitfill" src="https://images.hgmsites.net/sml/tesla-model-y_100695316_s.jpg" alt="2020 Tesla Model Y: Latest price, range, specs for new crossover SUV" /> </a>
</div>
</div>
</div>
</div>
</div>
<div class="topnav-link" id="ace">
<div class="vLine"></div>
<a href="/news/electric-cars" class="navlink"><span class="navTxt">Electric</span></a>
<div id="submenu-ace" class="submenu-dd">
<h3>All Cars Electric</h3>
<div class="moreLink">
<a title="Read more" href="/news/electric-cars">More &#187;</a>
</div>
<div class="news-item">
<a class="title" href="/news/1123289_gm-plans-its-own-nationwide-charging-network-with-bechtel">
GM plans its own nationwide charging network with... </a>
<span class="date">an hour ago</span>
<a class="image-link" href="/news/1123289_gm-plans-its-own-nationwide-charging-network-with-bechtel" title="GM plans its own nationwide charging network with Bechtel">
<img class="fitfill" src="https://images.hgmsites.net/sml/2019-chevrolet-bolt-ev-at-public-charging-station_100694027_s.jpg" alt="GM plans its own nationwide charging network with Bechtel" /> </a>
</div>
<div class="news-item">
<a class="title" href="/news/1123273_what-matters-most-when-fast-charging-on-a-road-trip-take-our-twitter-poll">
What matters most when fast-charging on a road... </a>
<span class="date">2 hours ago</span>
<a class="image-link" href="/news/1123273_what-matters-most-when-fast-charging-on-a-road-trip-take-our-twitter-poll" title="What matters most when fast-charging on a road trip? Take our Twitter poll">
<img class="fitfill" src="https://images.hgmsites.net/sml/2019-audi-e-tron_100701701_s.jpg" alt="What matters most when fast-charging on a road trip? Take our Twitter poll" /> </a>
</div>
<div class="news-item last">
<a class="title" href="/news/1123270_corsa-e-electric-hatchback-is-part-of-opels-first-move-independent-of-gm">
Corsa-e electric hatchback is part of Opel's... </a>
<span class="date">3 hours ago</span>
<a class="image-link" href="/news/1123270_corsa-e-electric-hatchback-is-part-of-opels-first-move-independent-of-gm" title="Corsa-e electric hatchback is part of Opel's first move independent of GM">
<img class="fitfill" src="https://images.hgmsites.net/sml/2020-opel-corsa-e_100702160_s.jpg" alt="Corsa-e electric hatchback is part of Opel's first move independent of GM" /> </a>
</div>
</div>
</div>
<div class="topnav-link">
<div class="vLine"></div>
<a href="/new-cars" class="navlink"><span class="navTxt">Car Types</span></a>
<div id="submenu-car-types" class="submenu-dd">
<div>
<h3>News by Car Type</h3>
<div class="moreLink">
<a title="Read more" href="/new-cars">See all new cars &#187;</a>
</div>
<div id="submenu-types">
<ul>
<li>
<a class="cat" href="/news/hybrid-cars">HYBRID</a>
<a class="thumb" href="/news/hybrid-cars">
<img src="/images/categories/category-hybrid-cars.jpg" alt="Hybrid" />
</a>
</li>
<li>
<a class="cat" href="/news/electric-cars">ELECTRIC</a>
<a class="thumb" href="/news/electric-cars">
<img src="/images/categories/category-electric-cars.jpg" alt="Electric" />
</a>
</li>
<li>
<a class="cat" href="/news/diesel">DIESEL</a>
<a class="thumb" href="/news/diesel">
<img src="/images/categories/category-diesel.jpg" alt="Diesel" />
</a>
</li>
<li>
<a class="cat" href="/news/fuel-cell">FUEL CELL</a>
<a class="thumb" href="/news/fuel-cell">
<img src="/images/categories/category-fuel-cell.jpg" alt="Fuel Cell" />
</a>
</li>
</ul>
</div>
<div id="submenu-car-links">
<span>Popular Green Cars</span>
<ul>
<li>
<a class="thumb" href="/overview/chevrolet_volt_2019">
<img class="fitfill" src="https://images.hgmsites.net/tmb/2019-chevrolet-volt_100665702_t.gif" alt="2019 Chevrolet Volt" /> </a>
<a class="car-link" href="/overview/chevrolet_volt_2019">2019 Chevrolet Volt</a>
</li>
<li>
<a class="thumb" href="/overview/nissan_leaf_2019">
<img class="fitfill" src="https://images.hgmsites.net/tmb/2019-nissan-leaf_100685576_t.gif" alt="2019 Nissan Leaf" /> </a>
<a class="car-link" href="/overview/nissan_leaf_2019">2019 Nissan Leaf</a>
</li>
<li>
<a class="thumb" href="/overview/tesla_roadster_2012">
<img src="https://static.hgmsites.net/images/cache/2011-tesla-roadster_100337784_77x54.jpg" alt="2012 Tesla Roadster" width="77" height="54" /> </a>
<a class="car-link" href="/overview/tesla_roadster_2012">2012 Tesla Roadster</a>
</li>
<li>
<a class="thumb" href="/overview/toyota_prius_2019">
<img class="fitfill" src="https://images.hgmsites.net/tmb/2019-toyota-prius_100690149_t.gif" alt="2019 Toyota Prius" /> </a>
<a class="car-link" href="/overview/toyota_prius_2019">2019 Toyota Prius</a>
</li>
 </ul>
</div>
</div>
</div>
</div>
<div class="topnav-link" id="video">
<div class="vLine"></div>
<a href="/videos" class="navlink"><span class="navTxtSingle">Video</span></a>
</div>
<div class="topnav-link">
<div class="vLine"></div>
<span class="navlink lastNavLink"><span class="navTxt dropdown">Follow</span></span>
<div id="submenu-more" class="submenu-dd">
<div class="submenu-outer">
<ul class="top-social">
<li><a class="topnav-facebook" href="https://www.facebook.com/GreenCarReports" title="Like us on Facebook" target="_blank"><span></span>Like Us on Facebook</a></li>
<li><a class="topnav-twitter" href="https://www.twitter.com/GreenCarReports" title="Follow us on Twitter" target="_blank"><span></span>Follow us on Twitter</a></li>
<li><a class="topnav-youtube" href="https://www.youtube.com/user/greencarreports" title="Our YouTube channel" target="_blank"><span></span>Our YouTube Channel</a></li>
</ul>
</div>
</div>
</div>
</div>
</div>
<script>
    $('.topnav-link').groupHover();
    $("#submenu-news-item  a.image-link img.fitfill,\n\
         a.featured-image img.fitfill,\n\
        #submenu-guide-item a.image-link img.fitfill,\n\
        #submenu-mileage a.image-link img.fitfill,\n\
        #submenu-car-links a.thumb img.fitfill,\n\
        #submenu-ace a.image-link img.fitfill").imgFitFill({mode:'fill'});
    if ($('#nav-custom-ad').length > 0) {
        $('#ace').hover(
            function() {
                hgm.trackEvent("GCR-Nav-AD", "Display", 'Smart', 0);
            },
            function() {
            }
        );
    }
</script>
<div class="search" id="masterSearch">
<div class="vLine"></div>
<div class="global-google-search" id="google-search-form-0" style="width: 210px;">
<script>
        (function() {
            var cx = '001937828977938864696:tstejjfkb_g';
            var gcse = document.createElement('script');
            gcse.type = 'text/javascript';
            gcse.async = true;
            gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
            var s = document.getElementsByTagName('script')[0];
            s.parentNode.insertBefore(gcse, s);
        })();
    </script>
<gcse:searchbox-only resultsUrl="/searchresults" data-placeholder="test"></gcse:searchbox-only>
</div>
<script>
    $('#masterSearch').on('focus', '.gsc-input', function () {
        $("#masterSearch").addClass("hover");
    });
    $('#masterSearch').on('blur', '.gsc-input', function () {
        $("#masterSearch").removeClass("hover");
    });
    window.onload = function() {
        $('#gsc-iw-id1 input').attr('placeholder', 'search');
        $('#gsc-iw-id1 input').addClass('gcs_visible');
    }
</script>
</div> 
</div> 
<div id="masterhead-adblock" style="overflow: visible">

<div id="rising-star-banner" class="ad ad-r-t" style="max-width: 970px; max-height: auto">
<script>
                $(function () {
                    googletag.cmd.push(function() {
                        googletag.display('rising-star-banner');                        for (var i = gptadslots.length; i--;) {
                             var curSlot = gptadslots[i];
                             if ( curSlot.getSlotElementId() === 'rising-star-banner') {
                                googletag.pubads().refresh([curSlot]);
                             }
                        }                    });
                });
            </script> </div>
</div>
</div> 
<div class="clear"></div>
<div id="sub-header" class="centerColumn">
<div id="bc_container">
<div id="breadcrumbs">
<div id="bc_title">
<a id="a_bc_home" href="/"><span>Home</span></a>
</div>
<div class="bc_separator"></div>
<div id="bc_child_0">
<a id="a_bc_0" class="bc_link" href="/news"><span>News</span></a>
</div>
<div class="bc_separator"></div> <div id="bc_child_1">
<a id="a_bc_1" class="bc_link" href="/news/today-in-car-news"><span>Today in Car News</span></a>
</div>
<div class="bc_separator"></div> <div id="a_bc_2" class="bc_link">
<span>Byton details, GM chargers, Opel electric, what readers want in fast charging: Today's Car News</span> </div>
<div style="clear:both"></div><br class="clear" />
</div>
</div>
<script type="text/javascript">
    var bc_time;

    function hgm_hideBcDropDowns(myid) {
        $('.bc_link_hover').removeClass('bc_link_hover');
        $('.bc_separator_hover').removeClass('bc_separator_hover');
        $(".bc_dropdown").hide();
    }

    $(".bc_link_dd").hover(function(){
        clearTimeout(bc_time);
        var regexp = new RegExp("a_(.*)", "gi");
        var myid = regexp.exec(this.id)[1];
        $("#div_"+myid).css("left", $(this).position().left);
        $("div.bc_dropdown").each(function() {
           if($(this).attr("id") != myid) $(this).hide(1);
        });
        $("#div_"+myid).show();
        $('.bc_separator_hover').removeClass('bc_separator_hover');
        $('.bc_link_hover').removeClass('bc_link_hover');
        $(this).addClass('bc_link_hover');
        $(this).prev().addClass('bc_separator_hover');
    }, function() {
        var regexp = new RegExp("a_(.*)", "gi");
        var myid = regexp.exec(this.id)[1];
        clearTimeout(bc_time);
        bc_time = setTimeout(hgm_hideBcDropDowns, 500);
    });
    $("div.bc_dropdown").hover(function() {
        clearTimeout(bc_time);
    },function() {
        bc_time = setTimeout(hgm_hideBcDropDowns, 500);
    });
</script>
</div>
<script>
    dataLayer.push({'category_tags': 'news,today-in-car-news',
                    'tags': 'news,today-in-car-news'});
</script>
<script>
        $(function() {
            hgm.pingView(1123290, null);
        });
    </script>
<div id="container">
<div class="social-v">
<ul>
<li class="social-facebook-button">
<a class="facebook" title="Share this article on Facebook" href="javascript:void(0);" data-title="News%3A%20Byton%20details%2C%20GM%20chargers%2C%20Opel%20electric%2C%20what%20readers%20want%20in%20fast%20charging%3A%20Today%27s%20Car%20News" onclick="hgm.trackEvent('Social Buttons Vertical', 'Facebook Button Clicked');popupCenter('https://www.facebook.com/sharer.php?t=News%3A%20Byton%20details%2C%20GM%20chargers%2C%20Opel%20electric%2C%20what%20readers%20want%20in%20fast%20charging%3A%20Today%27s%20Car%20News&amp;u=https://www.greencarreports.com/news/1123290_byton-details-gm-chargers-opel-electric-what-readers-want-in-fast-charging-todays-car-news?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed%3A+TheCarConnection-CarReviews+%28The+Car+Connection+-+Car+Reviews%29', 700, 400)">
</a>
</li>
<li class="social-twitter-button">
<a title="Share this article on Twitter" href="javascript:void(0);" data-title="News%3A%20Byton%20details%2C%20GM%20chargers%2C%20Opel%20electric%2C%20what%20readers%20want%20in%20fast%20charging%3A%20Today%27s%20Car%20News" onclick="hgm.trackEvent('Social Buttons Vertical', 'Twitter Button Clicked');popupCenter('https://twitter.com/home?status=News%3A%20Byton%20details%2C%20GM%20chargers%2C%20Opel%20electric%2C%20what%20readers%20want%20in%20fast%20charging%3A%20Today%27s%20Car%20News https://www.greencarreports.com/news/1123290_byton-details-gm-chargers-opel-electric-what-readers-want-in-fast-charging-todays-car-news?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed%3A+TheCarConnection-CarReviews+%28The+Car+Connection+-+Car+Reviews%29', 700, 300)">
</a>
</li>
<li class="linkedIn-share-button">
<a class="linkedin" title="Share this article on LinkedIn" href="javascript:void(0);" data-title="News%3A%20Byton%20details%2C%20GM%20chargers%2C%20Opel%20electric%2C%20what%20readers%20want%20in%20fast%20charging%3A%20Today%27s%20Car%20News" onclick="hgm.trackEvent('Social Buttons Vertical', 'LinkedIn Button Clicked');popupCenter('https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.greencarreports.com/news/1123290_byton-details-gm-chargers-opel-electric-what-readers-want-in-fast-charging-todays-car-news?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed%3A+TheCarConnection-CarReviews+%28The+Car+Connection+-+Car+Reviews%29&amp;title=News%3A%20Byton%20details%2C%20GM%20chargers%2C%20Opel%20electric%2C%20what%20readers%20want%20in%20fast%20charging%3A%20Today%27s%20Car%20News', 700, 420)">
</a>
</li>
<li class="bookmark-button">
<a title="Bookmark this page" href="#" rel="sidebar">
</a>
</li>
<li class="email-this-button">
<a class="email-this m-email" title="Email this article" data-subject="News%3A%20Byton%20details%2C%20GM%20chargers%2C%20Opel%20electric%2C%20what%20readers%20want%20in%20fast%20charging%3A%20Today%27s%20Car%20News" href="#"></a>
</li>
</ul>
<br clear="all" />
</div> 
<div id="social-email-div" style="display:none">
<div class="title"><h2>Email This Page</h2></div>
<div id="social-error-messages"></div>
<form id="social-email-form">
<div><label for="social-fromname">Your Name</label><input type="text" name="fromName" id="social-fromname" class="social-form-field"></div>
<input type="text" name="email" id="social-fake-email" class="social-form-field">
<div><label for="social-fromemail">Your Email</label><input type="text" name="fromEmail" id="social-fromemail" class="social-form-field"></div>
<div><label for="social-to">To <span>(separate emails with commas)</span></label><input type="text" name="to" id="social-to" class="social-form-field"></div>
<div><label for="social-message">Message <span>(optional)</span></label><textarea name="message" id="social-message" class="social-form-field"></textarea></div>
<input type="hidden" name="token" value="Yl/U4cPQqHzCArXzvRn4GNAI1GnfxlKpgpFaUka5CP0=">
<div id="social-submit"><div class="stdButton">Send</div></div>
</form>
<div id="social-success-message">
<div>Your email was sent successfully.</div>
<div><span class="social-close">Close</span></div>
</div>
<br>
</div> <div class="centerColumn">
<div class="headtohead-banner"></div>
<h1>Byton details, GM chargers, Opel electric, what readers want in fast charging: Today's Car News</h1>
<div id="leftcol">
<div class="article_body">
<div class="article_content">
<div class="author-line">
<div id="byline" class="byline">
<div class="reviewer">
<a href="/writer/10064169_eric-c-evarts" class=" author-image" alt="Eric C. Evarts" style="background: url(https://images.hgmsites.net/tny/avatar-image-for-eevarts_100649159_0.jpg)"></a>
<span class="ex-author ">
<a rel="author" href="/writer/10064169_eric-c-evarts" title="View Eric C. Evarts's Profile" target="_blank"><span>Eric C. Evarts</span></a></span>
</div>
</div>
<div class="by-line-comments-views-date">
<a href="https://www.greencarreports.com/news/1123290_byton-details-gm-chargers-opel-electric-what-readers-want-in-fast-charging-todays-car-news#disqus_thread" class="comment comment-disqus"></a>
<span class="date">May 28, 2019</span>
</div>
<script>
    $('#authorSocialFollow').hoverIntent(
        function(event) {
            $('#authorSocialFollowExpanded').slideDown('fast');
            event.stopPropagation();
            $('#authorSocialFollowExpanded').mouseenter(function() {
                $(this).show();
            });
            $('#authorSocialFollowExpanded').mouseleave(function() {
                $(this).hide();
            });
        },
        function() {
            $('#authorSocialFollowExpanded').hide();
        }
    );
</script> <br class="clear" />
</div>
<div class="image_wrapper first_wrapper"><img name="tccimg_100685161_m" float="none" src="https://images.hgmsites.net/med/byton-m-byte-and-k-byte_100685161_m.jpg" title="Byton M-Byte and K-Byte" alt="Byton M-Byte and K-Byte" width="640" height="360" data-width="1024" data-height="576" data-url="https://images.hgmsites.net/lrg/byton-m-byte-and-k-byte_100685161_l.jpg" class="first_image"><p>Byton M-Byte and K-Byte</p></div><p>GM is planning an electric-car charging network. Chinese self-driving electric-car startup reveals more details about its upcoming models. Opel announces its first independent electric car. And our latest Twitter poll asks readers what's most important to them in fast-charging their electric cars. All this and more on <em>Green Car Reports</em>.</p>
<p>General Motors confirmed a report that it plans to team up with construction giant Bechtel <a href="https://www.greencarreports.com/news/1123289_gm-plans-its-own-nationwide-charging-network-with-bechtel">to potentially build thousands of fast chargers</a> around the U.S. The company suggests they may primarily be in cities, though it said planning is still in early stages.</p>
<p>Byton announced more details about its what underpins its upcoming M-Byte SUV, and it's keeping to message about its <a href="https://www.greencarreports.com/news/1123276_byton-readies-for-china-production-of-45k-us-bound-electric-suv">$45,000 starting price</a>.</p>
<p>In its first act since General Motors sold the brand, Opel has developed a new <a href="https://www.greencarreports.com/news/1123270_corsa-e-electric-hatchback-is-part-of-opels-first-move-independent-of-gm">electric version of its small Corsa hatchback</a>, the Corsa-e. Once again, it's planned only for Europe.</p>
<p>Following Audi's latest efforts to focus on charging speed consistency over maximum range, our latest Twitter poll asks readers <a href="https://www.greencarreports.com/news/1123273_what-matters-most-when-fast-charging-on-a-road-trip-take-our-twitter-poll">what they think is most important in fast charging</a>.</p>
<p>More <a href="https://www.motorauthority.com/news/1108285_2020-porsche-taycan-spy-shots-and-video">spy photos—along with a video</a>—have emerged of the upcoming electric Porsche Taycan out testing, this time from forum users.</p>
<p>Finally, a new study by <em>Consumer Reports</em> found that more than 16 percent of ride-sharing cars in New York City and Seattle <a href="https://www.thecarconnection.com/news/1123283_many-ride-share-cars-have-open-safety-recalls">have outstanding recall work</a> that hasn't been done. </p>
<p>_______________________________________</p>
<p><em>Follow Green Car Reports on </em><a href="http://www.facebook.com/GreenCarReports"><span><em>Facebook</em></span></a><em> and </em><a href="http://twitter.com/greencarreports"><span><em>Twitter</em></span></a></p></div>
</div>
<div id="postNav">
<a href="/news/" class="link prev"><div><i class="icon-arrow-left"></i><span class="arrow-left">Prev Post</span></div></a>
<a href="/news/1123290_byton-details-gm-chargers-opel-electric-what-readers-want-in-fast-charging-todays-car-news" class="link next"><div><i class="icon-arrow-right"></i><span class="arrow-right">Next Post</span></div></a>
</div>
<div class="tags-and-cats">
<div class="article-tags">
<span>Tags:</span>
<div class="links">
<a href="/news/today-in-car-news" rel="tag">Today in Car News</a>
</div>
<div class="clear"></div>
</div>
<div class="article-cats">
<span>Posted in:</span>
<div class="links">
<a href="/news/news" rel="tag">News</a>
</div>
<div class="clear"></div>
</div>
</div> 

<div class="recommended-galleries group">
<h3><a href="/pictures">Recommended Galleries</a></h3>

<div class="recommended-gallery">
<a class="recommended-link" href="/news/1123229_electric-car-startup-pich-sketches-out-future-models-including-suv">
<img class="fitfill" src="https://images.hgmsites.net/sml/piech-mark-zero-concept_100694002_s.jpg" alt="Electric-car startup Piëch sketches out future models, including SUV" /> </a>
<a href="/news/1123229_electric-car-startup-pich-sketches-out-future-models-including-suv">
<span>Electric-car startup Piëch sketches out future models, including SUV</span>
</a>
</div>


<div class="recommended-gallery">
<a class="recommended-link" href="/news/1123270_corsa-e-electric-hatchback-is-part-of-opels-first-move-independent-of-gm">
<img class="fitfill" src="https://images.hgmsites.net/sml/2020-opel-corsa-e_100702160_s.jpg" alt="Corsa-e electric hatchback is part of Opel's first move independent of GM" /> </a>
<a href="/news/1123270_corsa-e-electric-hatchback-is-part-of-opels-first-move-independent-of-gm">
<span>Corsa-e electric hatchback is part of Opel's first move independent of GM</span>
</a>
</div>


<div class="recommended-gallery">
<a class="recommended-link" href="/news/1123243_2019-audi-e-tron-road-trip-review-wait-range-ratings-arent-everything">
<img class="fitfill" src="https://images.hgmsites.net/sml/2019-audi-e-tron_100701707_s.jpg" alt="2019 Audi E-tron road-trip review: Wait, range ratings aren’t everything?" /> </a>
<a href="/news/1123243_2019-audi-e-tron-road-trip-review-wait-range-ratings-arent-everything">
<span>2019 Audi E-tron road-trip review: Wait, range ratings aren’t everything?</span>
</a>
</div>


<div class="recommended-gallery">
<a class="recommended-link" href="/news/1123182_2020-karma-revero-gt-breaks-coverwith-smaller-moustache">
<img class="fitfill" src="https://images.hgmsites.net/sml/2020-karma-revero-gt_100701573_s.jpg" alt="2020 Karma Revero GT breaks cover–with smaller mustache" /> </a>
<a href="/news/1123182_2020-karma-revero-gt-breaks-coverwith-smaller-moustache">
<span>2020 Karma Revero GT breaks cover–with smaller mustache</span>
</a>
</div>

</div>

<script>
    $('.recommended-galleries .recommended-link img.fitfill').imgFitFill({mode:'fill'});
    $('.recommended-gallery').click(function(){hgm.trackEvent('Recommended Gallery', 'clicked');});
</script> <div class="bottom-center-adverts">

<div id="ad-5" class="ad ad-t-r" style="max-width: 300px; max-height: auto">
<script>
                $(function () {
                    googletag.cmd.push(function() {
                        googletag.display('ad-5');                        for (var i = gptadslots.length; i--;) {
                             var curSlot = gptadslots[i];
                             if ( curSlot.getSlotElementId() === 'ad-5') {
                                googletag.pubads().refresh([curSlot]);
                             }
                        }                    });
                });
            </script> </div>
</div>
<div class="block_border">&nbsp;</div>
<div id="contribute-followus">
<div class="contribute">
<div class="label">Contribute</div>
<a class="sendUsTip" href="/contactus">Send us a tip</a>
<a class="comments" href="#comments">Comment</a>
<a class="contactEditor" href="/contactus">Contact the editor</a>
</div>
<div class="followus">
<div class="label">Follow Us</div>
<div class="facebook-twitter-follow">
<div class="fb-like-btn">
<div class="fb-like" data-href="https://www.facebook.com/GreenCarReports" data-send="false" data-layout="button_count" data-width="91" data-show-faces="false" data-colorscheme="light"></div></div>
<a href="https://twitter.com/GreenCarReports" class="twitter-follow-button" data-show-count="false" data-size="medium"></a> </div>

<div class="module static-email-subscribe inline">
<span class="email-label"> Get daily e-mail updates </span>
<form action="/blocks/mail-chimp-email-subscription/subscribeEmail" class="subscription-form" method="post">
<input type="text" name="email" placeholder="Enter email" class="input" />
<div class="stdButton mailchimp-signup">GO</div> <div class="small">I agree to receive emails from the site. I can withdraw my consent at any time by unsubscribing.</div>
</form>
<p class="thanks-msg"></p>
<p class="msg"></p>
<span class="error-msg"></span>
</div>

</div>
<br clear="all" />
</div>
<div id="comments"> </div>
<div id="disqus_thread"> </div>
<script type="text/javascript">
    $(function () {
        $('#comments').waypoint(
            // handler
            function(direction) {
                $.getScript('/blocks/threaded-comments/disqusinit?id=1123290&type=blog');
            },
            // options
            {
                offset: '100%',
                triggerOnce: true
            }
        );
    });
</script>
</div>


<div id="rightcol">
<div class="w300">


<div id="ad-2" class="ad ad-t-r" style="max-width: 300px; max-height: auto">
<script>
                $(function () {
                    googletag.cmd.push(function() {
                        googletag.display('ad-2');                        for (var i = gptadslots.length; i--;) {
                             var curSlot = gptadslots[i];
                             if ( curSlot.getSlotElementId() === 'ad-2') {
                                googletag.pubads().refresh([curSlot]);
                             }
                        }                    });
                });
            </script> </div>

<div id="ad-4" class="ad ad-t-r" style="max-width: 300px; max-height: auto">
 <script>
                $(function () {
                    googletag.cmd.push(function() {
                        googletag.display('ad-4');                        for (var i = gptadslots.length; i--;) {
                             var curSlot = gptadslots[i];
                             if ( curSlot.getSlotElementId() === 'ad-4') {
                                googletag.pubads().refresh([curSlot]);
                             }
                        }                    });
                });
            </script> </div>

<div class="module static-email-subscribe ">
<div class="block-inner">
<span class="email-label">News In Your Inbox</span>
<div class="email-logo">
<span class="e-green">Green</span><span class="e-car">Car</span><span class="e-reports">Reports</span>
</div>
<form action="/blocks/mail-chimp-email-subscription/subscribeEmail" class="subscription-form" method="post">
<input type="text" name="email" placeholder="Enter email" class="input" />
<div class="stdButton mailchimp-signup">Sign Up</div> <span class="small">I agree to receive emails from the site. I can withdraw my consent at any time by unsubscribing.</span>
</form>
<span class="error-msg"></span>
<p class="thanks-msg"></p>
<p class="msg"></p>
</div>
</div>

<div class="small module" id="related-news-table">
<div class="block-header">
<h3 class="block-title">Related Articles</h3>
</div>
<ul class="block-inner articles_listing">
<li>
<a class="image-link" href="/news/1123289_gm-plans-its-own-nationwide-charging-network-with-bechtel">
<img title="GM plans its own nationwide charging network with Bechtel" class="fitfill" src="https://images.hgmsites.net/sml/2019-chevrolet-bolt-ev-at-public-charging-station_100694027_s.jpg" alt="2019 Chevrolet Bolt EV at public charging station" /> </a>
<a class="title-link" href="/news/1123289_gm-plans-its-own-nationwide-charging-network-with-bechtel">GM plans its own nationwide charging network with Bechtel</a>
</li>
<li>
<a class="image-link" href="/news/1123273_what-matters-most-when-fast-charging-on-a-road-trip-take-our-twitter-poll">
<img title="What matters most when fast-charging on a road trip? Take our Twitter poll" class="fitfill" src="https://images.hgmsites.net/sml/2019-audi-e-tron_100701701_s.jpg" alt="2019 Audi E-tron  -  first drive report  -  Calirornia, May 2019" /> </a>
<a class="title-link" href="/news/1123273_what-matters-most-when-fast-charging-on-a-road-trip-take-our-twitter-poll">What matters most when fast-charging on a road trip? Take our Twitter poll</a>
</li>
<li>
<a class="image-link" href="/news/1123270_corsa-e-electric-hatchback-is-part-of-opels-first-move-independent-of-gm">
<img title="Corsa-e electric hatchback is part of Opel's first move independent of GM" class="fitfill" src="https://images.hgmsites.net/sml/2020-opel-corsa-e_100702160_s.jpg" alt="2020 Opel Corsa-e" /> </a>
<a class="title-link" href="/news/1123270_corsa-e-electric-hatchback-is-part-of-opels-first-move-independent-of-gm">Corsa-e electric hatchback is part of Opel's first move independent of GM</a>
</li>
<li>
<a class="image-link" href="/news/1123279_fiat-chrysler-submits-offer-for-renault-merger-could-jump-start-electric-car-development">
<img title="Fiat Chrysler submits offer for Renault merger, could jump-start electric car development" class="fitfill" src="https://images.hgmsites.net/sml/renault-logo-and-fiat-chrysler-automobiles-logo_100702232_s.jpg" alt="Renault logo and Fiat Chrysler Automobiles logo" /> </a>
<a class="title-link" href="/news/1123279_fiat-chrysler-submits-offer-for-renault-merger-could-jump-start-electric-car-development">Fiat Chrysler submits offer for Renault merger, could jump-start electric car development</a>
</li>
<li>
<a class="image-link" href="/news/1123264_bay-area-residents-can-get-4000-credit-on-used-plug-ins">
<img title="Bay Area residents can get $4,000 credit on used plug-ins" class="fitfill" src="https://images.hgmsites.net/sml/used-2016-chevy-volt-sold-through-peninsula-family-service-program-credit-peninsula-clean-energy_100702170_s.jpg" alt="Used 2016 Chevy Volt sold through Peninsula Family Service program (CREDIT: Peninsula Clean Energy)" /> </a>
<a class="title-link" href="/news/1123264_bay-area-residents-can-get-4000-credit-on-used-plug-ins">Bay Area residents can get $4,000 credit on used plug-ins</a>
</li>
<li class="follow-us">
<h3>Follow Us</h3>
<div>
<div class="facebook">
<div class="fb-like-btn">
<div class="fb-like" data-href="https://www.facebook.com/GreenCarReports" data-send="false" data-layout="button_count" data-width="91" data-show-faces="false" data-colorscheme="light"></div></div>
On Facebook
</div>
<div class="twitter-google-plus">
<div class="twitter">
<a href="https://twitter.com/GreenCarReports" class="twitter-follow-button" data-show-count="false" data-size="medium"></a> </div>
</div>
<div class="clear"></div>
</div>
</li>
</ul>
<br class="clear" />
</div>
<script type="text/javascript">
    //<![CDATA[
    $("#related-news-table img.fitfill").imgFitFill({mode:'fill'});
    //]]>
</script>
<div id="mostpopular-blog-thisweek">
<h2>Most Popular <span>This Week</span></h2>
<div class="clear"></div>

<div class="popular-outer">
<div class="popular_1 most-popular">
<div class="image-number">1</div>
<a class="mainLink" href="/news/1123243_2019-audi-e-tron-road-trip-review-wait-range-ratings-arent-everything" title="2019 Audi E-tron road-trip review: Wait, range ratings aren’t everything?">
<img class="fitfill" src="https://images.hgmsites.net/tmb/2019-audi-e-tron_100701707_t.gif" alt="2019 Audi E-tron road-trip review: Wait, range ratings aren’t everything?" /> 2019 Audi E-tron road-trip review: Wait, range ratings aren’t... </a>
<div class="fb-like-btn">
<div class="fb-like" data-href="https://www.greencarreports.com/news/1123243_2019-audi-e-tron-road-trip-review-wait-range-ratings-arent-everything" data-send="false" data-layout="button_count" data-width="91" data-show-faces="false" data-colorscheme="light"></div></div>
<a href="https://www.greencarreports.com/news/1123243_2019-audi-e-tron-road-trip-review-wait-range-ratings-arent-everything#disqus_thread" class="comment comment-disqus"></a>
</div>
<div class="clear">&nbsp;</div>
</div>
<div class="popular-outer">
<div class="popular_2 most-popular">
<div class="image-number">2</div>
<a class="mainLink" href="/news/1123209_2019-tesla-model-s-long-range-vs-2013-model-s-85-how-do-they-compare-in-value" title="2019 Tesla Model S Long Range vs. 2013 Model S 85: How do they compare in value?">
<img class="fitfill" src="https://images.hgmsites.net/tmb/2013-tesla-model-s_100409159_t.gif" alt="2019 Tesla Model S Long Range vs. 2013 Model S 85: How do they compare in value?" /> 2019 Tesla Model S Long Range vs. 2013 Model S 85: How do they... </a>
<div class="fb-like-btn">
<div class="fb-like" data-href="https://www.greencarreports.com/news/1123209_2019-tesla-model-s-long-range-vs-2013-model-s-85-how-do-they-compare-in-value" data-send="false" data-layout="button_count" data-width="91" data-show-faces="false" data-colorscheme="light"></div></div>
<a href="https://www.greencarreports.com/news/1123209_2019-tesla-model-s-long-range-vs-2013-model-s-85-how-do-they-compare-in-value#disqus_thread" class="comment comment-disqus"></a>
</div>
<div class="clear">&nbsp;</div>
</div>
<div class="popular-outer">
<div class="popular_3 most-popular">
<div class="image-number">3</div>
<a class="mainLink" href="/news/1123271_tesla-troubles-model-s-value-e-tron-drive-fresh-air-and-why-norway-the-week-in-reverse" title="Tesla troubles, Model S value, E-tron drive, fresh air, and why Norway? The Week in Reverse">
<img class="fitfill" src="https://images.hgmsites.net/tmb/2013-tesla-model-s-in-july-2017-photo-david-noland_100613425_t.gif" alt="Tesla troubles, Model S value, E-tron drive, fresh air, and why Norway? The Week in Reverse" /> Tesla troubles, Model S value, E-tron drive, fresh air, and why... </a>
<div class="fb-like-btn">
<div class="fb-like" data-href="https://www.greencarreports.com/news/1123271_tesla-troubles-model-s-value-e-tron-drive-fresh-air-and-why-norway-the-week-in-reverse" data-send="false" data-layout="button_count" data-width="91" data-show-faces="false" data-colorscheme="light"></div></div>
<a href="https://www.greencarreports.com/news/1123271_tesla-troubles-model-s-value-e-tron-drive-fresh-air-and-why-norway-the-week-in-reverse#disqus_thread" class="comment comment-disqus"></a>
</div>
<div class="clear">&nbsp;</div>
</div>
<div class="popular-outer">
<div class="popular_4 most-popular">
<div class="image-number">4</div>
<a class="mainLink" href="/news/1123208_how-should-ev-owners-pay-for-road-maintenance-twitter-poll-results" title="" How should EV owners pay for road maintenance?" Twitter poll results">
<img class="fitfill" src="https://images.hgmsites.net/tmb/canadian-reader-ks-new-tesla-model-3_100653806_t.gif" alt="&quot;How should EV owners pay for road maintenance?&quot; Twitter poll results" /> "How should EV owners pay for road maintenance?" Twitter poll... </a>
<div class="fb-like-btn">
<div class="fb-like" data-href="https://www.greencarreports.com/news/1123208_how-should-ev-owners-pay-for-road-maintenance-twitter-poll-results" data-send="false" data-layout="button_count" data-width="91" data-show-faces="false" data-colorscheme="light"></div></div>
<a href="https://www.greencarreports.com/news/1123208_how-should-ev-owners-pay-for-road-maintenance-twitter-poll-results#disqus_thread" class="comment comment-disqus"></a>
</div>
<div class="clear">&nbsp;</div>
</div>
<div class="popular-outer">
<div class="popular_5 most-popular">
<div class="image-number">5</div>
<a class="mainLink" href="/news/1123272_first-all-electric-airline-could-soar-with-converted-old-seaplanes" title="First all-electric airline could soar with converted old seaplanes">
<img class="fitfill" src="https://images.hgmsites.net/tmb/harbour-air-de-havilland-dhc-2-mk-iii-beaver-flying-out-of-vancouver-b-c-credit-harbour-air_100702213_t.gif" alt="First all-electric airline could soar with converted old seaplanes" /> First all-electric airline could soar with converted old... </a>
<div class="fb-like-btn">
<div class="fb-like" data-href="https://www.greencarreports.com/news/1123272_first-all-electric-airline-could-soar-with-converted-old-seaplanes" data-send="false" data-layout="button_count" data-width="91" data-show-faces="false" data-colorscheme="light"></div></div>
<a href="https://www.greencarreports.com/news/1123272_first-all-electric-airline-could-soar-with-converted-old-seaplanes#disqus_thread" class="comment comment-disqus"></a>
</div>
<div class="clear">&nbsp;</div>
</div>
<div class="clear"></div>
<span class="moreLink"><a href="/news">More &#187;</a></span>
</div> <div id="category-list" class="">
<h3>Topics</h3>
<ul>
<li>
<a class="cat" href="/news/gas-mileage">GAS MILEAGE</a>
<a class="thumb" href="/news/gas-mileage"><img class="fitfill" src="/images/categories/category-gas-mileage.jpg" alt="Gas Mileage" /></a>
</li>
<li>
<a class="cat" href="/news/hybrid-cars">HYBRIDS</a>
<a class="thumb" href="/news/hybrid-cars"><img class="fitfill" src="/images/categories/category-hybrid-cars.jpg" alt="Hybrids" /></a>
</li>
<li>
<a class="cat" href="/news/electric-cars">ELECTRIC CARS</a>
<a class="thumb" href="/news/electric-cars"><img class="fitfill" src="/images/categories/category-electric-cars.jpg" alt="Electric Cars" /></a>
</li>
<li>
<a class="cat" href="/news/diesel">DIESEL CARS</a>
<a class="thumb" href="/news/diesel"><img class="fitfill" src="/images/categories/category-diesel.jpg" alt="Diesel Cars" /></a>
</li>
<li>
<a class="cat" href="/news/alternative-fuels">ALT FUELS</a>
<a class="thumb" href="/news/alternative-fuels"><img class="fitfill" src="/images/categories/category-alternative-fuels.jpg" alt="Alt Fuels" /></a>
</li>
<li>
<a class="cat" href="/news/auto-shows">AUTO SHOWS</a>
<a class="thumb" href="/news/auto-shows"><img class="fitfill" src="/images/categories/category-auto-shows.jpg" alt="Auto Shows" /></a>
</li>
</ul>
</div>
<br class="clear" />
<script>
var numSlides =5;
</script>
<div id="gallery-carousal" class="module">
<div id="gallery-carousal-inner">
<h3>Photo Galleries</h3>
<div id="gallery-slide">
<ul>
<li id="slide-1" class="slides">
<div class="photo_gallery">
<a class="image-link" href="/pictures/1123182_2020-karma-revero-gt-breaks-coverwith-smaller-moustache_gallery-1#100701573">
<img class="fitfill" src="https://images.hgmsites.net/sml/2020-karma-revero-gt_100701573_s.jpg" alt="2020 Karma Revero GT breaks cover–with smaller mustache" /> </a>
<a href="/pictures/1123182_2020-karma-revero-gt-breaks-coverwith-smaller-moustache_gallery-1#100701573">
<span>2020 Karma Revero GT breaks cover–with smaller mustache</span>
</a>
</div>

</li>
<li id="slide-2" class="slides">
<div class="photo_gallery">
<a class="image-link" href="/pictures/1123228_rivian-builds-r1t-overland-as-cookout-camping-special_gallery-1#100701596">
<img class="fitfill" src="https://images.hgmsites.net/sml/rivian-r1t-overlanding-concept_100701596_s.jpg" alt="Rivian builds R1T Overland as cookout camping special" /> </a>
<a href="/pictures/1123228_rivian-builds-r1t-overland-as-cookout-camping-special_gallery-1#100701596">
<span>Rivian builds R1T Overland as cookout camping special</span>
</a>
</div>

</li>
<li id="slide-3" class="slides">
<div class="photo_gallery">
<a class="image-link" href="/pictures/1123229_electric-car-startup-pich-sketches-out-future-models-including-suv_gallery-1#100694002">
<img class="fitfill" src="https://images.hgmsites.net/sml/piech-mark-zero-concept_100694002_s.jpg" alt="Electric-car startup Piëch sketches out future models, including SUV" /> </a>
<a href="/pictures/1123229_electric-car-startup-pich-sketches-out-future-models-including-suv_gallery-1#100694002">
<span>Electric-car startup Piëch sketches out future models, including SUV</span>
</a>
</div>

</li>
<li id="slide-4" class="slides">
<div class="photo_gallery">
<a class="image-link" href="/pictures/1123243_2019-audi-e-tron-road-trip-review-wait-range-ratings-arent-everything_gallery-1#100701707">
<img class="fitfill" src="https://images.hgmsites.net/sml/2019-audi-e-tron_100701707_s.jpg" alt="2019 Audi E-tron road-trip review: Wait, range ratings aren’t everything?" /> </a>
<a href="/pictures/1123243_2019-audi-e-tron-road-trip-review-wait-range-ratings-arent-everything_gallery-1#100701707">
<span>2019 Audi E-tron road-trip review: Wait, range ratings aren’t everything?</span>
</a>
</div>

</li>
<li id="slide-5" class="slides">
<div class="photo_gallery">
<a class="image-link" href="/pictures/1123270_corsa-e-electric-hatchback-is-part-of-opels-first-move-independent-of-gm_gallery-1#100702160">
<img class="fitfill" src="https://images.hgmsites.net/sml/2020-opel-corsa-e_100702160_s.jpg" alt="Corsa-e electric hatchback is part of Opel's first move independent of GM" /> </a>
<a href="/pictures/1123270_corsa-e-electric-hatchback-is-part-of-opels-first-move-independent-of-gm_gallery-1#100702160">
<span>Corsa-e electric hatchback is part of Opel's first move independent of GM</span>
</a>
</div>

</li>
</ul>
</div>
<div id="gallery-navigation">
<div id="button_left" class="prev">&#171;</div>
<div id="button_text"><span>1</span> of <span>5</span></div>
<div id="button_right" class="next">&#187;</div>
<br class="clear" />
</div>
</div>
</div>
<script>
    $("#gallery-slide .image-link img").imgFitFill({mode:'fill'});// this will work only for the first image(which is visible)
    $('#gallery-slide').jCarouselLite({
   
        pauseOnHover: true,
        visible: 1,
        speed: 500,
        circular: true,
        easing: "easeInOutExpo",
        afterEnd: function (a) {
            var slideId = a.attr('id');
            slideNum = parseInt(slideId.substring(slideId.length - 1)); // slide-2
            if (slideNum > numSlides) {
                slideNum = 1;
            }
            if (slideNum < 1) {
                slideNum = numSlides;
            }
            $("#button_text").html('<span>'+slideNum +'</span>'+ " of <span>"+numSlides+"</span>");
            //$(".image-link img").imgFitFill({mode:'fill'});
        },
        btnNext: '#gallery-carousal-inner div.next',
        btnPrev: '#gallery-carousal-inner div.prev',
        btnEvent: 'click'
    });
</script>

<div id="ad-3" class="ad ad-t-r" style="max-width: 300px; max-height: auto">
<script>
                $(function () {
                    googletag.cmd.push(function() {
                        googletag.display('ad-3');                        for (var i = gptadslots.length; i--;) {
                             var curSlot = gptadslots[i];
                             if ( curSlot.getSlotElementId() === 'ad-3') {
                                googletag.pubads().refresh([curSlot]);
                             }
                        }                    });
                });
            </script> </div>
</div>

<br clear="all" />
</div>
</div>
</div>

<div id="popup-email-subscribe" style="display:none">
<div id="popup-newsletter-header">
<img src="/images/gcr/mailchimp_popup_logo.png" />
</div>
<div class="email-subscribe-text">
<span class="subtext-one">Get the Web's best green cars newsletter!</span>
<span class="subtext-two">We'll email you the latest in green car news every day.</span>
</div>
<form method="post" id="popup-subscription-form" action="/blocks/mail-chimp-email-subscription/subscribeEmail">
<input type="text" onblur="if(this.value == '') { this.value = 'Enter your email address'; }" onfocus="if(this.value =='Enter your email address') { this.value = ''; }" class="email-fld" value="Enter your email address" name="email">
<div id="footer-signup" class="mailchimp-signup stdButton">Subscribe</div>
</form>
<p class="thanks-msg"></p>
<p class="msg"></p>
<span class="error-msg"></span>
</div>
<script>
    $(".car-compare-table a.image-link img.fitfill").imgFitFill({mode:'fill'});
    //TCC-5748 make top banner ad sticky for 2 sec. once user scrolls past the breadcrumbs
    // FIXME Temporarily disable stick ads on MA/GCR blog post pages
    var $topAd = $('#masterhead-adblock');
    $('#sub-header').waypoint({
        handler: function (direction) {
            if (direction === 'down') {
                $topAd.addClass('adfixed');
                setTimeout(function () {
                    $topAd.removeClass('adfixed')
                }, 1500);
                this.destroy();
            }
        },
        offset: 20
    });
</script>

<div class="FooterMore">
<h3 class="MoreTitle">More from High Gear Media</h3>
<div class="clear">&nbsp;</div>
<ul>
<li class="FooterMoreColumn  first">
<a href="//www.motorauthority.com/" title="Motor Authority"><img src="/images/logo-MA-208x35.jpg" /></a>
<ul>
<li>
<a class="image-link" href="//www.motorauthority.com/news/1123191_2021-chevrolet-bolt-ev-based-crossover-spy-shots-and-video" title="2021 Chevrolet Bolt EV-based crossover spy shots and video">
<img title="2021 Chevrolet Bolt EV-based crossover spy shots and video" class="fitfill" src="https://images.hgmsites.net/sml/2021-chevrolet-bolt-ev-based-crossover-spy-shots--image-via-s-baldauf-sb-medien_100701630_s.jpg" alt="2021 Chevrolet Bolt EV-based crossover spy shots - Image via S. Baldauf/SB-Medien" /> </a>
 <a href="//www.motorauthority.com/news/1123191_2021-chevrolet-bolt-ev-based-crossover-spy-shots-and-video">
2021 Chevrolet Bolt EV-based crossover spy shots and video </a>
</li>
<li>
<a class="image-link" href="//www.motorauthority.com/news/1123287_mercedes-gla-spied-ferrari-supercar-teased-acura-nsx-type-r-rumored-car-news-headlines" title="Mercedes GLA spied, Ferrari supercar teased, Acura NSX Type R rumored: Car News Headlines">
<img title="Mercedes GLA spied, Ferrari supercar teased, Acura NSX Type R rumored: Car News Headlines" class="fitfill" src="https://images.hgmsites.net/sml/2021-mercedes-benz-gla-spy-shots--image-via-s-baldauf-sb-medien_100702234_s.jpg" alt="2021 Mercedes-Benz GLA spy shots - Image via S. Baldauf/SB-Medien" /> </a>
<a href="//www.motorauthority.com/news/1123287_mercedes-gla-spied-ferrari-supercar-teased-acura-nsx-type-r-rumored-car-news-headlines">
Mercedes GLA spied, Ferrari supercar teased, Acura NSX Type R rumored: Car News Headlines </a>
</li>
<li>
<a class="image-link" href="//www.motorauthority.com/news/1029948_650-horsepower-acura-nsx-type-r-headed-for-2019-tokyo-motor-show" title="650-horsepower Acura NSX Type R headed for 2019 Tokyo Motor Show?">
<img title="650-horsepower Acura NSX Type R headed for 2019 Tokyo Motor Show?" class="fitfill" src="https://images.hgmsites.net/sml/2019-acura-nsx-gt3_100675298_s.jpg" alt="2019 Acura NSX GT3 Evo race car" /> </a>
<a href="//www.motorauthority.com/news/1029948_650-horsepower-acura-nsx-type-r-headed-for-2019-tokyo-motor-show">
650-horsepower Acura NSX Type R headed for 2019 Tokyo Motor Show? </a>
</li>
</ul>
</li>
<li class="FooterMoreColumn ">
<a href="//www.thecarconnection.com/" title="The Car Connection"><img src="/images/logo-TCC-208x35.jpg" /></a>
<ul>
<li>
<a class="image-link" href="//www.thecarconnection.com/news/1123283_many-ride-share-cars-have-open-safety-recalls" title="Many ride-share cars have open safety recalls">
<img title="Many ride-share cars have open safety recalls" src="https://static.hgmsites.net/images/cache/uber-driver-photo-by-uber_100537825_120x80.jpg" alt="Uber driver (photo by Uber)" width="120" height="80" /> </a>
<a href="//www.thecarconnection.com/news/1123283_many-ride-share-cars-have-open-safety-recalls">
Many ride-share cars have open safety recalls </a>
</li>
<li>
<a class="image-link" href="//www.thecarconnection.com/news/1123285_fiat-chrysler-renault-merger-ferrari-hybrid-supercar-teased-byton-readies-its-suv-whats-new-the-car-connection" title="Fiat Chrysler-Renault merger, Ferrari hybrid supercar teased, Byton readies its SUV: What's New @ The Car Connection">
<img title="Fiat Chrysler-Renault merger, Ferrari hybrid supercar teased, Byton readies its SUV: What's New @ The Car Connection" class="fitfill" src="https://images.hgmsites.net/sml/renault-logo-and-fiat-chrysler-automobiles-logo_100702232_s.jpg" alt="Renault logo and Fiat Chrysler Automobiles logo" /> </a>
<a href="//www.thecarconnection.com/news/1123285_fiat-chrysler-renault-merger-ferrari-hybrid-supercar-teased-byton-readies-its-suv-whats-new-the-car-connection">
Fiat Chrysler-Renault merger, Ferrari hybrid supercar teased, Byton readies its SUV: What's New @ The Car Connection </a>
</li>
<li>
<a class="image-link" href="//www.thecarconnection.com/news/1123278_fiat-chrysler-proposes-mega-merger-with-renault-in-auto-industry-shakeup" title="Fiat Chrysler proposes mega-merger with Renault in auto industry shakeup">
<img title="Fiat Chrysler proposes mega-merger with Renault in auto industry shakeup" class="fitfill" src="https://images.hgmsites.net/sml/renault-logo-and-fiat-chrysler-automobiles-logo_100702232_s.jpg" alt="Renault logo and Fiat Chrysler Automobiles logo" /> </a>
<a href="//www.thecarconnection.com/news/1123278_fiat-chrysler-proposes-mega-merger-with-renault-in-auto-industry-shakeup">
Fiat Chrysler proposes mega-merger with Renault in auto industry shakeup </a>
</li>
</ul>
</li>
</ul>
</div>
<div class="clear">&nbsp;</div>


<div class="Footer">

<div class="LogoColumn">
<img src="/images/gcr/FootLogo.gif" alt="Green Car Reports" title="Green Car Reports" />
</div>
<div class="FooterLinkColumn">
<ul>
<li class="Title"><a href="/news">News</a></li>
<li class="Title"><a href="/news/first-drives">Reviews</a></li>
<li class="Title"><a href="/news/buying-guides">Buying Guides</a></li>
<li class="Title"><a href="/rss">RSS Feed</a></li>
</ul>
</div>
<div class="FooterLinkColumn">
<ul>
<li class="Title"><a href="/news/electric-cars">Electric</a></li>
<li class="Title"><a href="/news/gas-mileage">Gas Mileage</a></li>
<li class="Title"><a href="/new-cars">Car Types</a></li>
</ul>
</div>
<div class="FooterLinkColumn">
<ul>
<li class="Title TitleTight">Company</li>
<li><a href="/aboutus">About Us</a></li>
<li><a href="/contactus">Contact Us</a></li>
<li><a href="https://ibauto.tumblr.com/">Press</a></li>
<li><a href="https://www.internetbrands.com/ibterms/">Legal</a></li>
<li><a href="https://www.internetbrands.com/ibterms/supplementalcarrelatedterms/">Disclaimer</a></li>
<li><a href="https://www.internetbrands.com/privacy/privacy-highlights.html?site=internetbrandsauto.com">Privacy Policy</a></li>
<li><a href="https://wrightsmedia.com/reprints/index.cfm?magid=3533" target="_blank" rel="nofollow">Reprints</a></li>
</ul>
</div>
<div class="FooterLinkColumn FooterSocialColumn">
<ul>
<li class="Title">Follow Us</li>
<li class="footer-social"><a href="https://www.twitter.com/GreenCarReports" title="Follow us on twitter" target="_blank"><img src="/images/gcr/ico4.jpg" alt="Twiiter"></a></li>
<li class="footer-social"><a href="https://www.facebook.com/GreenCarReports" title="Like us on Facebook" target="_blank"><img src="/images/gcr/ico3.jpg" alt="Facebook"></a></li>
</ul>
<div class="clear"></div>
<div class="footer-mobile"></div>
</div>

<div class="clear">&nbsp;</div>
</div>


<div class="FooterCopyright">
&copy; 2019 MH Sub I, LLC.
All Rights Reserved.
Stock photography by <a href="//www.izmocars.com/">izmostock</a>.
Read our <a href="//www.internetbrands.com/privacy/cookie-policy.html">Cookie Policy</a>.</div>

<script>
    $(".FooterMoreColumn .image-link img.fitfill").imgFitFill({mode:'fill'});
    $(hgm.addMobileSiteButton);
</script>
</div>
</div>

<script type="text/javascript">
    
                var disqus_shortname = 'greencarreports';

                (function() {
                    var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
                    dsq.src = '//' + disqus_shortname + '.disqus.com/count.js';
                    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
                }());    
</script>
<script type="text/javascript">
    

    (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
    new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
    j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
    '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
    })(window,document,'script','dataLayer','GTM-NQ2JMG');
    
</script>
<script type="text/javascript" src="/js_cache/547638.js"></script>
<script type="text/javascript">
var _sf_startpt = window._sf_startpt || (new Date()).getTime();
var _sf_async_config={uid:22002,domain:"greencarreports.com"};
_sf_async_config.authors = 'Eric C. Evarts';
_sf_async_config.sections = 'news';
(function() {
  function loadChartbeat() {
    window._sf_endpt=(new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('async', 'true');
    e.setAttribute('src', (("https:" == document.location.protocol) ? "https://a248.e.akamai.net/chartbeat.download.akamai.com/102508/" : "http://static.chartbeat.com/") + "js/chartbeat.js");
    document.body.appendChild(e);
  }
  var oldonload = window.onload;
  window.onload = (typeof window.onload != 'function') ?
     loadChartbeat : function() { oldonload(); loadChartbeat(); };
})();
</script>
<script>
    dataLayer.push({'exelate_query':'p=258&g=81&j=0&pageurl=%2Fnews%2F1123290_byton-details-gm-chargers-opel-electric-what-readers-want-in-fast-charging-todays-car-news%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%253A%2BTheCarConnection-CarReviews%2B%2528The%2BCar%2BConnection%2B-%2BCar%2BReviews%2529&sitename=greencarreports&tag1=news&tag2=today-in-car-news&segment=misc'});
</script>


<div id="ad-X" class="ad ad-t-r" style="max-width: 1px; max-height: auto">
<script>
                $(function () {
                    googletag.cmd.push(function() {
                        googletag.display('ad-X');                        for (var i = gptadslots.length; i--;) {
                             var curSlot = gptadslots[i];
                             if ( curSlot.getSlotElementId() === 'ad-X') {
                                googletag.pubads().refresh([curSlot]);
                             }
                        }                    });
                });
            </script> </div>



<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"fcb635eb66","applicationID":"135926744","transactionName":"MgcAYUMDDUFWAkJaDAtNI1ZFCwxcGBFXVAYWTQBZXgVOQlgSQh4CFxYLVl0HTFtZBVNL","queueTime":0,"applicationTime":188,"atts":"HkAXFwsZHh4VABQJGBgf","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
